Bilgisayar yenileme veya değiştirme sırasında Windows 7 dağıtım başarısız

ÖNEMLİ: Bu makale, Microsoft Makine Çevirisi Düzenleme yazılımı tarafından tercüme edilmiş olup, yüksek olasılıkla profesyonel bir çevirmen yerine CTF teknolojisi kullanılarak, Microsoft Topluluğu tarafından düzenlenmiştir. Microsoft, Bilgi Bankamız içindeki tüm makaleleri kendi dilinizde okuyabilmeniz için size hem profesyonel çevirmenler tarafından tercüme edilen hem de makine tarafından tercüme edildikten sonra Topluluk tarafından kontrol edilen makaleler sunar. Bununla birlikte, makine tarafından tercüme edilen, hatta Topluluk tarafından kontrol edilen bir makale bile her zaman mükemmel dil kalitesinde olmayabilir. Makalede dilinizi konuşan yabancı birisinin yapabileceği türden sözcük, söz dizimi veya dilbilgisi hataları bulunabilir. Microsoft, içeriğin hatalı tercümesinin veya müşterilerimiz tarafından kullanımının doğurabileceği olası yanlış anlamalar, hatalar veya zararlardan sorumlu değildir. Öte yandan Microsoft, Makine Çevirisi Düzenleme işlemini geliştirmek amacıyla Makine Çevirisi Düzenleme yazılımını ve araçlarını sık sık güncelleştirmektedir.

Makalenin İngilizcesi aşağıdaki gibidir: 3084782
Belirtiler
Yenileme veya değiştirme bir bilgisayar Windows 7 dağıtımı başarısız olur. Bu durumda, aşağıdaki hata iletisini alabilirsiniz:

DismApi.DLL bilgisayarınızda eksik olduğundan program başlatılamıyor. Bu sorunu gidermek için programı yeniden yüklemeyi deneyin.
Neden
Windows 7 tabanlı bilgisayarlarda Loadstate.exe Bileşen bağımlılıkları eksik olduğundan, bu sorun oluşur.
Çözüm
Bu sorunu gidermek için aşağıdaki yöntemlerden birini kullanın.

Yöntem 1

Windows değerlendirme ve Dağıtım Seti (Windows ADK) yüklediğinizde, Windows Kullanıcı Durumu Geçiş Aracı (USMT) yanı sıra dağıtım araçları özelliği seçin. Daha sonra Scanstate.exe Dağıtım Araçları komut isteminden çalıştırın.

Yöntem 2

Loadstate çalışıyor sistemde Windows ADK yükleyemezseniz, başka bir sistemde Windows 10 ADK yükleyin (ve dağıtım araçları özelliği de yüklediğinizden emin olun). Daha sonra aşağıdaki adımları izleyin:

  1. Aşağıdaki yolları ADK yüklü olduğu sistemde uygun mimari klasöründen bulun:

    • X 64 bilgisayarlar

      C:\Program Files (x 86) \Windows Kits\10\Assessment ve dağıtım Kit\Deployment Tools\amd64\DISM

      C:\Program Files (x 86) \Windows Kits\10\Assessment ve dağıtım Kit\Deployment Tools\x86\DISM
    • X 32 için bilgisayarlar

      C:\Program Files\Windows Kits\10\Assessment ve dağıtım Kit\Deployment Tools\amd64\DISM

      C:\Program Files\Windows Kits\10\Assessment ve dağıtım Kit\Deployment Tools\x86\DISM
  2. Aşağıdaki ikili dosyalar, Loadstate.exe içeren Adım 1'den eşleşen mimarisi klasörüne kopyalayın:

    • dismapi.dll
    • api-MS-Win-downlevel-Advapi32-L1-1-1.dll
    • api-MS-Win-downlevel-Kernel32-L1-1-0.dll
    • api-MS-Win-downlevel-Kernel32-L2-1-0.dll
    • api-MS-Win-downlevel-Ole32-L1-1-1.dll
    • api-MS-Win-downlevel-User32-L1-1-1.dll
    • api-MS-Win-downlevel-Version-L1-1-0.dll
  3. System Center Configuration Manager'ı kullanıyorsanız, USMT paketi içeren dağıtım noktalarında USMT paketini güncelleştirin.
Örneğin, x 64 için paketi güncelleştirmek isterseniz, dağıtımları, adım 2 aşağıdaki klasörden dosyaları kopyalayın:

C:\Program Files (x 86) \Windows Kits\10\Assessment ve dağıtım Kit\Windows Setup\amd64\Sources
Dosyaları aşağıdaki klasöre yapıştırın:
C:\Program Files (x 86) \Windows Kits\10\Assessment ve dağıtım Kit\User durum MigrationTool\amd64

Uyarı: Bu makalenin çevirisi otomatik olarak yapılmıştır

Özellikler

Makale No: 3084782 - Son İnceleme: 01/11/2016 17:03:00 - Düzeltme: 3.0

Windows 7 Enterprise, Windows 7 Professional, Windows 7 Ultimate

  • kbexpertiseadvanced kbsurveynew kbtshoot kbmt KB3084782 KbMttr
Geri bildirim