Microsoft Entra ID'de bir B2C dizinini silmeye çalıştığınızda hata: '<contoso>' silinemiyor

Bu makalede, Microsoft Entra ID'da bir B2C dizinini silmeye çalıştığınızda bir hata oluşması sorunu açıklanır.

Orijinal ürün sürümü: Microsoft Entra ID
Özgün KB numarası: 3112170

Belirtiler

Microsoft Entra bir ortamda bir B2C dizini ayarlayıp silmeye çalışırsınız. Ancak, aşağıdaki hata iletisini alırsınız:

'<contoso>' silinemiyor
Aşağıdaki sorunlarda dizinin silinmesi engellenir:
Dizin, bir kullanıcı veya yönetici tarafından eklenen bir veya daha fazla uygulama içeriyor

Neden

Mevcut B2C uygulama hizmet sorumluları (örneğin, CPIM, Ibiza Portalı ve SSPR) silme işlemini engelliyorsa bu sorun oluşur.

Çözüm

Bu sorunu çözmek için Azure portal kullanın.

1. Adım: Azure AD B2C Panosu'nda listelenen tüm uygulamaları silme

Bunu yapmak için şu adımları uygulayın:

  1. Azure AD B2C dizinine erişimi olan bir yönetici olarak Azure portal oturum açın.

  2. Sağ üst köşedeki görünen adınızı seçin ve ardından B2C dizininiz olan dizini seçin.

    Not

    Yalnızca bir dizininiz varsa, Azure AD B2C dizininiz zaten seçilir.

  3. Azure AD B2C dikey penceresini bulmak için, sol alt köşedeki Diğer Hizmetler (>) düğmesini seçin ve "B2C" araması yapın.

  4. Azure AD B2C'yi seçin.

  5. Tüm Ayarlar'ı ve ardından Uygulamalar'ı seçin.

    Uygulamalar ayarının ekran görüntüsü.

  6. Tüm uygulamaları silin. Bunu yapmak için uygulamayı seçin, Özellikler'i ve ardından Sil düğmesini seçin.

    Bir uygulamanın nasıl silineceği ekran görüntüsü.

2. Adım: Azure AD B2C kiracısını silme

Bunu yapmak için şu adımları uygulayın:

  1. Azure AD B2C dizininde Azure portal Microsoft Entra ID dikey penceresini bulun ve seçin.

  2. Genel Bakış menüsünde Dizini Sil'i seçin.

  3. Portaldaki yönergeleri izleyin.

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.