Şu anda çevrimdışısınız; İnternet'in yeniden bağlanması bekleniyor

Visual Basic Yükseltme Sihirbazı nasıl kullanılır?

ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.

Makalenin İngilizcesi aşağıdaki gibidir: 317885
Özet
Bu adım adım makalede basit açıklar Visual Basic 6.0 uygulamasını Visual Basic ve Visual Basic application sonra yükseltme .net ya da Visual Basic 2005, Visual Studio .net ya da Visual Studio 2005'teki Visual Basic Yükseltme Sihirbazı'nı kullanarak.

Not Visual Basic .net Yükseltme Sihirbazı Visual dahil Studio .net Professional.

Not Visual Basic 2005 Yükseltme Sihirbazı'nı Visual Basic önceki sürümlerden geliştirmiştir. back to the top

Gereksinimleri

Aşağıdaki öğeler, önerilen donanım, yazılım açıklayan, ağ altyapısı, beceriler, bilgi ve hizmet paketlerini şunları yapmanız gerekir:
  • Microsoft Windows 2000 Professional (veya sunucu) veya Microsoft Windows xp Professional (veya sunucu) ile .net Framework yüklü
  • Microsoft Visual Basic 6.0
  • Microsoft sql Server 7.0 veya sonraki sürümleri ile Northwind Veritabanı, uygun izinleri ve kullanıcı kimliği ve parola değerleri
Önceki bilgi gereklidir:
  • Kullanarak uygulamaları oluşturma hakkında genel bilgi Visual Basic 6.0
back to the top

Visual Basic Yükseltme Sihirbazı'nı kullanma

Aşağıdaki adımlar basit bir Visual Basic oluşturulacağını gösterir. 6.0 uygulamasını ve sonra yükseltme kullanarak uygulama Visual Basic .net ya da Visual Basic 2005 Visual Basic Yükseltme Sihirbazı, Visual Studio .net ya da Visual Studio 2005'te:
  1. Başlat menüsünde, Programlar' ın, Microsoft Visual Studio 6. 0' ın üzerine gelin ve Microsoft Visual Basic 6. 0' ı tıklatın.
  2. New Project iletişim kutusunda Standart exe dosyası' nı tıklatın ve ardından ' ı tıklatın.
  3. Bu uygulamada ilk formu almak için ado kullanan bir Recordset ' in ve Recordset'i Microsoft hiyerarşik FlexGrid içinde görüntüler Denetim. Form1'in özellikleri iletişim kutusunda adı alanına yazın.frmADO.
  4. Araç kutusu açık değilse, View menüsünden Toolbox' ı tıklatın.
  5. Araç kutusundan, bir MSHFlexGrid formda görüntülenmemesini çoğu formu doldurur. Yeterli boşluk bırakın bir düğme yerleştirmek için formun alt kısmında.

    Not: araç kutusundaki MSHFlexGrid simgesini görmüyorsanız, onu Toolbox'a ekleyin. Sağ tıklatın Araç, Bileşenler' i tıklatın. Bileşenleri iletişim kutusunda Microsoft hiyerarşik FlexGrid Control 6.0 (oledb) kullanılabilir bileşenler listesinden seçmek için tıklatın ve sonra Tamam' ı tıklatın.
  6. KomutDüğmesi Toolbox'dan form MSHFlexGrid altına yerleştirin. Özellikler iletişim kutusunun başlık alanına yazın TAMAM.
  7. MADOsağ tıklatın ve Kod Görüntüle'yitıklatın. Veritabanı bağlantısı oluşturur aşağıdaki kodu ekleyin ve Tüm Northwind veritabanının Ürünler tablosundaki verileri içeren bir Recordset'i döndürür.

    Not: Aşağıdaki örnek kodu değiştirmeniz gerekir Kullanıcı kimliği =<username></username> ve Parola =<strong password=""></strong> doğru değerler için. Emin olun ve kullanıcı kimliği veritabanı üzerinde bu işlemi gerçekleştirmek için uygun izinlere sahip olur.
    Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub					
  8. Formu kaydetmek için ctrl + s tuşlarına basın. Dosya menüsünde Farklı Kaydet'itıklatın. Farklı Kaydet iletişim kutusunda, Kaydet' i tıklatın.
  9. Project Explorer'da Project1sağ tıklatın, Ekle' yi tıklatın ve sonra formutıklatın. ' ı tıklatın.
  10. Özellikler iletişim kutusunda adı alanına yazın. frmClipboard.
  11. Toolbox'dan form üzerinde bir metin kutusu yerleştirin. Metin alanına yazın Hızlı kahverengi tilki tembel Atlanan köpek.
  12. KomutDüğmesiTextboxaltına yerleştirin. Özellikler iletişim kutusunun başlık alanına yazın Kopyala.
  13. İkinci KomutDüğmesi forma yerleştirin. Özellikler iletişim kutusunun başlık alanına yazın Yapıştır.
  14. FrmClipboardsağ tıklatın ve Kod Görüntüle'yitıklatın. Yapıştır KomutDüğmesi için aşağıdaki kodu olaylar'ı tıklatın. Bu kod kullanmaktadır Pano get nesne ve metin yapıştırın:
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd Sub					
  15. Formu kaydetmek için ctrl + s tuşlarına basın.
  16. Gereksinim duyduğunuz son uygulamanın ana form formdur. Project Explorer'da Project1sağ tıklatın, Ekle' yi tıklatın, Form' u tıklatın ve ardından ' ı tıklatın.
  17. Özellikler iletişim kutusunda adı alanına yazın. frmMain.
  18. Araç kutusundan, KomutDüğmesi frmMain forma yerleştirin. Özellikler iletişim kutusunun başlık alanına yazın ADO.
  19. İkinci KomutDüğmesi forma yerleştirin. Özellikler iletişim kutusunun başlık alanına yazın Pano.
  20. FrmMainsağ tıklatın ve Kod Görüntüle'yitıklatın. Aşağıdaki kod KomutDüğmesi için Yapıştır olaylar için iki form göster:
    Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub					
  21. Formu kaydetmek için ctrl + s tuşlarına basın.
  22. Solution Explorer'da Project1sağ tıklatın ve Project1 özellikler' i tıklatın. Başlangıç nesnesi alanı frmMain' ı tıklatın ve sonra Tamam' ı tıklatın.
  23. Proje menüsünde ado bileşeni için bir başvuru eklemek için Başvurular' ı tıklatın. Kullanılabilir Başvurular listesinde, Microsoft ActiveX Data Object kitaplığı (herhangi bir sürüm 2.0 veya sonraki sürümünü yapacağını) seçmek için tıklatın. Tamam' ı tıklatın.
  24. Dosya menüsünden projeyi derlemek için Project1.exe yap'ıtıklatın. Proje yap iletişim kutusunda Tamam ' ı tıklatın (varsayılan dosya adını kabul edin).
  25. Uygulama hata ayıklama modunda çalıştırmak için F5 tuşuna basın.

    Not: doğrulamak gerekmez eski Visual Basic yükseltme yapmadan önce uygulama herhangi bir sorunla karşılaşmadan çalışır.
  26. Visual Basic geliştirme ortamını kapatın. AT komut istemi projeye değişiklikleri kaydetmek için Evet' i tıklatın. Projeyi kaydedin ve varsayılan adı kullanın.
  27. Başlat menüsünde, Programlar' ın, Microsoft Visual Studio.netiçin işaretleyin ve Microsoft Visual Studio.net' i tıklatın.
  28. Başlangıç Sayfası'nda Açık projeyitıklatın. Visual Basic 6.0 projeyi içeren klasörü bulun. Şimdi (genelde C:\Program Files\Microsoft Visual oluşturduğunuz dosya Studio\VB98). Project1.vdp' ı tıklatın ve ardından ' ı tıklatın.
  29. Visual Studio .net eski Visual olduğunu algılar. Temel Proje ve Visual Basic Yükseltme Sihirbazı'nı başlatır. Sihirbaz görüntüler bir Aşağıdaki adımlarda her adımı siz açıklaması devam sıra:
    • Varolan proje içine yeni bir proje yaratın yükseltilir.
    • Form dosyalarını ve sınıf dosyaları yeni dosyaya kopyalayın Proje.
    • Bileşenlerini listeleyen bir yükseltme raporu sağlar başarıyla yükseltilmiş proje ve yükseltme bileşenleri başarılı bir şekilde.

  30. Yükseltme işlemi başlar kadar sonraki her adımı tıklatın. , Yükseltme, yaklaşık olarak 30-60 saniye sürer.
  31. Solution Explorer'da, _UpgradeReport.htmçift tıklatın. Bu rapor, yükseltme işleminin sonuçlarını görüntüler. Dikkat tüm herhangi bir sorunla karşılaşmadan yükseltilmiş frmClipboard dışında biçimleri.
  32. FrmClipboard.vb sorunları görüntülemek için genişletin. Clipboard.SetText ve GetText doğru yükseltme değil. Sorunları düzeltmek nasıl görüntülemek için Açıklama bağlantılar'ı tıklatın.
  33. Solution Explorer'da, tüm formları tutulan dikkat edin. .frm için gelen özgün adlarını, ancak dosya uzantısı değiştirildiğinde . vb.
  34. Başvurular' ı genişletin. Tüm gerekli bileşenleri başvuran Not eski Visual Basic ve ado bileşenleri kullanmak için eklendi otomatik olarak.
  35. Biçimlerden birini sağ tıklatın ve Kod Görüntüle'yitıklatın. Yükseltme desteği bölgeyi genişletin. Bu alanda, Visual Studio .net ya da Visual Studio 2005 nasıl yapılandırıldığı görüntülenir. çeşitli özellikler ve yükseltilmiş kod desteklemek için değişkenleri.
  36. Solution Explorer'da, frmClipboard.vbsağ tıklatın ve Kod Görüntüle'yitıklatın. Yorumları vermedi önündeki satırlara yerleştirilmiş olduğunu göz önünde bulundurun Yükseltme değil.
  37. Command1_Click ve Command2_Click olayları aşağıdaki gibi değiştirin:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click        Clipboard.SetDataObject(Text1.Text)    End Sub    Private Sub Command2_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command2.Click        Text1.SelectedText = _            Clipboard.GetDataObject().GetData(GetType(System.String))    End Sub					
back to the top

Kod listelerinin tamamlanması

Kod listesi (frmADO.frm) tamamlayın

Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub				
back to the top

Kod listesi (frmClipboard.frm) tamamlayın

Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd SubComplete Code Listing (frmMain.frm)Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub				
back to the top

Uygulamanın çalıştığını doğrulayın

  1. Uygulamayı başlatmak için F5 tuşuna basın.
  2. Komut projeyi kaydetmek için Tamam' ı tıklatın.
  3. Form1'de ado' ı tıklatın. Kılavuz verileri içeren bir form belirir. Bu kapatma formu.
  4. 5 Form1'Pano ' ı tıklatın.
  5. Kopyala' yı tıklatın.
  6. Başında metin kutusuna ekleme noktasını yerleştirin. metni Yapıştır' ı tıklatın. Yapıştırılan metin görmeniz gerekir.
back to the top

Sorun giderme

Visual Basic .net önceki sürümlerinden gelen önemli bir değişme olur Visual Basic. Birçok proje için bazı kapsamlı hazırlık iş tavsiye edilir yükseltmeden önce. Olabilecek bilgiler için aşağıdaki belgeye bakın daha kolay bir şekilde yükseltin yardımcı olur:
back to the top

BAŞVURULAR

Daha fazla bilgi için aşağıdaki Microsoft Developer başvurun Network (msdn) makaleleri: back to the top

Uyarı: Bu makalenin çevirisi otomatik olarak yapılmıştır

Özellikler

Makale No: 317885 - Son İnceleme: 07/02/2012 05:31:00 - Düzeltme: 1.0

Microsoft Visual Basic 2005, Microsoft Visual Basic .NET 2003 Standard Edition, Microsoft Visual Basic .NET 2002 Standard Edition, Microsoft Visual Basic 6.0 Professional Edition, Microsoft .NET Framework 1.1

  • kbvs2005swept kbvs2005applies kbmigration kbhowtomaster kbmt KB317885 KbMttr
Geri bildirim