Şu anda çevrimdışısınız; İnternet'in yeniden bağlanması bekleniyor

Microsoft Dynamics GP içinde ek boşluk oluşturmadan grafik satın alma siparişi raporları için kalem açıklamaları ekleme

ÖNEMLİ: Bu makale, Microsoft Makine Çevirisi Düzenleme yazılımı tarafından tercüme edilmiş olup, yüksek olasılıkla profesyonel bir çevirmen yerine CTF teknolojisi kullanılarak, Microsoft Topluluğu tarafından düzenlenmiştir. Microsoft, Bilgi Bankamız içindeki tüm makaleleri kendi dilinizde okuyabilmeniz için size hem profesyonel çevirmenler tarafından tercüme edilen hem de makine tarafından tercüme edildikten sonra Topluluk tarafından kontrol edilen makaleler sunar. Bununla birlikte, makine tarafından tercüme edilen, hatta Topluluk tarafından kontrol edilen bir makale bile her zaman mükemmel dil kalitesinde olmayabilir. Makalede dilinizi konuşan yabancı birisinin yapabileceği türden sözcük, söz dizimi veya dilbilgisi hataları bulunabilir. Microsoft, içeriğin hatalı tercümesinin veya müşterilerimiz tarafından kullanımının doğurabileceği olası yanlış anlamalar, hatalar veya zararlardan sorumlu değildir. Öte yandan Microsoft, Makine Çevirisi Düzenleme işlemini geliştirmek amacıyla Makine Çevirisi Düzenleme yazılımını ve araçlarını sık sık güncelleştirmektedir.

Makalenin İngilizcesi aşağıdaki gibidir: 906709
Özet
Bu makalede, raporlar rapor yazan açın ve rapor bölümleri değiştirmek nasıl açıklanır. Bu makalede ayrıca yeni hesaplanan alanlar oluşturmak nasıl, nasıl varolan hesaplanan alanları değiştirin ve rapor düzenini ayarlamak nasıl açıklanır.
GİRİŞ
Bu makalede, Microsoft Dynamics GP ve Microsoft Business Solutions - Great Plains ek boşluk oluşturmadan grafik satın alma siparişi raporları için kalem açıklamaları ekleme işlemi açıklanmaktadır.
Daha fazla bilgi
Not: Bu adımları yalnızca Üretici numaraları satın alan dahil etmek istemiyorsanız çalışır.

Yedekleme ve rapor açın

  1. Reports.dicfile yedekleme herhangi bir rapor değiştirdiyseniz. Herhangi bir rapor değiştirmediyseniz, 2. adıma geçin.

    Seek Reports.dic dosya için şu adımları izleyin:
    1. Araçlar menüsünde, Kur', sistemi' ne gelin ve Başlatma dosyası Düzenle'yitıklatın.
    2. Bir sistem parolası girmeniz istenirse, parolanızı yazın.
    3. Microsoft Dynamics GP veya Great Plainstıklatın. Reports.dic dosyasının yolunu Raporlar kutusunda görünür.
    Not: Areport önceden değiştirdiyseniz yalnızca Reports.dic dosyası bulunmaktadır.
  2. Raporu yazan başlatın ve sonra uygun yöntemi kullanın:
    • Microsoft Dynamics GP 10.0 Microsoft Dynamics GP' ı tıklatın, Araçlar' ın üzerine, Özelleştir' in üzerine ve Rapor yazıcı' yı tıklatın.
    • Microsoft Dynamics GP 9.0 ve önceki sürümlerinde, Araçlar menüsünde Özelleştir ' in üzerine ve Rapor yazıcı' yı tıklatın.
  3. Microsoft Dynamics GP veya Great PlainsÜrün listesinde tıklatın, ve Tamam' ı tıklatın.
  4. Raporu yazanRaporlar' ı tıklatın.
  5. Özgün rapor sütununda, değiştirmek istediğiniz thepurchase sipariş raporu seçin.
  6. Raporları değiştirilen sütun için bir rapor eklemek için Ekle ' yi tıklatın.
  7. ' ı tıklatın ve sonraDüzen' i tıklatın.

Rapor bölümlerini değiştirme

  1. Araçlar menüsünde SectionOptionstıklatın.
  2. Ek altbilgi bölümünde Altbilgi seçenekleri iletişim kutusu açmak içinYeni'yi tıklatın.
  3. Altbilgi adı kutusuna yazın.SİP.
  4. Raporu tablosu listesinde,Satınalma siparişi satırı toplama Temp' ı tıklatın.
  5. Alan listesinde,Sipariş' i tıklatın.
  6. Tamam'a tıklayın.
  7. Ek altbilgi bölümündeYorum 1 altbilgitıklatın ve sonraKaldır' ı tıklatın.

    Altbilgi kaldırmak için istenirse, Evet'itıklatın.
  8. Ek altbilgi listesinde aşağıdaki altbilgi için 7 arasındaki adımları yineleyin:
    • Yorum 2 altbilgi
    • Yorum 3 altbilgi
    • Yorum 4 altbilgi

Hesaplanan alanları değiştirme

  1. Toolbox penceresi kaynak listesindeHesaplanan alanlar' ı tıklatın.
  2. SSuppressComment1' ı tıklatın ve sonra Hesaplanan alan tanımıiletişim kutusunu açmak için ' ı tıklatın.
  3. Koşulluİfadenin türü bölümünde tıklatın.

    Günün ifade yok etmek için istenirse, devam' ı tıklatın.
  4. İfade türü bölümünde,hesaplanan' ı tıklatın.
  5. TamsayıSonuç türü listesinde tıklatın.
  6. Sabitler.
  7. Tamsayıtürü listesinde tıklatın.
  8. Sabit alanına yazın0, Ekle' yi tıklatın ve sonraTamam' ı tıklatın.
  9. 1. adım adım 8 ile aşağıdaki hesaplanmış alan için yineleyin:
    • sSuppressComment2
    • sSuppressComment3
    • sSuppressComment4

Rapor düzenini ayarlayın

  1. Toolbox penceresi kaynak listesindeSatın açıklama' yı tıklatın.
  2. Yorum alanı Rapor düzeni iletişim kutusunuF3 bölümüne sürükleyin. Rapor alan seçenekleri iletişim kutusu görüntülenir. Girin1Dizi dizini alanına yazın.
  3. Toplam dörtYorum alan eklemek için adım 1 ve adım 2'yi yineleyin.
    Sorulduğunda, bir dizi indexfor için her alan, yazın 2 ikinci alan için yazın3 Üçüncü alan ve ardından yazın.1 Dördüncü alan için.
  4. F3 bölümündeComment4 alan rapor kenarına taşıyın.

    Not: Bu yorum alanı yazdırılan raporda görünmez. Ancak, bu yorum alan hesaplanan fieldwill çalışmak üzere kenar boşluğunda olmalıdır.
  5. Açıklama metni alanı Rapor düzeni iletişim kutusunuB bölümüne sürükleyin.
  6. Aşağıdaki alanları raporun kenar taşıyın:
    • Üretici madde numarası
    • Üretici
    • Madde açıklaması
  7. B bölümüne girin yorum linesthat en fazla sayısını sığacak rapor gövdesinde sufficientspace oluşturmak için sürükleyin.

    Örneğin, 10 satır ofcomments yazdırırsanız, B bölümünde 10 satır uzunluğunda olmalıdır.
  8. B bölümün tamamını occupythe için Açıklama metin alanı yeniden boyutlandırılır.
  9. Aşağıdaki metin alanlarınıH7 bölümden silin:
    • Üretici madde numarası
    • Üretici
    • Açıklama

İlk yeni hesaplanan alan oluşturma

  1. Toolbox penceresi kaynak listesinde,Hesaplanan alanlar' ı tıklatın ve sonraYeni' yi tıklatın.
  2. Hesaplanan alan tanımı iletişim kutusunda aşağıdaki ayarları belirleyin:
    • Adı: Yorum
    • İfade türü: koşullu
    • Sonuç türü: Tamsayı
  3. Koşullu deyimleralanı tıklatın.
  4. Alan listesinde tıklatın F3_LASTComment [1], Ekle' yi tıklatın.
  5. İşleçler bölümünde tıklatın<>.
  6. Sabitleri sekmesini tıklatın. Türü listesinde, String' i tıklatın ve sonraEkle' yi tıklatın.
  7. İşleçler bölümündeve' ı tıklatın.
  8. Alan listesindeki alanları sekmesinde, F3_LAST yorum [4],'ı tıklatın ve Ekle' yi tıklatın.
  9. İşleçler bölümünde='ı tıklatın.
  10. Sabitleri sekmesini tıklatın. Türü listesinde, String' i tıklatın ve sonraEkle' yi tıklatın.
  11. Gerçek durum alanı tıklatın.
  12. Tamsayısabitler sekmesinde,tür listesinde tıklatın. Sabit alanına yazın 1ve ardındanEkle'yitıklatın.
  13. Yanlış bir durum alanı tıklatın.
  14. Sabitler sekmesinde,sabit alanına yazın 0ve ardındanEkle'yitıklatın.

    Hesaplanmış alan, aşağıdaki benzer olmalıdır:
    Koşullu ifadeler: F3_LAST yorum [1] <> </>''' ve F3_LAST yorum [4] ='' '
    GERÇEK DURUM: 1
    YANLIŞ DURUMU: 0
  15. Tamam'a tıklayın.

İkinci yeni hesaplanan alan oluşturma

  1. Yeni'yi tıklatın.
  2. Hesaplanan alan tanımı iletişim kutusunda aşağıdaki ayarları belirleyin:
    • Adı: Comment2
    • İfade türü: koşullu
    • Sonuç türü: Tamsayı
  3. Koşullu deyimleralanı tıklatın.
  4. Kaynak listesinde,Satın alma açıklama' yı tıklatın. Alan listesinde,Açıklama' yı tıklatın ve sonra Ekle' yi tıklatın. Türü1 ne zaman bir ArrayIndex girmeniz istenir.
  5. İşleçler bölümünde tıklatın<>.
  6. Sabitleri sekmesini tıklatın. Türü listesinde, String' i tıklatın ve sonraEkle' yi tıklatın.
  7. Gerçek durum alanı tıklatın.
  8. Tamsayısabitler sekmesinde,tür listesinde tıklatın. Sabit alanına yazın 1ve ardındanEkle'yitıklatın.
  9. Yanlış bir durum alanı tıklatın.
  10. Sabitler sekmesinde,sabit alanına yazın 0ve ardındanEkle'yitıklatın.

    Hesaplanmış alan, aşağıdaki benzer olmalıdır:
    Koşullu ifadeler: POP_Comment.Comment[4] <> </>'''
    GERÇEK DURUM: 1
    YANLIŞ DURUMU: 0
  11. Tamam'a tıklayın.

Rapor bölümü seçeneklerini değiştirme

  1. Araçlar menüsünde SectionOptionstıklatın.
  2. Ek altbilgi bölümünde,Sipariş' i tıklatın ve ' ı tıklatın.
  3. Zaman alan IsEmpty Önle onay kutusunu seçmek için tıklatın. Hesaplanan alan listesinde,Açıklama' yı tıklatın.
  4. Tamam'a tıklayın.
  5. Hesaplanan alan listesinde gövde bölümünde Yorum 2,'ı tıklatın ve Tamam' ı tıklatın.

Raporunuzu kaydetmek

  1. Rapor düzeni iletişim kapatın.

    Değişiklikleri kaydetmek isteyip istemediğiniz sorulursa,Kaydet' i tıklatın.
  2. Rapor tanımı iletişim kutusunda Tamam' ı tıklatın.
  3. Dosya menüsünde MicrosoftDynamics GP veya Microsoft Business Solutions - GreatPlains'ıtıklatın.

Rapor için erişim izni ver

Microsoft Business Solutions - Great Plains 8.0 ve Microsoft Dynamics GP 9.0

Yöntem 1: Gelişmiş Güvenlik işlevi kullanarak

  1. Araçlar' ı tıklatın,Kur, Sistemgidin veGelişmiş Güvenlik' i tıklatın. Sistem parolasını yazın, areprompted.
  2. Görüntüle' yi tıklatın ve sonra byAlternate, değiştirilme ve özel'itıklatın.
  3. Aşağıdaki düğümleri genişletin:
    • Great Plains
    • Raporları
    • Satın alma
  4. Satınalma siparişi formunda, youmodified genişletin.
  5. Great Plains (düzeltilmiş)tıklatın.
  6. Uygula' yı tıklatın ve sonraTamam' ı tıklatın.

    Not:Gelişmiş Güvenlikiletişim kutusunu açtığınızda, varsayılan olarak, geçerli kullanıcı ve geçerli şirket seçilir. Geçerli şirket ve geçerli kullanıcı için yaptığınız herhangi bir changesthat olur. Ancak, ek kullanıcılar ve şirketler Şirketalanında ve AdvancedSecurity iletişim kutusunun kullanıcı alanında seçebilirsiniz.

Yöntem 2: standart Microsoft Business Solutions - Great Plains güvenlik kullanarak

  1. Araçlar' ı tıklatın,Kur, Sistemgidin veGüvenlik' i tıklatın.

    İstenirse, systempassword yazın.
  2. Kullanıcı kodu listesinde, kullanıcı kimliği için rapor erişimi istediğiniz kullanıcıyı tıklatın.
  3. Türü listesinde ModifiedReportstıklatın.
  4. Serileri listesindeSatınalma' yı tıklatın.
  5. Erişim listesi kutusunda, değişiklik thereport çift tıklatın ve sonra Tamam' ı tıklatın.

    Anasterisk (*) rapor adının yanında görüntülenir.

Microsoft Dynamics GP 10.0

  1. Değiştirilmiş raporu yazdırmak için bir kimlik oluşturun. Bunu yapmak için şu adımları izleyin:
    1. Microsoft Dynamics GP' ı tıklatın, Araçlar' ın üzerine, Kur', sistemi' ne gelin, Güvenlik' i seçin ve Alternatif/değiştirildi formlar ve raporlar'ıtıklatın.

      Sistem parolası istenirse, sistem parolasını yazın.
    2. Kimliği kimlik kutusuna yazın ve sonra Açıklama kutusuna bir açıklama yazın.
    3. Microsoft Dynamics GPÜrün alanını tıklatın ve sonra raportürü alanını tıklatın.
    4. Serilerigenişletin ve sonra Değiştirilen Raporu'nutıklatın.
    5. Kaydet'i tıklatın.
  2. Değiştirilmiş raporu yazdırmak için güvenliği atayın. Bunu yapmak için şu adımları izleyin:
    1. Microsoft Dynamics GP' ı tıklatın, Araçlar' ın üzerine, Kur', sistemi' ne gelin, Güvenlik' i seçin ve Kullanıcı güvenlik' i tıklatın.
    2. Kullanıcı kimliği ve şirket veritabanı'nı tıklatın.
    3. Alternatif/değiştirme formları ve raporları kimliği alanının yanındaki menüyü tıklatın ve 1b adımında oluşturduğunuz kimliği'ni tıklatın.
    4. Değişiklikleri kaydedin ve sonra raporu yazdırın.
Referanslar
Microsoft Great Plains'de 7.5 kalem açıklamaları ekleme hakkında daha fazla bilgi için Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
888409 7.5 Microsoft Great Plains'de ek boşluk oluşturmadan grafik satın alma siparişi raporları için kalem açıklamaları ekleme
RW, POP

Uyarı: Bu makalenin çevirisi otomatik olarak yapılmıştır

Özellikler

Makale No: 906709 - Son İnceleme: 04/04/2016 22:49:00 - Düzeltme: 0.1

Microsoft Dynamics GP 10.0, Microsoft Dynamics GP 9.0, Microsoft Business Solutions–Great Plains 8.0, Purchase Order Processing, Report Writer

  • kbnosurvey kbexpertiseinter kbmbsmigrate kbhowto kbmt KB906709 KbMttr
Geri bildirim