Microsoft Dynamics GP'yi başlattığınızda "Oturum açma bilgileriniz kullanıcı etkinliği dosyasından kaldırıldı ve muhasebe sisteminde olamazsınız" Hata iletisi

Bu makalede, Microsoft Dynamics GP'yi başlattığınızda oluşan bir hatanın çözümü sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics GP
Özgün KB numarası: 916679

Belirtiler

Microsoft Dynamics GP'yi başlattığınızda aşağıdaki hata iletisini alırsınız:

Oturum açma bilgileriniz kullanıcı etkinlik dosyasından kaldırıldı ve muhasebe sisteminde olamazsınız.

Neden

Bu sorun, otomatik bir istemci güncelleştirmesi yayımlandığında oluşur. Ayrıca, Microsoft Windows Installer dosyasının (.msp dosyası) yolu yanlış veya .msp dosyası eksik.

Çözüm

Bu sorunu gidermek için aşağıdaki yöntemlerden birini kullanın:

Yöntem 1

İstemci güncelleştirmesi tüm istemcilerde zaten yüklüyse, yayımlanan istemci güncelleştirmesini silin. Bunu yapmak için şu adımları uygulayın:

  1. Sistem yöneticisi (sa) kullanıcı hesabı kullanarak Microsoft Dynamics GP'de oturum açın.
  2. Uygun adımı kullanın:
    • Microsoft Dynamics GP'de, Microsoft Dynamics GP menüsünde Araçlar'ın üzerine gelin, Kurulum'un üzerine gelin, Sistem'in üzerine gelin ve İstemci Güncelleştirmeler'ni seçin.
    • Microsoft Dynamics GP 9.0'da, Araçlar menüsünde Kurulum'un üzerine gelin, Sistem'in üzerine gelin ve İstemci Güncelleştirmeler'ni seçin.
  3. Otomatik İstemci Güncelleştirmeler Yönet penceresinde, Adı Güncelleştir kutusunun yanındaki simgeyi seçin.
  4. Güncelleştirmeler penceresinde yüklediğiniz güncelleştirmeyi ve ardından Seç'i seçin.
  5. Otomatik İstemci Güncelleştirmeler Yönet penceresinde Sil'i seçin.

Yöntem 2

İstemci güncelleştirmesini korumak istiyorsanız, .msp dosyasının varolduğunu ve .msp dosyasının yolunun doğru olduğunu doğrulayın. Bunu yapmak için şu adımları uygulayın:

  1. sa kullanıcı hesabı kullanarak Microsoft Dynamics GP'de oturum açın.
  2. Araçlar menüsünde Kurulum'un üzerine gelin, Sistem'in üzerine gelin ve ardından İstemci Güncelleştirmeler'nı seçin.
  3. Otomatik İstemci Güncelleştirmeler Yönet penceresinde, Adı Güncelleştir kutusunun yanındaki simgeyi seçin.
  4. Güncelleştirmeler penceresinde.msp dosyasının yolunun doğru olduğunu doğrulayın. Yanlışsa yolu düzeltin.
  5. .msp dosyasının yolun sonundaki dizinde olduğunu doğrulayın.

Yöntem 3

Sistemde hiçbir kullanıcı oturum açamıyorsa, DYNAMICS veritabanındaki otomatik istemci güncelleştirme tablosundan otomatik istemci güncelleştirmesini kaldırın. Bunu yapmak için şu adımları uygulayın:

  1. DYNAMICS veritabanının yedeğine sahip olduğunuzu onaylayın.

  2. SQL Sorgu Çözümleyicisi'ni veya SQL Server Management Studio açın.

  3. Tüm otomatik istemci güncelleştirmelerini görüntülemek için aşağıdaki SQL deyimini çalıştırın.

    select * from DYNAMICS..SYUPDATE
    
  4. Geçerli bir UNCPath'i olmayan otomatik istemci güncelleştirmesini kaldırın. Bunu yapmak için aşağıdaki betiği çalıştırın.

    delete DYNAMICS..SYUPDATE where UPDATENAME = 'XXXX'
    

    Not

    'XXXX' yerine doğru güncelleştirme adını yazın.

  5. Microsoft Dynamics GP'de oturum açın.

Durum

Microsoft, bunun Geçerli olan bölümünde listelenen Microsoft ürünlerinde bir sorun olduğunu onayladı. Bu sorun düzeltilecek şekilde zamanlanmış değil.