Microsoft Dynamics CRM 4.0 OnChange olayı tetikleyen bir müşteri tipi alanı <a1>Arama</a1> düğmesini tıklattığınızda, beklenmedik şekilde kapanabilir

ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.

Makalenin İngilizcesi aşağıdaki gibidir:948770
Bu makale arşivlenmiştir. "Olduğu gibi" sunulmaktadır ve bundan sonra güncelleştirilmeyecektir.
Belirtiler
Microsoft Dynamics CRM 4.0 OnLoad olayı bir <a0>Hesap</a0> varlığın veya müşteri türü alanı için bir OnChange olayı tetiklemek için ilgili kişi bir varlık ayarlayın. Örneğin, Ana firma alanında veya Birincil ilgili kişi alanında Müşteri türü alanı olabilir. OnChange olayı oluşur, bir ileti alırsınız.

Ancak, bir firma kaydını veya bir ilgili kişi kaydının açtığınızda OnLoad olayı, OnChange olayı oluşmaz. OnChange olayı için bir ileti almazsınız. Sonra arama düğmesini OnChange olayı tetikleyen müşteri türü alanındaki Ek Yardım düğmesini tıklattığınızda OnChange olayı yine de oluşmaz. Ayrıca, Microsoft Dynamics CRM 4.0 beklenmedik şekilde kapanabilir.
Neden
OnChange olayı oluştuğunda herhangi bir işlem sağlamak için hiçbir olay işleyicileri bulunduğundan bu sorun oluşur. Vardır hiçbir olay işleyicileri FireOnChange yöntemi OnLoad olayı için eklendiğinden ve olay işleyicileri FireOnChange yöntemi OnChange geçirdiğinde tanımlı olay.
Çözüm
Bu sorun, Microsoft Dynamics CRM 4.0 için en son toplu güncelleştirme toplamasına giderilmiştir. Daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
949256Microsoft Dynamics CRM 4.0 güncelleştirmelerini ve düzeltmeleri
Durum
Microsoft, "Geçerli Olduğu Ürünler" bölümünde listelenen Microsoft ürünlerinde bu sorunun olduğunu onaylamıştır.
Daha fazla bilgi
Yazılım güncelleştirme terminolojisi hakkında daha fazla bilgi için Microsoft Knowledge Base'deki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
824684Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması
887283Microsoft Business Solutions CRM yazılım düzeltmesi ve güncelleştirme paketi adlandırma standartları
Yığın Taşması satırında: 0

Uyarı: Bu makalenin çevirisi otomatik olarak yapılmıştır

Özellikler

Makale No: 948770 - Son İnceleme: 01/15/2015 18:46:39 - Düzeltme: 3.0

Microsoft Dynamics CRM 4.0

  • kbnosurvey kbarchive kbmt kberrmsg kbexpertiseinter kbfix kbmbscustomization kbmbsmigrate kbqfe kbhotfixserver kbautohotfix KB948770 KbMttr
Geri bildirim