#BÖL/0! hatasını düzeltme

Microsoft Excel, bir sayı sıfırla (0) bölündüğünde #BÖL/0! hatasını gösteriyor. Bu hata, =5/0 gibi basit bir formül girdiğinizde veya bir formül, bu resimde de gösterildiği gibi 0 değerine sahip veya boş olan bir hücreye başvurduğunda oluşur.

#BÖL/0! hatalarına neden olan formül örnekleri.

Hatayı düzeltmek için aşağıdakilerden birini yapın:

  • İşlevdeki veya formüldeki bölenin sıfır veya boş hücre olmadığından emin olun.

  • Formüldeki hücre başvurusunu sıfır (0) veya boş değer içermeyen başka bir hücreyle değiştirin.

  • Formülde bölen olarak başvuruda bulunulan hücreye #YOK değerini girin; bu eylem, bölen değerinin kullanılamadığını gösterecek şekilde formül sonucunu #YOK olarak değiştirir.

Birçok kez #DIV/0! hatasından kaçınamamak gerekir. Bu durumda, hata iletisinin hiç iletiyi görüntülemesini istemiyorsanız, giriş beklerken hatanın görüntülenmesini göstermek için kullanabileceğiniz birkaç hata işleme yöntemi vardır.

Paydanın 0 veya boş değer olup olmadığını değerlendirme

#BÖL/0! hatasının görüntülenmesini engellemenin en basit yolu EĞER işlevini kullanarak payda bulunup bulunmadığını değerlendirmektir. Bu sıfırsa (0) veya değer yoksa, #BÖL/0! hata değeri yerine formül sonucu olarak 0 veya değer yok gösterilmesini, aksi takdirde formülün hesaplanmasını sağlayın.

Örneğin, =A2/A3 formülü hata döndürüyorsa, 0 döndürmek için =EĞER(A3,A2/A3,0) formülünü veya boş dize döndürmek için =EĞER(A3,A2/A3,””) formülünü kullanın. Şunun gibi bir özel ileti de görüntüleyebilirsiniz: =EĞER(A3,A2/A3,”Giriş Gerekiyor”). İlk örnekteki BÖLÜM işleviyle, =EĞER(A3,BÖLÜM(A2,A3),0) formülünü kullanabilirsiniz. Bu Excel'e şunları söyler: EĞER(A3 varsa, formülün sonucunu döndür, aksi takdirde bunu yoksay).

#BÖL/0! hatalarına neden olan formül örnekleri.

#BÖL/0! hatasını engellemek için EĞERHATA kullanma

Bölme işleminizi EĞERERROR işlevinin içine iç içe kullanarak da bu hatayı engel alabilirsiniz. Yine A2/A3'ü kullanarak, =EĞERHATA(A2/A3,0) formülünü kullanabilirsiniz. Bu Excel'e formülünüz hata sonucu veriyorsa 0 döndürmesini, aksi takdirde formülün sonucunu döndürmesini söyler.

Excel'in Excel 2007'den önceki sürümleri için, EĞER(EHATALIYSA()) yöntemini kullanabilirsiniz: =EĞER(EHATALIYSA(A2/A3),0,A2/A3) (Bkz. E işlevleri).

Not: EĞERERROR ve EĞER(EHATALISA()) yöntemlerinin her ikisi de paket hata işleyicileridir; yalnızca hata #DIV/0! hatalarını gizlemezler. Herhangi bir hata işleme uygulamadan önce formülün düzgün bir şekilde çalıştığından emin olun, aksi takdirde formülle beklediğiniz gibi çalışmamış olduğunu fark edemeyebilirsiniz.

İpucu: Excel'de hata denetimi açıksa, hatayı gösteren hücrenin yanındaki Düğme Görüntüsü öğesine tıklayın. Söz konusu öğe kullanılabilir durumdaysa, Hesaplama Adımlarını Göster'e tıklayın ve verileriniz için uygun çözümü seçin.

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

EĞER işlevi

EĞERHATA işlevi

E işlevleri

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Daha fazla yardıma mı ihtiyacınız var?

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×