Formül geçerli olmayan bir hücreye başvurduğunda #BAŞV! hatası gösterilir. Bu çoğunlukla formülün başvurduğu hücrelerin silinmesi veya üzerlerine başka bir şey yapıştırılması durumunda olur.

Örnek - Sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği

Aşağıdaki örnek, E sütununda =TOPLA(B2,C2,D2) formülünü kullanır.

=TOPLA(B2,C2,D2) gibi açık hücre başvuruları kullanan formüller, bir sütunun silinmesi durumunda #BAŞV! hatası verebilir.

B, C veya D sütununu silmeniz #BAŞV! hatasına neden olur. Bu örnekte C sütununu (2007 Satışları) siliyoruz ve şimdi formül =TOPLA(B2,#BAŞV!,C2) oluyor. Bunun gibi açık hücre başvuruları kullanır (birbirinden virgülle ayrılmış olarak her hücreye tek tek başvurarak) ve başvurulan bir satır veya sütunu silerseniz, Excel bunu çözemez ve dolayısıyla #BAŞV! hatası döndürür. İşlevlerde açık hücre başvuruları kullanımının önerilmemesinin birincil nedeni budur.

Bir sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

  • Satır veya sütunları yanlışlıkla sildiyseniz, hemen Hızlı Erişim Araç Çubuğu'nda Geri Al düğmesine tıklayarak (veya CTRL+Z tuşlarına basarak) bunları geri yükleyebilirsiniz.

  • Formülü, tek tek hücreler yerine bir aralık başvurusu (=TOPLA(B2:D2) gibi) kullanacak şekilde ayarlayın. Şimdi toplama aralığının içindeki herhangi bir sütunu silebilirsiniz ve Excel formülü otomatik olarak ayarlar. Ayrıca, satırların toplamı için =TOPLA(B2:B5) formülünü de kullanabilirsiniz.

Örnek - Yanlış aralık başvuruları olan DÜŞEYARA

Aşağıdaki örnekte, =DÜŞEYARA(A8,A2:D5,5,YANLIŞ) #REF! hatası döndürür. Ancak başvuru aralığı A:D'dedir ve yalnızca 4 sütundur.

Yanlış aralıkta olan bir DÜŞEYARA formülü örneği.  Formül =DÜŞEYARA(A8,A2:D5,5,YANLIŞ).  DÜŞEYARA aralığında beşinci sütun yoktur, dolayısıyla 5 sütun düşeylik #REF! hatası verir.

Çözüm

Aralığı daha büyük olacak şekilde ayarlayın veya sütun arama değerini başvuru aralığıyla eşleşecek şekilde küçültün. =DÜŞEYARA(A8,A2:E5,5,YANLIŞ) ve =DÜŞEYARA(A8,A2:D5,4,YANLIŞ) geçerli başvuru aralıkları olabilir.

Örnek - Yanlış satır veya sütun başvurusu olan İNDİS

Bu örnekte, =İnDİS(B2:E5,5,5) formülü bir formül #REF! hatası döndürür. Ancak formül, 5. satır ve 5. sütundakileri geri istiyor olabilir.

Geçersiz aralık başvurusu içeren bir İNDİS formülü örneği.  Formül =İNDİS(B2:E5,5,5) ancak aralık yalnızca 4 satıra 4 sütundur.

Çözüm

Satır ve sütun başvurularını İNDİS arama aralığı içinde kalacak şekilde ayarlayın. =İNDİS(B2:E5,4,4) formülü geçerli bir sonuç döndürebilir.

Örnek – DOLAYLI işleviyle kapalı bir çalışma kitabına başvurma

Aşağıdaki örnekte, DOLAYLI işlevi kapalı olan bir çalışma kitabına başvurmayı denediğinden #BAŞV! hatasına neden olur.

Kapalı bir çalışma kitabına yapılan DOLAYLI başvuru nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

Başvurulan çalışma kitabını açın. Dinamik dizi işleviyle kapalı bir çalışma kitabına başvurursanız da aynı hatayla karşılaşırsınız.

OLE Sorunları

#BAŞV! hatası döndüren bir Nesne Bağlama ve Ekleme (OLE) bağlantısı kullandıysanız, bağlantının çağırdığı programı başlatın.

Not: OLE, programlar arasında bilgi paylaşmak için kullanabileceğiniz bir teknolojidir.

DDE Sorunları

#BAŞV! hatası alırsanız, önce doğru konuya başvurarak kontrol edin. Hala bir e-posta #REF! hatası alırsanız, Güven Merkezi'Ayarlar Belgelerde dış içeriği engelleme veya engellemesini kaldırma'da belirtilen dış Office kontrol edin.

Not:Dinamik Exchange Veri Kaynağı(DDE),Microsoft'un kendi tabanlı programları arasında veri alışverişinde Windows protokoldür.

Makro Sorunları

Makro, çalışma sayfasına, işlevin üstündeki bir hücreye başvuruda bulunduracak bir işlev girerse ve işlevi içeren hücre 1. satırda olursa, işlev tam #REF! çünkü 1. satırın üstünde hiçbir hücre yoktur. İşlevi kontrol edin ve bağımsız değişkenin geçerli olmayan bir hücreye veya hücre aralığına başvurup başvurduğuna bakın. Bunun için Makro Düzenleyicisi'nde (VBE) Visual Basic bu durumu dikkate almak gerekli olabilir.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?

Deneyiminizi ne etkiledi?

Başka geri bildirim göndermek istiyor musunuz? (İsteğe bağlı)

Geri bildiriminiz için teşekkür ederiz!

×