#DEĞER! ETOPLA/TOPSıO işlevinde hata

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Bu konu başlığı altında, ETOPLA ve ÇOKETOPLA işlevlerindeki #DEĞER! hatasının yaygın nedenleri ve bunların nasıl çözüleceği listelenir.

Sorun: Formül kapalı bir çalışma kitabındaki hücrelere başvuruyor

Kapalı bir çalışma kitabındaki hücreye veya aralığa başvuran ETOPLA/ÇOKETOPLA işlevleri #DEĞER! hatasıyla sonuçlanır.

Notu Bu, örneğin, EĞERSAY, BAĞ_DEĞŞ gibi diğer Excel işlevlerinin birkaç adı ETOPLA, EĞERSAY ve COUNTBLANK işlevlerinin "#VALUE!" Ifadesini görün Hatası ayrıntılı bilgi

Çözüm: Formülde belirtilen çalışma kitabını açın ve F9'a basarak formülü yenileyin.

TOPLA ve eğer işlevlerini bir dizi formülünde birlikte kullanarak da bu soruna geçici bir çözüm yapabilirsiniz. ETOPLA, EĞERSAY ve COUNTBLANK işlevlerinin #VALUE! hatası ayrıntılı bilgi

Sorun: Ölçüt dizesi 255 karakteri aşıyor

255 karakterden uzun dizeleri eşleştirmeye çalıştığınızda, ETOPLA/ÇOKETOPLA işlevleri yanlış sonuçlar döndürür.

Çözüm: Mümkünse dizeyi kısaltın. Dizeyi kısaltamıyorsanız, değeri birden çok dizeye bölmek için BİRLEŞTİR işlevini veya Ve (&) işlecini kullanın. Örneğin:

=ETOPLA(B2:B12,"uzun dize"&"bir uzun dize daha")

Sorun: ÇOKETOPLA işlevinde, ölçüt_aralığı bağımsız değişkeni aralık_toplamı bağımsız değişkeniyle tutarlı değil.

ÇOKETOPLA işlevinde aralık bağımsız değişkenlerinin her zaman aynı olması gerekir. Bu, ölçüt_aralığı ve aralık_toplamı bağımsız değişkenlerinin aynı sayıda satıra ve sütuna başvurması gerektiği anlamına gelir.

Aşağıdaki örnekte, formülün Balıkesir'deki günlük Elma satışlarının toplamını döndürmesi bekleniyor. Öte yandan, aralık_toplamı (C2:C10) bağımsız değişkeni ölçüt_aralığı (A2:A12 & B2:B12) bağımsız değişkenleriyle aynı satır ve sütun sayısına karşılık gelmiyor. =ÇOKETOPLA(C2:C10,A2:A12,A14,B2:B12,B14) söz diziminin kullanılması #DEĞER! hatası döndürüyor.

Yanlış formül: =ÇOKETOPLA(C2:C10,A2:A12,A14,B2:B12,B14); burada C2:C10'un C2:C12 olması gerekir

Çözüm: Bu örnekte, aralık_toplamı bağımsız değişkenini C2:C12 olarak değiştirin ve formülü yeniden deneyin.

Not:  ETOPLA, farklı boyuttaki aralıkları kullanabilir.

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

ETOPLA işlevi

ÇOKETOPLA işlevi

Gelişmiş Eğer işlevi videoları

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×