#SPILL çok sonuç döndüren bir formül hatalarına Excel bu hatalar döndürülür ve Excel kılavuza döndüramaz. Bu hata türleri hakkında daha fazla ayrıntı için aşağıdaki yardım konularına bakın:

Bu hata, bir dizi formülünü taşan bir dizi aralığının boş olmadığını gösterir.

Excel’de #SPILL! hata - Taşma aralığı boş değil

Formül seçildiğinde, hedeflenen kesik çizgili kenarlık hedeflenen taşma aralığını gösterir.

Aşağıdaki engeli (ve hücreleri) hemen gitmek için Hata kayan yüzer öğesini ve sonra da Engeli Hücreleri Seç seçeneğini belirleyin. Bundan sonra, engeli silerek veya hücrenin girişini kapatarak hatayı temizebilirsiniz. Engel temizlensin mi, dizi formülü hedeflenen şekilde taşacak.

Excel geçici olduğundan spilled dizisinin boyutunu belirleyemedi ve hesaplama arasında yeniden boyutlandırılır. Örneğin, aşağıdaki formül bu formülü #SPILL! hatası döndürür:

=SEQUENCE(RANDBETWEEN(1,1000))

Elektronik tablonun tümüyle hesaplanmış olduğundan emin olmak için dinamik dizi yeniden boyutlandırmaları ek hesaplama geçişlerini tetikler. Bu ek geçişler sırasında dizinin boyutu değişmeye devam ederse ve bu ek geçişler sırasında Excel dizi, diziyi normal #SPILL!.

Bu hata değeri genel olarak SSS ,RANDARRAYve RANDBETWEEN işlevlerinin kullanımıyla ilişkilendirildi. KAYDIR, DOLAYLIve BUGÜN gibidiğer geçici işlevler her hesaplama geçişlarında farklı değerler dönmez. 

Örneğin, aşağıdaki örnekte olduğu gibi E2 hücresine yerleştirilse, =DÜŞEYARA(A:A,A:C,2,YANLIŞ) formülü daha önce yalnızca A2 hücresinde kimlik araması gerçekleştiri. Bununla birlikte, dinamik Excel dizi dizisinde formül başka bir #SPILL! hatası döndürür Excel sütunun tamamını arayacağız, 1.048.576 sonuç döndürür ve kılavuz çizgisinin Excel verir.

Excel’de #SPILL! hatasının nedeni E2 hücresinde =DÜŞEYARA(A:A,A:D,2,YANLIŞ) olduğundan sonuçlar çalışma sayfasının kenarının dışına taşma olur. Formülü E1 hücresine taşı uygun şekilde işlev gösterir.

Bu sorunu çözmenin 3 basit yolu vardır:

#

Yaklaşım

Formül

1

Yalnızca ilgilendiğin arama değerlerine başvuru. Bu formül stili dinamik bir dizi döndürür, ancak diğer tablolarla Excel çalışmaz. 

Formül sonucu elde etmeyen dinamik bir dizi elde etmek için =DÜŞEYARA(A2:A7,A:C,2,YANLIŞ) #SPILL! hatası verir.

=DÜŞEYARA(A2:A7,A:C,2,YANLIŞ)

2

Yalnızca aynı satırdaki değere başvurup formülü aşağı kopyalayın. Bu geleneksel formül stili tablolarda çalışır, ancak dinamik bir dizi geri dönmez.

Geleneksel DÜŞEYARA işlevini tek bir düşey lookup_value kullanın: =DÜŞEYARA(A2,A:C,32,YANLIŞ). Bu formül dinamik bir dizi geri dönmez, ancak diğer tablolarla Excel kullanılabilir.

=DÜŞEYARA(A2,A:C,2,YANLIŞ)

3

@ Excel kullanarak örtülü kesişim gerçekleştirmeyi talep edin ve ardından formülü aşağı kopyalayın. Bu formül stili tablolarda çalışır, ancak dinamik dizi dönmez.

@ işlecini kullanın ve aşağı kopyalayın: =DÜŞEYARA(@A:A,A:C,2,YANLIŞ). Bu başvuru stili tablolarda çalışır, ancak dinamik bir dizi geri dönmez.

=DÜŞEYARA(@A:A,A:C,2,YANLIŞ)

Bir tablodaki taşmış dizi formülleri Excel. Formülünü tablodan dışarı taşımayı veya tabloyu bir aralığına dönüştürmeyi deneyin (Tablo Tasarımı > Araçları'>dönüştür'e tıklayın).

Excel’de #SPILL! hata - Tablo formülü

Girmeye çalıştığınız spilled dizi formülü Excel yetersizliklere neden oldu. Lütfen daha küçük bir dizi veya aralık için başvuruyu deneyin.

Taşan dizi formülleri birleştirilmiş hücrelere taşamaz. Lütfen söz konusu hücreleri birleştirin veya formülü birleştirilmiş hücrelerle kesişemeyen başka bir aralıda hareket ettirin.

Excel’de #SPILL! hata - Birleştirilmiş hücreye taşma

Formül seçildiğinde, hedeflenen kesik çizgili kenarlık hedeflenen taşma aralığını gösterir.

Aşağıdaki engeli (ve hücreleri) hemen gitmek için Hata kayan yüzer öğesini ve sonra da Engeli Hücreleri Seç seçeneğini belirleyin. Birleştirilmiş hücreler temizlensin mi, dizi formülü amaçlanan şekilde taşar.

Excel bu hatanın nedenini tanımaz veya uzlaştırmaz. Lütfen formülde senaryo için tüm gerekli bağımsız değişkenlerin olduğundan emin olun.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

FİLTRE işlevi

RASGDİZİ işlevi

SIRALI işlevi

SIRALA işlevi

SIRALAÖLÇÜT işlevi

BENZERSİZ işlevi

Dinamik diziler ve taşan dizi davranışı

Örtük kesişim işleci: @

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×