İpucu: VLOOKUP'ın herhangi bir yönde çalışan ve varsayılan olarak tam eşleşmeleri döndürerek öncekinden daha kolay ve kullanışlı hale getiren geliştirilmiş bir sürümü olan yeni DÜŞEYARA işlevini kullanmayı deneyin.

Bir tablo veya aralıktaki öğeleri satıra göre bulmanız gerektiğinde DÜŞEYARA’yı kullanın. Örneğin, parça numarasına göre bir otomotiv parçasının fiyatını arayın veya çalışan kimliğine göre bir çalışan adı bulun.

En basit biçimiyle, DÜŞEYARA işlevi şunu söyler:

=DÜŞEYARA(Aramak istediğiniz şey, aramak istediğiniz yer, döndürülecek değeri içeren aralıktaki sütun numarası, Yaklaşık veya Tam eşleşme 1/DOĞRU veya 0/YANLIŞ olarak gösterilir) döndürür.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

İpucu: DÜŞEYARA’nın sırrı, aradığınız değerin (parça numarası), bulmak istediğiniz dönüş değerinin (miktar) solunda yer almasını sağlayacak şekilde verilerinizi düzenlemektir.

Tabloda bir değeri aramak için DÜŞEYARA işlevini kullanın.

Söz dizimi 

DÜŞEYARA(aranan_değer, tablo_dizisi, sütun_indis_sayısı, [aralık_bak])

Örneğin:

  • =DÜŞEYARA(A2,A10:C20,2,DOĞRU)

  • =DÜŞEYARA("Fontana",B2:E7,2,YANLIŞ)

  • =DÜŞEYARA(A2,'İstemci Ayrıntıları'! A:F,3,YANLIŞ)

Bağımsız değişken adı

Açıklama

aranan_değer    (gerekli)

Aramak istediğiniz değer. Aramak istediğiniz değer, tablo_dizisi olarak belirttiğiniz hücre aralığının ilk sütununda yer almalıdır.

Örneğin, tablo-dizisi B2:D7 arasındaki hücrelere yayılıyorsa arama değeriniz B sütununda yer almalıdır.

Aranan_değer , bir değer veya hücre referansı olabilir.

tablo_dizisi    (gerekli)

DÜŞEYARA işlevinin aranan_değeri ve dönüş değerini bulmak için arama yapacağı hücre aralığı. Adlandırılmış aralık veya tablo kullanabilir ve hücre başvuruları yerine bağımsız değişkendeki adları kullanabilirsiniz. 

Hücre aralığındaki ilk sütun aranan_değeri içermelidir. Hücre aralığı, ayrıca bulmak istediğiniz dönüş değerini de içermelidir.

Çalışma sayfasında aralıkları seçmeyi öğrenin.

sütun_indis_sayısı    (gerekli)

Dönüş değerini içeren sütunun numarası (tablo_dizisinin en solundaki sütun için 1’den başlayarak).

aralık_bak    (isteğe bağlı)

DÜŞEYARA işlevinin yaklaşık eşleşme mi yoksa tam eşleşme mi bulmasını istediğinizi belirten mantıksal değer:

  • Yaklaşık eşleşme - 1/TRUE, tablodaki ilk sütunun sayısal veya alfabetik olarak sıralandığını varsayar ve en yakın değeri arar. Yöntem belirtmezseniz, varsayılan yöntem olarak bu kullanılır. Örneğin, =DÜŞEYARA(90,A1:B100,2,DOĞRU).

  • Tam eşleşme - 0/YANLIŞ, ilk sütundaki tam olarak eşleşen değeri arar. Örneğin, =DÜŞEYARA("Smith",A1:B100,2,YANLIŞ).

Nasıl başlanır

DÜŞEYARA söz dizimini oluşturmak için dört ayrı bilgiye ihtiyacınız vardır:

  1. Arama değeri olarak da adlandırılan, aramak istediğiniz değer.

  2. Arama değerinin yer aldığı aralık. DÜŞEYARA işlevinin düzgün çalışması için, arama değeri her zaman aralıktaki ilk sütunda olmalıdır. Örneğin, arama değeriniz C2 hücresindeyse aralığınız C ile başlamalıdır.

  3. Aralıkta, dönüş değerini içeren sütunun numarası. Örneğin, aralık olarak B2: D11 belirtirseniz, B’yi ilk sütununuz, C’yi ikinci sütununuz vb. şeklinde değerlendirmeniz gerekir.

  4. İsteğe bağlı olarak, dönüş değerine yönelik yaklaşık bir eşleşme elde etmek için DOĞRU, tam eşleşme elde etmek için YANLIŞ değerini belirtebilirsiniz. Hiçbir şey belirtmezseniz, varsayılan değer her zaman için DOĞRU veya yaklaşık eşleşme olur.

Yukarıda açıklananları şu şekilde toparlayabiliriz:

=DÜŞEYARA(arama aralığı, arama değerinin yer aldığı aralık, aralıkta dönüş değerini içeren sütunun numarası, Yaklaşık eşleşme (DOĞRU) veya Tam eşleşme (YANLIŞ)).

Örnekler

İşte DÜŞEYARA işlevinin kullanımıyla ilgili birkaç örnek:

Örnek 1

=DÜŞEYARA (B3,B2:E7,2,YANLIŞ)

DÜŞEYARA, table_array B2:E7'deki ilk sütunda (B sütunu) Fontana'yı arar ve table_array ikinci sütunundan (C sütunu) Olivier'i döndürür.  Yanlış tam eşleşme döndürür.

Örnek 2

=DÜŞEYARA (102,A2:C7,2,YANLIŞ)

DÜŞEYARA, A2:C7 aralığındaki ikinci sütunda (B sütunu) 102 (lookup_value) için soyadının tam eşleşmesini (YANLIŞ) arar ve Fontana döndürür.

Örnek 3

=EĞER(DÜŞEYARA(103,A1:E7,2,YANLIŞ)="Souse","Konum","Bulunamadı")

EĞER, DÜŞEYARA işlevinin, A1:E7'de (tablo_dizisi) 103'e (arama_değeri) karşılık gelen çalışanın soyadı olarak Sousa döndürüp döndürmediğini denetler. 103'e karşılık gelen soyadı Leal olduğundan, EĞER koşulu yanlış olur ve Bulunamadı görüntülenir.

Örnek 4

=TAMSAYI(YILORAN(TARİH(2014,6,30),DÜŞEYARA(105,A2:E7,5,FLASE),1))



DÜŞEYARA, A2:E7 aralığındaki (table_array) 109’a (lookup_value) karşılık gelen çalışanın doğum tarihini arar ve 04/03/1955 döndürür. Ardından YILORAN bu doğum tarihini 2014/6/30'dan çıkarır ve INY tarafından 59 tamsayısına dönüştürülen bir değer döndürür.

Örnek 5

EĞER(EYOKSA(DÜŞEYARA(105,A2:E7,2,FLASE))=DOĞRU,"Çalışan bulunamadı",DÜŞEYARA(105,A2:E7,2,YANLIŞ))



EĞER, DÜŞEYARA işlevinin 105 (lookup_value) için B sütunundan soyadı için bir değer döndürüp döndürmediğini denetler. DÜŞEYARA bir soyadı bulursa, EĞER soyadını görüntüler, aksi takdirde EĞER işlevi Çalışan bulunamadı değerini döndürür. EYOKSA, DÜŞEYARA #N/A döndürürse hatanın #N/A yerine Çalışan bulunamadı olarak değiştirilmesini sağlar.



Bu örnekte dönüş değeri, 105'e karşılık gelen soyadı olan Burke'dir.

Tablolardan birinde diğerleriyle ortak alanlar olduğu sürece, birden çok tabloyu tek bir tabloda birleştirmek için DÜŞEYARA işlevini kullanabilirsiniz. Bir çalışma kitabını veri kaynağı olarak birden çok tabloyla desteklemeyen eski Excel sürümlerine sahip kişilerle paylaşmanız gerekiyorsa, bu özellikle yararlı olabilir. Kaynakları tek bir tabloda birleştirerek ve veri özelliğinin veri kaynağını yeni tabloyla değiştirerek, veri özelliği eski Excel sürümlerinde kullanılabilir (veri özelliğinin kendisi eski sürüm tarafından destekleniyorsa).

Diğer tablolardan veri almak için DÜŞEYARA kullanan sütunlar içeren bir çalışma sayfası

Burada, A-F ve H sütunlarında yalnızca çalışma sayfasındaki değerleri kullanan değerler veya formüller vardır ve sütunların geri kalanı, diğer tablolardan veri almak için DÜŞEYARA'yı ve A (İstemci Kodu) ile B sütununun (Avukat) değerlerini kullanır.

  1. Ortak alanları olan tabloyu yeni bir çalışma sayfasına kopyalayın ve bir ad verin.

  2. İlişkileri Yönet iletişim kutusunu açmak için Veri > Veri Araçları > İlişkiler’e tıklayın.

    İlişkileri Düzenle iletişim kutusu
  3. Listelenen her ilişki için aşağıdakileri not edin:

    • Tabloları bağlayan alan (iletişim kutusunda parantez içinde listelenir). DÜŞEYARA formülünüzün aranan_değeri budur.

    • İlgili Arama Tablosu adı. DÜŞEYARA formülünüzün tablo_dizisi budur.

    • İlgili Arama Tablosundaki, yeni sütununuzda istediğiniz verileri içeren alan (sütun). Bu bilgiler İlişkileri Yönet iletişim kutusunda gösterilmez; hangi alanı almak istediğinizi görmek için İlgili Arama Tablosu'na bakmanız gerekir. Sütun numarasını (A=1) not etmek istiyorsunuz; formülünüzün sütun_indis_sayısı budur.

  4. Yeni tabloya alan eklemek için, 3. adımda topladığınız bilgileri kullanarak DÜŞEYARA formülünüzü ilk boş sütuna girin.

    Örneğimizde G sütunu, =DÜŞEYARA([@Attorney],tbl_Attorneys,4,YANLIŞ) formülüyle Avukatlar çalışma sayfası tablosundaki tblAttorneys (tablo_dizisi) dördüncü sütundan (sütun_indis_sayısı = 4) Fatura Oranı verilerini almak için Avukat (lookup_value) kullanır.

    Formül, hücre başvurusu ve aralık başvurusu da kullanabilir. Örneğimizde şöyle olacaktır: =DÜŞEYARA(A2,'Avukatlar'! A:D,4,YANLIŞ).

  5. İhtiyacınız olan tüm alanlara sahip olana kadar alan eklemeye devam edin. Birden çok tablo kullanan veri özellikleri içeren bir çalışma kitabı hazırlamaya çalışıyorsanız, veri özelliğinin veri kaynağını yeni tabloyla değiştirin.

Sorun

Nerede sorun çıktı?

Yanlış değer verdi

Aralık_bak değeri DOĞRU ise veya boş bırakılmışsa, ilk sütunun alfabetik veya sayısal olarak sıralanması gerekir. İlk sütun sıralanmamışsa, verilen değer beklenmedik bir şey olabilir. İlk sütunu sıralayın veya tam eşleşme için YANLIŞ değerini kullanın.

Hücrede #YOK değeri

  • Aralık_bak değeri DOĞRU ise, aranan_değer bağımsız değişkenindeki değer tablo_dizisi’nin ilk sütunundaki en küçük değerden daha küçük olduğunda #YOK hata değerini alırsınız.

  • Aralık_bak YANLIŞ ise, #YOK hata değeri tam sayının bulunamadığını gösterir.

DÜŞEYARA işlevindeki #YOK hatalarını düzeltme hakkında daha fazla bilgi için bkz. DÜŞEYARA işlevindeki #YOK hatasını düzeltme.

Hücrede #BAŞV! değeri

Sütun_indis_sayısı değeri tablo-dizisi içindeki sütunların sayısından büyükse, #BAŞV! hata değerini alırsınız.

DÜŞEYARA işlevindeki #REF! hatalarını düzeltme hakkında daha fazla bilgi için bkz. #REF! hatasını düzeltme..

Hücrede #DEĞER! değeri

Tablo_dizisi 1’den küçükse, #DEĞER! hata değerini alırsınız.

DÜŞEYARA işlevindeki #DEĞER! hatalarını düzeltme hakkında daha fazla bilgi için bkz. DÜŞEYARA işlevindeki #DEĞER! hatasını düzeltme..

Hücrede #AD? değeri

#AD? hata değeri, çoğunlukla formülde tırnak işaretlerinin eksik olduğu anlamına gelir. Bir kişinin adını aramak için, formüldeki adda tırnak işaretlerini kullandığınızdan emin olun. Örneğin, =DÜŞEYARA("Fontana",B2:E7,2,YANLIŞ) içinde adı "Fontana" olarak girin.

Daha fazla bilgi için bkz. #AD! hatasını düzeltme.

Excel’de #SPILL! var

Bu özel #SPILL! hatası genellikle formülünüzün arama değeri için örtük kesişimi kullandığı ve bir sütunun tamamını başvuru olarak kullandığı anlamına gelir. Örneğin, =DÜŞEYARA(A:A,A:C,2,YANLIŞ). Arama başvurusunu @ işleciyle şu şekilde sabitleyerek sorunu çözebilirsiniz: =DÜŞEYARA(@A:A,A:C,2,YANLIŞ). Alternatif olarak, geleneksel DÜŞEYARA yöntemini kullanabilir ve sütunun tamamı yerine tek bir hücreye başvurabilirsiniz: =DÜŞEYARA(A2,A:C,2,YANLIŞ).

Bunu yapın

Neden?

Aralık_bak için mutlak başvurular kullanın

Mutlak başvurular kullanmak, formülü her zaman tam olarak aynı arama aralığına bakacak şekilde aşağı doğru doldurmanıza olanak tanır.

Mutlak hücre başvurularının nasıl kullanıldığını öğrenin.

Sayı veya tarih değerlerini metin olarak depolamayın.

Sayı veya tarih değerlerini ararken tablo_dizisinin ilk sütunundaki verilerin metin değerleri olarak depolanmamış olduğundan emin olun. Yoksa, DÜŞEYARA yanlış veya beklenmeyen bir değer verebilir.

İlk sütunu sıralayın

aralık_bak değeri DOĞRU olduğunda, DÜŞEYARA’yı kullanmadan önce tablo_dizisi değerinin ilk sütununu sıralayın.

Joker karakterler kullanın

Aralık_bak YANLIŞ ve bakılan_değer metinse, bakılan_değerde joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. YANLIŞ'sa ve aranan_değer metinse, aranan_değer’de joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. Yıldız işareti bir dizi karakteri eşleştirir. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Örneğin, =DÜŞEYARA("Sala?",B2:E7,2,YANLIŞ) formülü, son harfi değişken olabilecek şekilde tüm Salah örneklerini arar.

Verilerinizde hatalı karakterler kullanılmadığından emin olun.

İlk sütundaki metin değerlerini ararken, ilk sütunda metnin başında boşluklar, sonunda boşluklar, tutarsız kullanılmış düz ( ' veya " ) ya da kıvrımlı ( ‘ veya “) tırnak işaretleri veya yazdırılamayan karakterler bulunmadığından emin olun. Bunlar varsa, DÜŞEYARA beklenmeyen bir değer verebilir.

Doğru sonuçlar almak için, hücrede tablo değerlerini izleyen sondaki boşlukları kaldırmak üzere TEMİZ işlevini veya KIRP işlevini kullanmayı deneyin.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Excel'de canlı ve ücretsiz yanıtlar alın

Ayrıca Bkz:

Hızlı Başvuru Kartı: DÜŞEYARA yenileyicisi
Hızlı Başvuru Kartı: DÜŞEYARA sorun giderme ipuçları
DÜŞEYARA işlevindeki #VALUE! hatasını düzeltme
DÜŞEYARA işlevinde #YOK hatasını düzeltme
Excel’deki formüllere genel bakış
Bozuk formülleri önleme
Formüllerdeki hataları algılama
Excel işlevleri (alfabetik)
Excel işlevleri (kategoriye göre)
DÜŞEYARA (ücretsiz önizleme)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin

Eğitimleri keşfedin >

Yeni özellikleri ilk olarak siz edinin

Microsoft Insider’a katılın >

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×