DÜŞEYARA işlevi

İpucu: DÜŞEYARA'nın herhangi bir yönde çalışan ve varsayılan olarak tam eşleşmeleri döndüren geliştirilmiş bir sürümü olan yeni DÜŞEYARA işlevini kullanmayı deneyin. Bu, öncül sürümünden daha kolay ve kullanışlı bir kullanım sağlar.

Bir tablodaki veya aralıkta satıra göre bir şeyler bulmaniz gereken zaman DÜŞEYARA işlevini kullanın. Örneğin, parça numarasına göre bir otomobil parçasının fiyatını bulun veya çalışan kimliğine göre bir çalışan adı bulun.

İpucu: DÜŞEYARA ile ilgili daha fazla yardım için Microsoft Creators'un bu YouTube videolarını izleyin!

En basit biçimiyle, DÜŞEYARA işlevi şunu söyler:

=DÜŞEYARA(Ne arama yapmak istediğiniz, nerede arama yapmak istediğiniz, aralıkta, sonuç olarak değeri içeren sütun numarası; 1/DOĞRU veya 0/YANLIŞ olarak gösterilen Yaklaşık veya Tam eşleşme döndürür).

Tarayıcınız video desteklemiyor.

İpucu: DÜŞEYARA'nın sırrı, verilerinizi düzenleyecek şekilde, sizin baktığınız değerin (Meyve) bulmak istediğiniz dönüş değerinin (Tutar) sol tarafta yer aladır.

Tabloda bir değeri aramak için DÜŞEYARA işlevini kullanın.

Söz dizimi

DÜŞEYARA(aranan_değer, tablo_dizisi, sütun_indis_sayısı, [aralık_bak])

Örneğin:

  • =DÜŞEYARA(A2,A10:C20,2,DOĞRU)

  • =DÜŞEYARA("Fontana",B2:E7,2,YANLIŞ)

  • =DÜŞEYARA(A2,'İstemci Ayrıntıları'! A:F,3,YANLIŞ)

Bağımsız değişken adı

Açıklama

aranan_değer    (gerekli)

Aramak istediğiniz değer. Arama yapmak istediğiniz değer, bağımsız değişkende belirttiğiniz hücre aralığının ilk sütununda table_array gerekir.

Örneğin, tablo dizisi B2:D7 hücrelerine yayılmışsa, lookup_value B sütununda yer alıyor olmalı.

Lookup_value bir değer veya hücre başvurusu olabilir.

tablo_dizisi    (gerekli)

DÜŞEYARA işlevinin aranan_değeri ve dönüş değerini bulmak için arama yapacağı hücre aralığı. Adlandırılmış aralık veya tablo kullanabilir ve bağımsız değişkende hücre başvuruları yerine adları kullanabilirsiniz. 

Hücre aralığındaki ilk sütun veri aralığını lookup_value. Hücre aralığının, bulmak istediğiniz dönüş değerini de içermesi gerekir.

Çalışma sayfasında aralıkları seçmeyi öğrenin.

sütun_indis_sayısı    (gerekli)

Dönüş değerini içeren sütun numarası (en sol sütun için 1'den table_array)

aralık_bak    (isteğe bağlı)

DÜŞEYARA işlevinin yaklaşık eşleşme mi yoksa tam eşleşme mi bulmasını istediğinizi belirten mantıksal değer:

  • Yaklaşık eşleşme - 1/DOĞRU, tablodaki ilk sütunun sayısal veya alfabetik olarak sıralanmış olduğunu varsayarak en yakın değeri aratır. Yöntem belirtmezseniz, varsayılan yöntem olarak bu kullanılır. Örneğin, =DÜŞEYARA(90,A1:B100,2,DOĞRU).

  • Tam eşleşme - 0/YANLIŞ, ilk sütunda tam değeri arar. Örneğin, =DÜŞEYARA("Demir",A1:B100,2,YANLIŞ).

Nasıl başlanır

DÜŞEYARA söz dizimini oluşturmak için dört ayrı bilgiye ihtiyacınız vardır:

  1. Arama değeri olarak da adlandırılan, aramak istediğiniz değer.

  2. Arama değerinin yer aldığı aralık. DÜŞEYARA işlevinin düzgün çalışması için, arama değeri her zaman aralıktaki ilk sütunda olmalıdır. Örneğin, arama değeriniz C2 hücresindeyse aralığınız C ile başlamalıdır.

  3. Aralıkta, dönüş değerini içeren sütunun numarası. Örneğin, aralık olarak B2:D11 belirtirsiniz, B'yi ilk sütun, C'yi ikinci sütun olarak saymalı ve bu şekilde devam gerekir.

  4. İsteğe bağlı olarak, dönüş değerine yönelik yaklaşık bir eşleşme elde etmek için DOĞRU, tam eşleşme elde etmek için YANLIŞ değerini belirtebilirsiniz. Hiçbir şey belirtmezseniz, varsayılan değer her zaman için DOĞRU veya yaklaşık eşleşme olur.

Yukarıda açıklananları şu şekilde toparlayabiliriz:

=DÜŞEYARA(arama değeri, arama değerini içeren aralık, aralıkta dönüş değerini içeren sütun numarası, Yaklaşık eşleşme (DOĞRU) veya Tam eşleşme (YANLIŞ)).

Örnekler

DüşEYARA'ya birkaç örnek aşağıda verilmiştir:

Örnek 1

DÜŞEYARA Örneği 1

Örnek 2

DÜŞEYARA Örneği 2

Örnek 3

DÜŞEYARA Örneği 3

Örnek 4

DÜŞEYARA Örneği 4

Örnek 5

DÜŞEYARA Örneği 5

Tablolardan birinin tüm diğerleriyle ortak alanları olduğu sürece, düşEYARA'ya kullanarak birden çok tablo birleştirebilirsiniz. Veri kaynaklarını tek bir tabloda birleştirerek ve veri özelliğinin veri kaynağını yeni tabloyla değiştirerek, veri özelliği eski Excel sürümlerinde kullanılabilir (veri özelliğinin kendisi eski sürüm tarafından destek sağlandıysa).

Diğer tablolardan veri almak için DÜŞEYARA'nın sütunlarını içeren çalışma sayfası

Burada, A-F ve H sütunlarında yalnızca çalışma sayfasındaki değerleri kullanan değerler veya formüller vardır ve sütunların geri kalanı DÜŞEYARA ve A sütunu (İstemci Kodu) ile B sütunlarının değerleri diğer tablolardan veri almak için kullanılır.

  1. Ortak alanları olan tabloyu yeni bir çalışma sayfasına kopyalayın ve bir ad girin.

  2. İlişkileri Yönet > iletişim kutusunu > Veri Araçları ve İlişkiler'i tıklatın.

    İlişkileri Yönet iletişim kutusu
  3. Listelenen her ilişki için aşağıdakilere dikkat edin:

    • Tabloları (iletişim kutusunda parantez içinde listelenmiş) bağlantı alanı. DÜŞEYARA lookup_value için bu formül formülünü kullanın.

    • İlgili Arama Tablosu adı. DÜŞEYARA formül table_array bu formülde yer alan formül.

    • İlişkili Arama Tablosunda yer alan ve yeni sütunda istediğiniz verileri içeren alan (sütun). Bu bilgiler İlişkileri Yönet iletişim kutusunda gösterilmez; hangi alanı almak istediğinize bakmak için İlişkili Arama Tablosuna bakmaniz gerekir. Sütun numarasını (A=1) not etmek istediğiniz için, formül col_index_num değerdir.

  4. Yeni tabloya alan eklemek için, 3. adımda toplanmış bilgileri kullanarak DÜŞEYARA formülünü ilk boş sütuna girin.

    Örneğimizde G sütununda, Avukatlar çalışma sayfası tablosundan (lookup_value col_index_num= 4) dördüncü sütundan (col_index_num = 4) =DÜŞEYARA([@Attorney],tbl_Attorneys,4,YANLIŞ)formülüyle Birlikte Avukat (table_array)kullanılır.

    Formül bir hücre başvurusu ve aralık başvurusu da kullanabilir. Örneğimizde, =DÜŞEYARA(A2,'Avukatlar' olabilir! A:D,4,YANLIŞ).

  5. Size gereken tüm alanları ekleyene kadar alanları eklemeye devam eder. Birden çok tablo kullanan veri özellikleri içeren bir çalışma kitabını hazırlamaya çalışıyorsanız, veri özelliğinin veri kaynağını yeni tabloyla değiştirebilirsiniz.

Sorun

Nerede sorun çıktı?

Yanlış değer verdi

Aralık_bak değeri DOĞRU ise veya boş bırakılmışsa, ilk sütunun alfabetik veya sayısal olarak sıralanması gerekir. İlk sütun sıralanmamışsa, verilen değer beklenmedik bir şey olabilir. İlk sütunu sıralayın veya tam eşleşme için YANLIŞ değerini kullanın.

Hücrede #YOK değeri

  • Aralık_bak değeri DOĞRU ise, aranan_değer bağımsız değişkenindeki değer tablo_dizisi’nin ilk sütunundaki en küçük değerden daha küçük olduğunda #YOK hata değerini alırsınız.

  • Aralık_bak YANLIŞ ise, #YOK hata değeri tam sayının bulunamadığını gösterir.

DÜŞEYARA işlevindeki #YOK hatalarını düzeltme hakkında daha fazla bilgi için bkz. DÜŞEYARA işlevindeki #YOK hatasını düzeltme.

Hücrede #BAŞV! değeri

Sütun_indis_sayısı değeri tablo-dizisi içindeki sütunların sayısından büyükse, #BAŞV! hata değerini alırsınız.

Sorunları çözme hakkında daha fazla bilgi #REF! hataları için bkz. #REF! hatasını düzeltme.

Hücrede #DEĞER! değeri

Tablo_dizisi 1’den küçükse, #DEĞER! hata değerini alırsınız.

Sorunları çözme hakkında daha fazla bilgi #VALUE! hataları için bkz. DÜŞEYARA işlevinde #VALUE! hatasını düzeltme.

Hücrede #AD? değeri

#AD? hata değeri, çoğunlukla formülde tırnak işaretlerinin eksik olduğu anlamına gelir. Bir kişinin adını aramak için, formüldeki adda tırnak işaretlerini kullandığınızdan emin olun. Örneğin, =DÜŞEYARA("Fontana",B2:E7,2,YANLIŞ) içinde adı "Fontana" olarak girin.

Daha fazla bilgi için bkz. Bir hata #NAME! hatası.

Excel’de #SPILL! var

Bu özel #SPILL! hatası genellikle formüllerin arama değeri için örtülü kesişimini kullanıyor ve başvuru olarak sütunun tamamını kullanıyor olduğu anlamına gelir. Örneğin, =DÜŞEYARA(A:A,A:C,2,YANLIŞ). Arama başvurularını şu şekilde @ işleciyle sabitleerek sorunu çözesiniz: =DÜŞEYARA(@A:A,A:C,2,YANLIŞ). Alternatif olarak, geleneksel DÜŞEYARA yöntemini kullanabilir ve sütunun tamamı yerine tek bir hücreye başvurebilirsiniz: =DÜŞEYARA( A2 ,A:C,2,YANLIŞ).

Bunu yapın

Neden?

Aralık_bak için mutlak başvurular kullanın

Mutlak başvurular kullanmak, formülü her zaman tam olarak aynı arama aralığına bakacak şekilde aşağı doğru doldurmanıza olanak tanır.

Mutlak hücre başvurularının nasıl kullanıldığını öğrenin.

Sayı veya tarih değerlerini metin olarak depolamayın.

Sayı veya tarih değerlerini ararken tablo_dizisinin ilk sütunundaki verilerin metin değerleri olarak depolanmamış olduğundan emin olun. Yoksa, DÜŞEYARA yanlış veya beklenmeyen bir değer verebilir.

İlk sütunu sıralayın

aralık_bak değeri DOĞRU olduğunda, DÜŞEYARA’yı kullanmadan önce tablo_dizisi değerinin ilk sütununu sıralayın.

Joker karakterler kullanın

Range_lookup YANLIŞ ise ve lookup_value ise, metinde soru işareti (?) ve yıldız işareti (*) gibi joker karakterleri lookup_value. YANLIŞ'sa ve aranan_değer metinse, aranan_değer’de joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. Yıldız işareti bir dizi karakteri eşleştirir. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Örneğin, =DÜŞEYARA("Fontan?",B2:E7,2,YANLIŞ) fontananın son harfi değişebiliyor tüm örneklerini aratır.

Verilerinizde hatalı karakterler kullanılmadığından emin olun.

İlk sütundaki metin değerlerini ararken, ilk sütunda metnin başında boşluklar, sonunda boşluklar, tutarsız kullanılmış düz ( ' veya " ) ya da kıvrımlı ( ‘ veya “) tırnak işaretleri veya yazdırılamayan karakterler bulunmadığından emin olun. Bunlar varsa, DÜŞEYARA beklenmeyen bir değer verebilir.

Doğru sonuçlar almak için, hücrede tablo değerlerini izleyen sondaki boşlukları kaldırmak üzere TEMİZ işlevini veya KIRP işlevini kullanmayı deneyin.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Hızlı Başvuru Kartı: DÜŞEYARA yenilenmesi
Hızlı Başvuru Kartı: DÜŞEYARA sorun giderme ipuçları
YouTube: Microsoft Creators'tan DÜŞEYARA videoları
DÜŞEYARA işlevinde #VALUE! hatasını düzeltme
DÜŞEYARA işlevinde #N/A hatasını düzeltme
Excel'de formüllere genel bakış
Bozuk formülleri önleme
Formüllerde hataları algılama
Excel işlevleri (alfabetik)
Excel işlevleri (kategoriye göre)
DÜŞEYARA (ücretsiz önizleme)

Daha fazla yardıma mı ihtiyacınız var?

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×