Diğer çalışma kitaplarına (bağlantı olarak da adlandırılan) dış başvurular musunuz? Bu önemlidir çünkü başka biri bağlantılı hücrenin değerini değiştirirse, Excel hücre bağlantıyı güncelleştirmez ve siz söylemedikçe yeni değeri görüntülemez.

Bağlantıları içeren çalışma kitabı hedef çalışma kitabı, bağlı olduğu çalışma kitabı ise kaynak çalışma kitabı olarak adlandırılan bir çalışma kitabıdır. Birden çok kaynak çalışma kitabını tek bir hedef çalışma kitabına bağabilirsiniz.

Çalışma kitabı bağlantılar içeriyor

1. Hedef çalışma kitabı dış başvuru (bağlantı) içerir.

2. Dış başvuru (veya bağlantı), kaynak çalışma kitabındaki bir hücre veya aralığın başvurusuysa.

3. Kaynak çalışma kitabı bağlı hücreyi veya aralığı ve hedef çalışma kitabına döndürülen gerçek değeri içerir.

Not: Bağ yalnızca bağy kitabının sayısında bir sınırlama yoktur, ancak genellikle mümkün olduğunca az çalışma kitabına bağlantı yapmak iyi bir fikirdir. Aksi takdirde, formülün yeniden hesaplanmasında performans sorunlarıyla yol açabilirsiniz. Ayrıca, her biri hem kaynak hem de hedef gibi davranarak çalışma kitaplarını birbirine bağlamanız da mümkündür, ancak bu durum kafa karıştırıcı ve yönetimi zor olabilir.

Kaynak ve hedef çalışma kitapları aynı bilgisayarda açıldığında, bağlantılar otomatik olarak güncelleştirilir. Kaynak çalışma kitabı açık değilken hedef çalışma kitabını açtığınızda, Güvenlik Çubuğu tarafından bağlantıların güncelleştirilip güncelleştirilmeyeceği yönünde bir uyarı alırsınız. Güvenlik Çubuğu'nun size uyarıda bulunup bulunmamasını ve uyarı görüntülenmediğinde tüm bağlantıların güncelleştirilip güncelleştirilmeyeceğini denetleyebilirsiniz. Çalışma kitabında birden çok bağlantı varsa, yalnızca belirli bağlantıları güncelleştirmeyi de seçebilirsiniz.

Aşağıdaki bölümlerde bağlantıların nasıl güncelleştirilmiş olduğunu yönetmek için en yaygın seçenekleri gözden geçir ederiz.

  1. Tüm kaynak çalışma kitaplarını kapatın. Bir kaynak çalışma kitabı açık kalır ve diğerleri kapatılırsa, güncelleştirmeler eşit olmaz.

  2. Hedef çalışma kitabını açın.

  3. Bağlantıları güncelleştirmek için, Güven Çubuğu'ta Güncelleştir'e tıklayın. Bağlantıları güncelleştirmek istemiyorsanız Güven Çubuğunu kapatın (sağ tarafta X'i bakın).

  1. Bağlantıları içeren çalışma kitabını açın.

  2. Veri Kaynağı sorguları > ve Bağlantıları &'>gidin.

    Veri Bağlantıları

  3. Kaynak listesinde güncelleştirmek istediğiniz bağlantılı nesneyi tıklatın.

    Ctrl+tıklama ile veya Ctrl+Atuşlarına basarak tüm çalışma kitaplarını tek tek seçin.

  4. Değerleri Güncelleştir'i tıklatın.

    Excel Veri Sorguları ve Bağlantılar ve Bağlantıları Düzenle > Bağlantılar'& Bağlantıları > iletişim kutusu

  1. Dış başvuru için yeni kaynak olarak kullanmak istediğiniz çalışma kitabını bulun ve konumunu notun.

  2. Hedef çalışma kitabında, değiştirmek istediğiniz dış başvuruya sahip hücreyi seçin.

  3. Kaynak formül çubuğu Düğme resmi, C:\Reports\[Budget.xlsx] gibi başka bir çalışma kitabına başvuru bakın ve bu başvuruyla yeni kaynak çalışma kitabının konumunu değiştirin.

Bu çalışma kitabındaki bağlantıların, dosyayı a açma sırasında kullanıcının ayarına göre güncelleştirilip güncelleştirilmez, dosya açılırken güncelleştirilip güncelleştirilmez veya kullanıcıya sorulmadan otomatik olarak güncelleştirilip güncelleştirilmez.

Uyarı: Bu seçenek çalışma kitabının tüm kullanıcılarını etkiler. Bağlantıları güncelleştirmemeyi ve soru sormamayı seçerseniz, çalışma kitabı kullanıcıları verilerin eskimiş olduğunu bilmeyecektir.

  1. Veri Kaynağı sorguları > ve Bağlantıları &'>gidin.

  2. Başlangıç Komutu'nu tıklatın.

  3. Aşağıdaki üç seçenekten birini belirleyin:

  • Kullanıcıların uyarı görüntülemeyi seçmesine izin verme veya görüntüleme

  • Uyarıyı görüntüleme ve bağlantıları otomatik olarak güncelleştirme

  • Uyarıyı ve güncelleştirme bağlantılarını görüntülemeyin.

Notlar: 

  • Otomatik - El ile güncelleştirme seçenekleri - Formül bağlantıları her zaman Otomatik olarak ayarlanır.

  • Bağlantıların güncelleştirilip güncelleştiril Excel sorulmayacaklarını belirtse bile, bozuk bağlantılar varsa sizebildirilecek.

Bağlantıları Düzenle iletişim kutusunu(Veri > Sorguları & Bağlantılar > Düzenle)açarsanız, size mevcut bağlantılarla ilgilenmek için çeşitli seçenekler görüntülenir. Ctrl+tıklama ile veya Ctrl+Atuşlarına basarak tüm çalışma kitaplarını tek tek seçin.

Excel Veri Sorguları ve Bağlantılar ve Bağlantıları Düzenle > Bağlantılar'& Bağlantıları > iletişim kutusu
  • Değerleri Güncelleştirme

    Bu, tüm seçili çalışma kitaplarını güncelleştirecek.

  • Kaynağı Değiştir

    Varolan bağlantıları başka bir kaynağın üzerine almak istediğiniz zaman bu seçenek kullanışlıdır. Örneğin, önceki bir yıl çalışma kitabınız olabilir ve yeni yıl başladığında yeni bir çalışma kitabına işaret etmek gerekir. Kaynağı değiştir'i seçerek dosya gezgini iletişim kutusunu başlatabilir ve burada yeni kaynak çalışma kitabına göz atabilirsiniz. Çalışma kitabının birden çok çalışma sayfası varsa, hangisinin bağlantı olacağını belirtmeniz istenir; istediğiniz sayfaya tıklayın ve Tamam'a tıklayın.

    Not: Çalışma kitabını Kaynağı değiştir iletişim kutusundan seçerek kendisine geri işaret etmek mümkündür. Bu, özgün bağlantılı kaynak çalışma kitabına tüm formül bağlantılarını kesecek.

  • Açık Kaynak

    Bu, kaynak çalışma kitabını açar.

  • Bağlantıyı Kesme

    Önemli: Kaynağa olan bağlantıyı kestiğinizde, o kaynağı kullanan tüm formüller geçerli değerlerine dönüştürülür. Örneğin, =TOPLA([Budget.xlsx]Yıllık! C10:C25) kaynak çalışma kitabındaki değerlerin toplamına dönüştürülür. Bu eylem geri alınamay olduğundan, önce dosyanın bir sürümünü kaydetmek iyi olabilir.

    1. Veri sekmesininBağlantılar'daki Sorgular & Bağlantıları Düzenle'ye tıklayın.

    2. Kaynak listesinde kesmek istediğiniz bağlantıları tıklatın.

      Ctrl+tıklama ile veya Ctrl+Atuşlarına basarak tüm çalışma kitaplarını tek tek seçin.

    3. Bağlantıyı Kes'i tıklatın.

      Notlar: 

      • Bağlantı tanımlı bir ad kullandısa, ad otomatik olarak kaldırılamaz, dolayısıyla adı silmek de istemeniz gerekir.

      • Adı silmek için:

      • Dış veri aralığı kullanıyorsanız, sorgunun bir parametresi de başka bir çalışma kitabından gelen verileri kullanabilir. Bu tür bağlantıları denetlemek ve kaldırmak isteyebilirsiniz.

      • Formüller sekmesinde, Tanımlı Adlar grubunda, Ad Yöneticisi'ni tıklatın.

      • Ad sütununda, silmek istediğiniz adı tıklatın ve ardından Sil'i tıklatın.

  • Durumu Denetleme

    Böylece, bağlantılı çalışma kitabının hala geçerli bir kaynak olup olmadığıyla ilgili olarak Bağlantıları Düzenle bölmesinde bir bildirim görüntülenir. Tamam olarak görüntülenir,ancak görüntülenmezse kaynak çalışma kitabını denetlemen gerekir. Birçok durumda, bir kaynak çalışma kitabı taşınmış veya silinmiş olabilir (bağlantıyı keserek). Çalışma kitabı hala varsa, kaynağı değiştir seçeneğini kullanarak çalışma kitabını yeniden bağabilirsiniz.

  • Tek bir formülü hesaplanan değeriyle değiştirebilir miyim?

    Evet. Formülü, değeriyle değiştirdiğiniz zaman, Excel formülü kalıcı olarak kaldırır. Bir formülü bir değerle yanlışlıkla değiştirir ve formülü geri yüklemek için, değeri girdikten Geri Al düğmesi sonra Geri Al'a tıklayın.

    1. Formülü kopyalamak için Ctrl+C tuşlarına basın.

    2. Formülü değeri olarak yapıştırmak için Alt+E+S+V tuşlarına basın veya Giriş> Pano'ya> Yapıştırma > gidin.

  • Kaynakla bağlantılı değilken ne olacak?

    Güncelleştirme'yi tıklatın. Excel bağlı olmayan bir kaynaktan güncelleştirme yapamaz. Örneğin, kaynak bir ağ üzerinde olabilir ve bu ağa bağlı olmayabilirsiniz.

  • Geçerli verilerimin yeni verilerle değiştirilmesini istemiyorum

    Güncelleştirme'yi tıklatın.

  • Son kez güncelleştirmeye çalıştım, ama çok uzun sürdü

    Güncelleştirme'yi tıklatın. Verilerin en güncel biçimiyle çalışmanız gerekmiyorsa, bağlantıyı güncelleştirmemeyi seçerek zamandan kazanabilirsiniz. Çalışma kitabını açtıktan sonra, Veri sekmesinin Bağlantılar grubunda Bağlantıları Düzenle'yi tıklatın ve yalnız ihtiyacınız olan kaynak bağlantılarını güncelleştirin.

  • Çalışma kitabını başka biri oluşturdu ve bu istemi neden görüyorum bilmiyorum

    Güncelleştirme'ye tıklayın veçalışma kitabının sahibine ulaşın. Çalışma kitabında hangi bağlantıların olduğunu da araştırabilirsiniz. Veri sekmesininBağlantılar'daki Sorgular & Bağlantıları Düzenle'ye tıklayın.

  • Komut istemini her zaman aynı şekilde yanıt ediyorum ve tekrar görmek istemiyorum

    Başlatma komutunu tutarlı biçimde yanıtlayabilir ve komutun bu çalışma kitabında görüntülenmemesini sağlayabilirsiniz.

    • Açtığım tüm çalışma kitapları için bana sormadan bağlantıları otomatik olarak güncelleştir    

      Bu seçenek, bilgisayarda açılan her çalışma kitabını etkiler. Çalışma kitabını başka bir bilgisayarda açan kullanıcılar etkilenmez.

      1. Dosya > Seçenekler > Gelişmiş seçeneğine gidin.

      2. Genel altında Bağlantıları otomatik olarak güncelleştirmek için sor onay kutusunu temizleyin. Bu onay kutusu temizlenmişse, bağlantılar otomatik olarak güncelleştirilir ve herhangi bir uyarı görüntülenmez.

    • Bu çalışma kitabının tüm kullanıcıları için aynı şekilde istemde bulun    

      Uyarı: Bu seçenek çalışma kitabının tüm kullanıcılarını etkiler. Bağlantıları güncelleştirmemeyi ve soru sormamayı seçerseniz, çalışma kitabı kullanıcıları verilerin eskimiş olduğunu bilmeyecektir.

      Veri Kaynağı >Bağlantılar &'> Bağlantıları Düzenle > İstemi'ne gidin ve istediğiniz seçeneği belirtin.

      Not: Kopuk bağlantı olduğunda size bildirilmeye devam edecektir.

  • Parametre sorgusu kullanıyorsanız ne olacak?

    1. Güncelleştirme'yi tıklatın.

    2. Hedef çalışma kitabını kapatın.

    3. Kaynak çalışma kitabını açın.

    4. Hedef çalışma kitabını açın.

    5. Güncelleştir'i tıklatın.

    Kaynak çalışma kitabı açık değilse, bir parametre sorgusunun bağlantısı güncelleştirilemez.

  • Neden belirli bir dış bağlantı için güncelleştirme seçeneği olarak "El ile"yi seçey miyim?

    Formül bağlantıları her zaman Otomatik olarak ayarlanır.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×