İki değerin birbirine eşit olmadığından emin olmak istiyorsanız mantıksal işlevlerden biri olan DEĞİL işlevini kullanın.

Örnek

Bağımsız değişkenleri ters çevirmeye örnek olarak NOT işlevi örnekleri.  ÖRN. =NOT(1+1=2)

DEĞİL işlevi, bağımsız değişkeninin değerini tersine çevirir.

DEĞİL işlevinin yaygın kullanımlarından biri de, mantıksal sınama yapan diğer işlevlerin kullanışlılığını artırmaktır. Örneğin EĞER işlevi, bir mantıksal sınama gerçekleştirir ve sınama DOĞRU değerlendirdiğinde bir değeri, YANLIŞ değerlendirdiğinde de başka bir değeri döndürür. DEĞİL işlevini, EĞER işlevinin mantıksal_sınama bağımsız değişkeni olarak kullanarak, tek bir koşul yerine birden fazlasını sınayabilirsiniz.

Söz dizimi

DEĞİL(mantıksal)

DEĞİL işlevi söz diziminin bağımsız değişkenleri şunlardır:

  • Mantıksal    Gerekli. DOĞRU veya YANLIŞ olarak değerlendirilebilecek değerdir.

Açıklamalar

Mantıksal değer YANLIŞ ise DEĞİL, DOĞRU döndürür; mantıksal DOĞRU ise DEĞİL, YANLIŞ döndürür.

Örnekler

DEĞİL’in kendi başına ve EĞER, VE ve YADA ile kullanımına yönelik örnekleri aşağıda bulabilirsiniz.

DEĞİL, EĞER, VE ve YADA işlevlerinin örnekleri

Formül

Açıklama

=DEĞİL(A2>100)

A2, 100’den büyük DEĞİL

=EĞER(VE(DEĞİL(A2>1),DEĞİL(A2<100)),A2,"Değer aralık dışı")

50, 1'den büyüktür (DOĞRU) VE 50, 100'den küçük (DOĞRU) olur; bu nedenle, NOT her iki bağımsız değişkeni de YANLIŞ'a ters çevirmez. VE, her iki bağımsız değişkenin de DOĞRU olması için YANLIŞ olursa sonucu döndürür.

=EĞER(YADA(DEĞİL(A3<0),DEĞİL(A3>50)),A3,"Değer aralık dışı")

100, 0'dan küçük değildir (YANLIŞ) ve 100, 50'den büyüktür (DOĞRU). Bu nedenle, DEĞER, bağımsız değişkenleri DOĞRU/YANLIŞ'a ters çevirmez. YADA işlevi yalnızca bir bağımsız değişkenin DOĞRU olması için, DOĞRU olması gereken sonucu döndürür.

Satış Komisyonu hesaplama

DEĞİL’i EĞER ve VE ile kullanarak satış personelinin prime hak kazanıp kazanmadığını hesaplamaya yönelik örneğe bakalım

EĞER, VE ve DEĞİL işlevleriyle satış primi hesaplama örneği.  E14 hücresindeki formül: =EĞER(VE(DEĞİL(B14<$B$7),DEĞİL(C14<$B$5)),B14*$B$8,0)
  • =EĞER(VE(DEĞİL(B14<$B$7),DEĞİL(C14<$B$5)),B14*$B$8,0)- EĞER Toplam Satış, Satış Hedefi’nden az, DEĞİL ise VE Hesaplar, Hesap Hedefi’nden az DEĞİL ise Toplam Satış’ı Komisyon % ile çarp; değilse 0’a dönüştür

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

İlgili Konular

Video: Gelişmiş EĞER işlevleri
Formülde iç içe işlevler kullanmayı öğrenin
EĞER işlevi
VE işlevi
YADA işlevi
Excel'daki formüllere genel Excel
Bozuk formülleri önleme
Formüllerde hataları saptamak için hata denetimi kullanma
Klavye Excel
kısayolları Mantıksal işlevler (başvuru)
Excel (alfabetik)
Excel (kategoriye göre)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×