EĞERHATA işlevi

EğerERROR işlevini formülde hataları yakalama ve işleme için kullanabilirsiniz. EĞERERROR işlevi, bir formül hata değerlendirirse belirttiğiniz değeri döndürür; aksi takdirde, formülün sonucu verir.

Söz Dizimi

EĞERHATA(değer, eğer_hataysa_değer)

EĞERHATA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • değer    Gerekli. Hatayı denetleyen bağımsız değişkendir.

  • value_if_error    Gerekli. Formül bir hata değerlendirirse, geri dönecek değerdir. Aşağıdaki hata türleri değerlendirilir: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, veya #NULL!.

Notlar

  • Değer veya value_if_error boş bir hücre ise, EĞEREROR bunu boş bir dize değeri ("") olarak kabul eder.

  • Değer bir dizi formülü ise, EĞERERROR işlevi değerde belirtilen aralıkta yer alan her hücre için bir sonuç dizisi döndürür. Aşağıda ikinci örneğe bakın.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçin, F2 tuşuna ve sonra da Enter tuşuna basın.

Kota

Satılan Birimler

210

35

55

0

23

Formül

Açıklama

Sonuç

=EĞERHATA(A2/B2, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=EĞERHATA(A3/B3, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=EĞERHATA(A4/B4, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler ("" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir.

0

Örnek 2

Kota

Satılan Birimler

Oran

210

35

6

55

0

Hesaplama hatası

23

0

Formül

Açıklama

Sonuç

=C2

d>Dizinin ilk öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A2/B2 veya 210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=C3

Dizinin ikini öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A3/B3 veya 55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=C4

Dizinin üçüncü öğesindeki ilk bağımsız değerdeki formül hatasını denetler (A4/B4 veya "" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

0

Not: Microsoft 365'ingeçerli bir sürümünüz varsa, formülü çıkış aralığının sol üst hücresine girebilirsiniz, ardından formülü dinamik bir dizi formülü olarak onaylamak için ENTER tuşuna basın. Aksi takdirde, önce çıkış aralığı seçerek formülün, çıkış aralığının sol üst hücresine girilir ve ardından CTRL+SHIFT+ENTER tuşlarına basarak formülün eski bir dizi formülü olarak girilebilir. Excel sizin için formülün başına ve sonuna küme ayraçları ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Daha fazla yardıma mı ihtiyacınız var?

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×