Sign in with Microsoft
New to Microsoft? Create an account.

EĞERERROR işlevini formülde hataları yakalama ve işleme için kullanabilirsiniz. EĞERERROR işlevi, bir formül hata değerlendiriyorsa belirttiğiniz bir değeri döndürür; aksi takdirde, formülün sonucu verir.

Söz Dizimi

EĞERHATA(değer, eğer_hataysa_değer)

EĞERHATA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • değer    Gerekli. Hatayı denetleyen bağımsız değişkendir.

  • value_if_error    Gerekli. Formül hata değerlendirip değerlendirmezse, geri dönecek değerdir. Aşağıdaki hata türleri değerlendirilir: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? veya #NULL!.

Notlar

  • Değer veya value_if_error boş bir hücre ise, EĞERERROR bunu boş bir dize değeri ("") olarak kabul eder.

  • Değer bir dizi formülü ise, EĞERERROR işlevi değerde belirtilen aralıkta yer alan her hücre için sonuç dizisini verir. Aşağıda ikinci örneğe bakın.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçin, F2 tuşuna ve sonra da Enter tuşuna basın.

Kota

Satılan Birimler

210

35

55

0

23

Formül

Açıklama

Sonuç

=EĞERHATA(A2/B2, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=EĞERHATA(A3/B3, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=EĞERHATA(A4/B4, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler ("" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir.

0

Örnek 2

Kota

Satılan Birimler

Oran

210

35

6

55

0

Hesaplama hatası

23

0

Formül

Açıklama

Sonuç

=C2

d>Dizinin ilk öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A2/B2 veya 210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=C3

Dizinin ikini öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A3/B3 veya 55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=C4

Dizinin üçüncü öğesindeki ilk bağımsız değerdeki formül hatasını denetler (A4/B4 veya "" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

0

Not: Microsoft 365'ingeçerli bir sürümünüz varsa, formülü çıkış aralığının sol üst hücresine girebilirsiniz ve ardından ENTER tuşuna basarak formülü dinamik dizi formülü olarak onaylayın. Aksi takdirde, önce çıkış aralığı seçilip çıkış aralığının sol üst hücresine formül girilir ve ardından CTRL+SHIFT+ENTER tuşlarına basarak formülün bir eski dizi formülü olarak girilir. Excel sizin için formülün başına ve sonuna küme ayraçları ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×