ETOPLA işlevi

ETOPLA işlevini, belirttiğiniz ölçüte uyan bir aralıkta yer alan değerlerin toplamını almak için kullanırsınız. Örneğin sayıların bulunduğu bir sütunda yalnızca 5'ten büyük olan değerlerin toplamını hesaplamak istediğinizi varsayalım. Şu formülü kullanabilirsiniz: =ETOPLA(B2:B25,">5")

Duyurularla büyük bir etki yaratma

Bu video, Excel 'de numara eklemeadındaki eğitim kursunun bir bölümüdür.

İpuçları: 

  • İsterseniz, ölçütü bir aralığa uygulayıp farklı bir aralıkta bunlara karşılık gelen değerlerin toplamını alabilirsiniz. Örneğin, =ETOPLA(B2:B5, "Can", C2:C5) formülü yalnızca C2:C5 aralığında yer alan ve B2:B5 aralığındaki ilişkili hücrelerin "Can" değerine eşit olduğu değerlerin toplamını alır.

  • Birden çok ölçüt temelinde hücrelerin toplamını almak için bkz. ÇOKETOPLA işlevi.

Önemli: ETOPLA işlevi, 255 karakterden uzun dizeleri eşleştirmek için veya #VALUE!dizesine yanlış sonuçlar döndürüyor.

Söz dizimi

ETOPLA(aralık; ölçüt; [toplam_aralığı])

ETOPLA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • aralık   Gereklidir. Ölçüte göre değerlendirilmesini istediğiniz hücre aralığı. Aralıklardaki hücrelerde numaralar veya adlar, diziler ya da sayı içeren başvurular bulunmalıdır. Boşluk ve metin değerleri yoksayılır. Seçilen aralık standart Excel biçiminde tarihler içerebilir (aşağıdaki örnekler).

  • ölçüt   Gereklidir. Hangi hücrelerin sayılacağını tanımlayan sayı, ifade, hücre başvurusu, metin ya da hangi hücrelerin toplanacağını tanımlayan bir işlev biçimindeki ölçüt. Joker karakterler dahil olabilir: bir soru işareti (?) tek bir karakterle eşleşecek şekilde, herhangi bir karakter dizisini eşleştirmek için yıldız işareti (*). Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

    Örneğin, ölçüt 32, ">32", B5, "3?", "Apple *", "* ~?" veya bugün () olarak ifade edilebilir.

    Önemli: Tüm metin ölçütleri ve mantıksal ya da matematiksel simge içeren ölçütler çift tırnak (") içine alınmalıdır. Ölçüt sayısal bir değerse, çift tırnak kullanmak gerekmez.

  • toplam_aralığı   İsteğe bağlı. Aralık bağımsız değişkeninde belirtilen hücrelerden farklı hücrelerin toplamını almak istiyorsanız, toplamı alınacak hücreler. Toplam_aralığı bağımsız değişkeni belirtilmezse, Excel aralık bağımsız değişkeninde belirtilen hücreleri toplar (bunlar, ölçütün uygulandığı hücrelerdir).

    Sum_range , Aralıkile aynı boyutta ve şekilde olmalıdır. Değilse, performans düşebilir ve formül, Sum_Range ilk hücreyle başlayan ancak Aralıkile aynı boyutlara sahip bir hücre aralığını toplar. Örneğin:

    aralık

    toplam_aralığı

    Fiili toplam hücreler

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Örnekler

Örnek 1

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Mülk Değeri

Komisyon

Veri

100.000 TL

7.000 TL

250.000 TL

200.000 TL

14.000 TL

300.000 TL

21.000 TL

400.000 TL

28.000 TL

Formül

Açıklama

Sonuç

=ETOPLA(A2:A5,">160000",B2:B5)

160.000'in üzerindeki mülk değerleri için komisyon toplamı.

63.000 TL

=ETOPLA(A2:A5,">160000")

160.000'in üzerindeki mülk değerlerinin toplamı.

900.000 TL

=ETOPLA(A2:A5,300000,B2:B5)

300.000'e eşit mülk değerleri için komisyon toplamı.

21.000 TL

=ETOPLA(A2:A5,">" & C2,B2:B5)

C2 hücresindeki değerden büyük mülk değeri için komisyonların toplamı.

49.000 TL

Örnek 2

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın. Gerekirse, tüm verileri görmek için sütun genişliğini ayarlayabilirsiniz.

Kategori

Yiyecek

Satışlar

Sebzeler

Karnabahar

2.300 TL

Sebzeler

Kereviz

5.500 TL

Meyveler

Portakal

800 TL

Tereyağı

400 TL

Sebzeler

Havuç

4.200 TL

Meyveler

Elma

1.200 TL

Formül

Açıklama

Sonuç

=ETOPLA(A2:A7,"Meyveler",C2:C7)

"Meyveler" kategorisindeki tüm besinlerin satışlarının toplamı.

2.000 TL

=ETOPLA(A2:A7,"Sebzeler",C2:C7)

"Sebzeler" kategorisindeki tüm besinlerin satışlarının toplamı.

12.000 TL

=ETOPLA(B2:B7,"ka*",C2:C7)

"Ka" ile başlayan tüm besinlerin (Karnabahar, Kayısı ve Kavun) satışlarının toplamı.

4.300 TL

=ETOPLA(A2:A7,"",C2:C7)

Kategorisi belirtilmemiş olan tüm besinlerin satışlarının toplamı.

400 TL

Sayfanın Başı

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca bkz.

ÇOKETOPLA işlevi, birden çok ölçüte uyan tüm bağımsız değişkenleri toplar

TOPKARE işlevi, birden çok değeri toplamadan önce her değer üzerinde bir matematiksel karesini alma işlemi yapar

EĞERSAY işlevi yalnızca tek bir ölçüte uyan değerleri sayar

ÇOKEĞERSAY işlevi yalnızca birden çok ölçüte uyan değerleri sayar

ÇOKEĞER işlevi (Office 365, Excel 2016 ve sonrası)

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Matematik ve Trigonometri işlevleri

Excel işlevleri (alfabetik)

Excel işlevleri (Kategoriye göre)

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×