Listelerde yaygın formül örnekleri

Listelerde yaygın formül örnekleri

Listelerde hesaplanan sütunlarda formüllerin kullanımı, fiyat üzerinde satış vergisini hesaplama gibi mevcut sütunlara eklemeye yardımcı olabilir. Bunlar, verileri programatik olarak doğrulamak için bir arayalanabilir. Hesaplanmış sütun eklemek için, + sütun ekle'yetıklayın ve Diğer öğesini seçin. 

Not: Hesaplanan alanlar yalnızca kendi satırları üzerinde çalışır, bu nedenle başka bir satırdaki değere ya da başka bir liste veya kitaplıkta bulunan sütunlara başvuramazsınız. Formülde arama alanları desteklenmemektedir ve yeni eklenen satırın kimliği, formül işlendiğinde Kimlik var olduğundan kullanılamaz.

Formüller girerken, aksi belirtilmedikçe anahtar sözcükler ve işleçler arasında boşluk olmaz.

Aşağıdakiler çok kapsamlı bir liste değildir. Tüm formülleri görüntülemek için, bu makalenin sonundaki alfabetik listeye bakın.

Ayrıntılı yönergeleri görmek için aşağıdaki başlıklardan birini seçerek açın. 

Tamam veya Tamam değil gibi alternatif bir değeri sınamak ya da null değeri temsil eden boş veya kısa çizgi değeri geri dönmek için, deyim koşullarını sınamak ve Evet veya Hayır değeri dönmek için aşağıdaki formülleri kullanabilirsiniz.

Bir say ın başka bir sayıdan büyük veya küçük olup olduğunu denetleme

Bu karşılaştırmayı yapmak için EĞER işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

15000

9000

=[Sütun1]>[Sütun2]

Sütun1, Sütun2'den büyük mü? (Evet)

15000

9000

=EĞER([Sütun1]<=[Sütun2], "Tamam", "Tamam Değil")

Sütun1, Sütun2'den küçük mü yoksa eşit mi? (Tamam değil)

Sütun içeriğini karşılaştırdikten sonra mantıksal bir değer verir

Mantıksal değer (Evet veya Hayır) olan bir sonuç için VE, YADAve NOT işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (olası sonuç)

15

9

8

=VE([Sütun1]>[Sütun2], [Sütun1]<[Sütun3])

15, 9'dan büyük ve 8'den küçük mü? (Hayır)

15

9

8

=YADA([Sütun1]>[Sütun2], [Sütun1]<[Sütun3])

15, 9'dan büyük veya 8'den küçük mü? (Evet)

15

9

8

=NOT([Sütun1]+[Sütun2]=24)

15 artı 9, 24'e eşit değildir mi? (Hayır)

Başka bir hesaplama veya Evet veya Hayır dışında herhangi bir değer olan bir sonuç için EĞER,VEve VE ve VEYA işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (olası sonuç)

15

9

8

=EĞER([Sütun1]=15, "Tamam", "Tamam Değil")

Sütun1'in değeri 15'e eşitse, "Tamam" değerini verir. (OK)

15

9

8

=EĞER(VE([Sütun1]>[Sütun2], [Sütun1]<[Sütun3]), "Tamam", "Tamam Değil")

15, 9'dan büyük ve 8'den küçükse, "Tamam" dön. (Tamam değil)

15

9

8

=EĞER(YADA([Sütun1]>[Sütun2], [Sütun1]<[Sütun3]), "Tamam", "Tamam Değil")

15, 9'dan büyük veya 8'den küçükse, "Tamam" ifadesini geri seçin. (OK)

Sıfırları boşluk veya tire olarak görüntüleme

Sıfır görüntülemek için basit bir hesaplama gerçekleştirin. Boş veya kısa çizgi görüntülemek için, EĞER işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

10

10

=[Sütun1]-[Sütun2]

İkinci sayı ilk sayıdan çıkarılır (0)

15

9

=EĞER([Sütun1]-[Sütun2],"-",[Sütun1]-[Sütun2])

Değer hatalı olduğunda, bir kısa çizgi işareti döndürülür (-)

Sütunlarda hata değerlerini gizleme

Hata değeri yerine kısa #N, A/A veya YOKSAY değerini görüntülemek için EHATALISA işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

10

0

=[Sütun1]/[Sütun2]

Bir hataya (#SAYI/0) yol açar

10

0

=EĞER(EHATALISA([Sütun1]/[Sütun2]),"YOKSAY",[Sütun1]/[Sütun2])

Değer hatalıysa, YOKSAY değerini verir

10

0

=EĞER(EHATALISA([Sütun1]/[Sütun2]),"-",[Sütun1]/[Sütun2])

Değer hatalıysa, bir kısa çizgi işareti verir

Boş alanları denetleme

Boş alanları bulmak için ISBLANK formülünü kullanabilirsiniz.

Sütun1

Formül

Açıklama (olası sonuç)

"Jelly beans"

=EDA([Sütun1]

Boşsa veya boş yoksa Evet veya Hayır döndürür

"Çelik"

=EĞER(ALAN([Sütun1]), "Tamam Değil", "Tamam")

Kendi tercihlerinizi doldurun; önce boşsa, ikinci seçenek boşsa

Diğer E işlevleri için bkz. E işlevleri.

Tarihe gün, ay veya yıl sayısı ekleme, iki tarih arasındaki farkı hesaplama ve zamanı ondalık değere dönüştürme gibi tarih ve saatlere dayalı hesaplamalar yapmak için aşağıdaki formülleri kullanabilirsiniz.

Tarih ekleme

Tarihe gün sayısı eklemek için toplama (+) işlecini kullanın.

Not: Tarihleri işlerken, hesaplanmış sütunun dönüş türü Tarih ve Saat olarak ayarlanmalı.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

6/9/2007

3

=[Sütun1]+[Sütun2]

9/6/2007'ye 3 gün ekler (12/6/2007)

12/10/2008

54

=[Sütun1]+[Sütun2]

10/12/2008'e 54 gün ekler (2/2/2009)

Bir tarihe ay sayısı eklemek için, DATE ,YEAR, MONTHve DAY işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

6/9/2007

3

=DATE(YEAR([Sütun1]),AY([Sütun1])+[Sütun2],GÜN([Sütun1]))

9/6/2007'ye 3 ay ekler (9/9/2007)

12/10/2008

25

=DATE(YEAR([Sütun1]),AY([Sütun1])+[Sütun2],GÜN([Sütun1]))

10/12/2008'e 25 ay ekler (10/1/2011)

Tarihe yıl sayısı eklemek için, DATE ,YEAR, MONTHve DAY işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

6/9/2007

3

=DATE(YEAR([Sütun1])+[Sütun2],AY([Sütun1]),GÜN([Sütun1]))

9/6/2007'ye 3 yıl ekler (9/6/2010)

12/10/2008

25

=DATE(YEAR([Sütun1])+[Sütun2],AY([Sütun1]),GÜN([Sütun1]))

10/12/2008'e 25 yıl ekler (10/12/2033)

Tarihe gün, ay ve yıl birleşimini eklemek için, DATE ,YEAR, MONTHve DAY işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

6/9/2007

=DATE(YEAR([Sütun1])+3,AY([Sütun1])+1,GÜN([Sütun1])+5)

9/6/2007'ye 3 yıl, 1 ay, 5 gün ekler (14/7/2010)

12/10/2008

=DATE(YEAR([Sütun1])+1,AY([Sütun1])+7,GÜN([Sütun1])+5)

10/12/2008'e 1 yıl, 7 ay, 5 gün ekler (15/7/2010)

İki tarih arasındaki farkı hesaplama

Bu hesaplamayı gerçekleştirmek için DATEDIF işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

01.01.1995

15-Haz-1999

=DATEDIF([Sütun1], [Sütun2],"d")

İki tarih arasındaki gün sayısını verir (1626)

01.01.1995

15-Haz-1999

=DATEDIF([Sütun1], [Sütun2],"ym")

Tarihler arasındaki ay sayısını verir; yıl bölümü yoksayıldı (5)

01.01.1995

15-Haz-1999

=DATEDIF([Sütun1], [Sütun2],"yd")

Yıl bölümünü (165) yok sayarak, tarihler arasındaki gün sayısını verir

İki saat arasındaki farkı hesaplama

Sonucu standart saat biçiminde (saat:dakika:saniye) sunmak için çıkarma işlecini (-) ve METNEÇEMİr işlevini kullanın. Bu yöntemin çalışması için saatler 24'ü ve dakika ile saniye sayısı da 60'ın üzerinde olmalı.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

09.06.2007 10:35

09.06.2007 15:30

=METNEKEN([Sütun2]-[Sütun1],"s")

İki zaman arasındaki saatler (4)

09.06.2007 10:35

09.06.2007 15:30

=METNEKEN([Sütun2]-[Sütun1],"s:dd")

İki saat (4:55) arasında saat ve dakika

09.06.2007 10:35

09.06.2007 15:30

=METNEKEN([Sütun2]-[Sütun1],"s:dd:ss")

İki zaman arasındaki saat, dakika ve saniye (4:55:00)

Sonucu bir zaman birimini temel alan bir toplamla sunmak için TAMSAYI işlevini veya SAAT ,DAKİKA veyaİkİnCİ işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

09.06.2007 10:35

10.06.2007 15:30

=TT(([Sütun2]-[Sütun1])*24)

İki zaman arasındaki toplam saat sayısı (28)

09.06.2007 10:35

10.06.2007 15:30

=TT(([Sütun2]-[Sütun1])*1440)

İki zaman arasındaki toplam dakika sayısı (1735)

09.06.2007 10:35

10.06.2007 15:30

=TT(([Sütun2]-[Sütun1])*86400)

İki zaman arasındaki toplam saniye (104100)

09.06.2007 10:35

10.06.2007 15:30

=SAAT([Sütun2]-[Sütun1])

Fark 24'ü (4) geçmeyecek şekilde iki zaman arasındaki saat sayısı

09.06.2007 10:35

10.06.2007 15:30

=DAKİKA([Sütun2]-[Sütun1])

Aradaki fark 60'ın (55) üzerindeyken iki zaman arasındaki dakika sayısı

09.06.2007 10:35

10.06.2007 15:30

=SECOND([Sütun2]-[Sütun1])

Fark 60'ın (0) üzerinde değilken iki zaman arasındaki saniye sayısı

Saatleri dönüştürme

Saatleri standart saat biçiminden ondalık sayıya dönüştürmek için INT işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

10:35

=([Sütun1]-TT([Sütun1]))*24

12:00'dan itibaren saat sayısı (10,583333)

12:15

=([Sütun1]-TT([Sütun1]))*24

12:00'den itibaren saat sayısı (12,25)

Ondalık bir sayıdan standart saat biçimine (saat:dakika:saniye) dönüştürmek için bölme işlecini ve METNEÇEVİr işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

23:58

=METNEKEN(Sütun1/24, "ss:dd:ss")

00:00'dan itibaren saatler, dakikalar ve saniyeler (00:59:55)

2:06

=METNETEİr(Sütun1/24, "s:dd")

00:00'dan itibaren saatler ve dakikalar (0:05)

Metin tarihlerini ekleme

Metin tarihi, geçerli yılın bileşimi olan bir tarih biçimine ve yılın başlangıcından bu yana geçen gün sayısına başvurur. Örneğin, 1 Ocak 2007, 2007001 ve 31 Aralık 2007 olarak, 2007365 olarak temsil edildi. Bu biçim, Metin takvimini temel alarak değildir.

Bir tarihi Metin tarihine dönüştürmek için METNETEĞER veDATEVALUE işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

6/23/2007

=METNEKEN([Sütun1],"yy")&METNERİ(([Sütun1]-DATEVALUE("1/1/"& METNERİ([Sütun1],"yy"))+1),"000")

İki basamaklı yıl ile Metin biçimindeki tarih (07174)

6/23/2007

=METNEKEN([Sütun1],"yyyy")&METNEĞİ(([Sütun1]-DATEVALUE("1/1/"&METNERİ([Sütun1],"yy"))+1),"000")

Dört basamaklı bir yıl ile Metin biçimindeki tarih (2007174)

Bir tarihi, astronomda kullanılan Metin tarihine dönüştürmek için 2415018.50 sabiti kullanın. Bu formül yalnızca 1/3/1901'den sonra gelen tarihlerde ve 1900 tarih sistemini kullanıyorsanız çalışır.

Sütun1

Formül

Açıklama (sonuç)

6/23/2007

=[Sütun1]+2415018,50

Astronomda kullanılan Metin biçiminde tarih (2454274,50)

Tarihleri haftanın günü olarak gösterme

Tarihleri haftanın gününü metne dönüştürmek için METNETEVİh ve HAFTANIN GÜNİişlevlerini kullanın.

Sütun1

Formül

Açıklama (olası sonuç)

19.02.2007

=METNEVİr(HAFTANIN GÜNÜ([Sütun1]), "esnas")

Tarih için haftanın günlerini hesaplar ve günün tam adını verir (Pazartesi)

03.02.2008

=METNEVİr(HAFTANIN GÜNÜ([Sütun1]), "esna")

Tarih için haftanın günlerini hesaplar ve günün kısaltılmış adını verir (Bu)

Toplama, çıkarma, çarpma ve bölme, sayıların ortalamasını veya ortasını hesaplama, s sayma ve değerleri sayma gibi çeşitli matematiksel hesaplamalar yapmak için aşağıdaki formülleri kullanabilirsiniz.

Sayıları toplama

Bir satırda iki veya daha fazla sütunda sayı eklemek için toplama işleci (+) veya TOPLA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

6

5

4

=[Sütun1]+[Sütun2]+[Sütun3]

İlk üç sütunda yer alan değerleri ekler (15)

6

5

4

=TOPLA([Sütun1],[Sütun2],[Sütun3])

İlk üç sütunda yer alan değerleri ekler (15)

6

5

4

=TOPLA(EĞER([Sütun1]>[Sütun2], [Sütun1]-[Sütun2], 10), [Sütun3])

Sütun1 Sütun2'den büyükse, farkı ve Sütun3'ü ekler. Ek olarak 10 ve Sütun3 ekleyin (5)

Sayıları çıkarma

Bir satırdaki iki veya daha fazla sütundaki sayıları çıkarmak için çıkarma işleci (-) veya negatif sayılarla TOPLA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

15000

9000

-8000

=[Sütun1]-[Sütun2]

15000'den 9000'i çıkarır (6000)

15000

9000

-8000

=TOPLA([Sütun1], [Sütun2], [Sütun3])

Negatif değerler de içinde olmak üzere, ilk üç sütunda sayıları ekler (16000)

İki sayı arasındaki farkı yüzde olarak hesaplama

Çıkarma (-) ve bölme (/) işleçlerini ve MUTLAK işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

2342

2500

=([Sütun2]-[Sütun1])/ABS([Sütun1])

Yüzde değişimi (%6,75 veya 0,06746)

Sayıları çarpma

Bir satırdaki iki veya daha fazla sütundaki sayıları çarpmak için çarpma işleci (*) veya ÇARPI işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

5

2

=[Sütun1]*[Sütun2]

İlk iki sütunda sayıları çarpar (10)

5

2

=ÜRÜN([Sütun1], [Sütun2])

İlk iki sütunda sayıları çarpar (10)

5

2

=ÜRÜN([Sütun1],[Sütun2],2)

İlk iki sütunda yer alan sayıları ve 2'nin (20) sayısını çarpar

Sayıları bölme

Bir satırdaki iki veya daha fazla sütundaki sayıları bölmek için bölme işleci (/) kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

15000

12

=[Sütun1]/[Sütun2]

15000'i 12'ye böler (1250)

15000

12

=([Sütun1]+10000)/[Sütun2]

15000 ve 10000 eklerini ekler, sonra toplamı 12'ye (2083) böler

Sayıların ortalamasını hesaplama

Ortalamaya, ortalama da denir. Bir satırdaki iki veya daha fazla sütundaki sayıların ortalamasını hesaplamak için ORTALAMA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

6

5

4

=ORTALAMA([Sütun1], [Sütun2],[Sütun3])

İlk üç sütunda yer alan sayıların ortalaması (5)

6

5

4

=ORTALAMA(EĞER([Sütun1]>[Sütun2], [Sütun1]-[Sütun2], 10), [Sütun3])

Sütun1 Sütun2'den büyükse, farkın ve Sütun3'in ortalamasını hesapla. 10 ve Sütun3 değerinin ortalamasını (2,5) başka hesaplama

Sayıların orta değerini hesaplama

Orta değer, sıralı bir sayı aralığının orta değeridir. Bir sayı grubunun orta değerini hesaplamak için ORTA DEĞER işlevini kullanın.

A

B

C

D

E

Ş

Formül

Açıklama (sonuç)

10

7

9

27

0

4

=ORTA DEĞER(A, B, C, D, E, F)

İlk 6 sütunda sayıların ortası (8)

Aralıkta en küçük veya en büyük s numarayı hesaplama

Bir satırdaki iki veya daha fazla sütundaki en küçük veya en büyük s numarayı hesaplamak için Mİn veMAK işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

10

7

9

=MİNA([Sütun1], [Sütun2], [Sütun3])

En küçük sayı (7)

10

7

9

=MAK([Sütun1], [Sütun2], [Sütun3])

En büyük sayı (10)

Değerleri sayma

Sayısal değerleri saymak için SAY işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

Elma

12/12/2007

=SAY([Sütun1], [Sütun2], [Sütun3])

Sayısal değerler içeren sütunların sayısını sayar. Tarih ve saat, metin ve null değerleri dışlar (0)

12 TL

#SAYI/0!

1.01

=SAY([Sütun1], [Sütun2], [Sütun3])

Sayı değerleri içeren sütunları sayar, ancak hata ve mantıksal değerleri dışarıda sayar (2)

Bir sayıyı bir yüzde oranında artırma veya azaltma

Yüzdeyi (%) kullanma işlecine iki işleci de dahil edebilirsiniz.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

23

3%

=[Sütun1]*(1+%5)

Sütun1'in sayısını %5 artırır (24,15)

23

3%

=[Sütun1]*(1+[Sütun2])

Sütun1'in sayısını Sütun2'de yüzde değeriyle artırır: %3 (23,69)

23

3%

=[Sütun1]*(1-[Sütun2])

Sütun1'in sayısını Sütun2'de yüzde değeriyle azaltma: %3 (22,31)

S sayısını bir sayıya yükseltme

Bu hesaplamayı gerçekleştirmek için üs işlecini (^) veya ÜS işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

5

2

=[Sütun1]^[Sütun2]

Beş kareli hesaplama (25)

5

3

=GÜÇ([Sütun1], [Sütun2])

Beş küpü hesaplar (125)

Sayıyı yuvarlama

S numarayı yukarı yuvarlamak için, YUVARLA,TEKveya ÇIFT işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20.3

=YUVARLA([Sütun1],0)

20,3'ü en yakın tamsayıya (21) yukarı yuvarlar

-5.9

=YUVARLA([Sütun1],0)

-5,9'a en yakın tamsayıya (-5) yukarı yuvarlar

12.5493

=YUVARLA([Sütun1],2)

12,5493'ü en yakın yüz, iki ondalık basamak olacak biçimde yukarı yuvarlar (12,55)

20.3

=EVEN([Sütun1])

20,3 sayısını yukarı doğru en yakın iki sayıya (22) yuvarlar

20.3

=TEK([Sütun1])

20,3 sayısını yukarı doğru en yakın tek sayıya (21) yuvarlar

S aşağı doğru yuvarlamak için AYIRLA işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20.3

=ARITMA([Sütun1],0)

20,3'ü en yakın tamsayıya (20) aşağı yuvarlar

-5.9

=ARITMA([Sütun1],0)

-5,9'a en yakın tamsayıya (-6) aşağı yuvarlar

12.5493

=ARITMA([Sütun1],2)

12,5493'ü en yakın yüz, iki ondalık basamağa (12,54) aşağı yuvarlar

Sladırı en yakın sayıya veya kesirye yuvarlamak için YUVARLA işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20.3

=YUVARLA([Sütun1],0)

Kesir bölümü 0,5'den küçük (20) olduğundan 20,3'ü aşağı yuvarlar

5.9

=YUVARLA([Sütun1],0)

Kesir bölümü 0,5'den büyük (6) olduğundan 5,9'a yukarı yuvarlar

-5.9

=YUVARLA([Sütun1],0)

Kesir bölümü -,5'den (-6) küçük olduğundan -5,9'a aşağı yuvarlar

1,25

=YUVARLA([Sütun1], 1)

Sayıyı en yakın onuncu sayıya (bir ondalık basamak) yuvarlar. Yuvarlanacak kısım 0,05 veya daha büyük olduğundan, sayı yukarı yuvarlanmış (sonuç: 1,3)

30.452

=YUVARLA([Sütun1], 2)

Sayıyı en yakın yüz doyma (iki ondalık basamak) yuvarlar. Yuvarlanacak kısım 0,002 olduğundan, sayı 0,005'den küçük olduğundan, sayı aşağı yuvarlanr (sonuç: 30,45)

Bir sladırı 0'ın üzerindeki anlamlı basamaklara yuvarlamak için YUVARLA ,ASIYARA ,AYIRT ,INTve UZUNLUK işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

5492820

=YUVARLA([Sütun1],3-UZUNLUK(TT([Sütun1])))

Sladırı 3 anlamlı basamacak şekilde yuvarlar (5490000)

22230

=ARITME([Sütun1],3-UZUNLUK(TT([Sütun1])))

Alt sladırı aşağı doğru 3 anlamlı basamak olacak şekilde yuvarlar (22200)

5492820

=YUVARLAT([Sütun1], 5-UZUNLUK(TT([Sütun1])))

Üst sladırı en çok 5 anlamlı basamamacak şekilde yuvarlar (5492900)

Birden çok sütunda yer alan değerleri birleştirme, sütunların içeriğini karşılaştırma, karakterleri veya boşlukları kaldırma ve yinelenen karakterler gibi metinleri işlemek için aşağıdaki formülleri kullanabilirsiniz.

Metinde büyük/küçük harfi değiştirme

Metnin büyük/küçük harflerini değiştirmek için BÜYÜK HARF,KÜÇÜKHARF YA DA PROPER işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

olarak Vietzen

=BÜYÜK HARF([Sütun1])

Metni büyük harfe dönüştürür (VIETZEN)

olarak Vietzen

=KÜÇÜK HARF([Sütun1])

Metni küçük harfe dönüştürür (vietzen)

olarak Vietzen

=PROPER([Sütun1])

Metni büyük/harfe (Vietzen) değiştirir

Ad ve last adlarını birleştirme

Ad ve lastaları birleştirmek için, ve işleci (&) veya CONCATENATE işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Yılan

Carvallo

=[Sütun1]&[Sütun2]

İki dizeyi birleştirir (DizeCarvallo)

Yılan

Carvallo

=[Sütun1]&" "&[Sütun2]

Bir boşlukla ayrılmış iki dizeyi birleştirir (Bud KaraDiya Karadila)

Yılan

Carvallo

=[Sütun2]&", "&[Sütun1]

Virgül ve boşlukla ayrılmış iki dizeyi birleştirir (Carvallo, Unvan)

Yılan

Carvallo

=CONCATENATE([Sütun2], ",", [Sütun1])

Virgülle ayrılmış iki dizeyi birleştirir (Carvallo,Alo)

Farklı sütunlardan metin ve sayıları birleştirme

Metinleri ve sayıları birleştirmek için, CONCATENATE işlevini, ve işlecini (&) veya METNEÇEMİr işlevini ve ve işleci kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Yang

28

=[Sütun1]&" "&[Sütun2]sütun2] &" birim sattı."

Yukarıdaki içeriği bir tümcecik olarak birleştirir (Yang 28 birim sattı.)

Dubaku

40%

=[Sütun1]&" toplam satışların "&TEXT([Sütun2],"%0")&" satışı yaptı.

Yukarıdaki içerikleri bir tümcecik olarak birleştirir (Dub söz konusu satışların %40'lık bir oranına satış yaptı.)

Not: METNE GÖRE işlevi, temel alınan değer (0,4) yerine Sütun2'nin biçimlendirilmiş değerini ekler.

Yang

28

=CONCATENATE([Sütun1]," satılan ",[Sütun2]," birimler.)

Yukarıdaki içeriği bir tümcecik olarak birleştirir (Yang 28 birim sattı.)

Metinleri tarih veya saatle birleştirme

Metni tarih veya saatle birleştirmek için, METNEÇEMİr işlevini ve ve (Tarih) işlecini &.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Faturalama Tarihi

5-Haz-2007

="Deyim tarihi: "&TEXT([Sütun2], "d-mmm-yyyy")

Metni tarihle birleştirir (Deyim tarihi: 5-Haz-2007)

Faturalama Tarihi

5-Haz-2007

=[Sütun1]&" "&METNELE([Sütun2], "mmm-d-yyyy")

Farklı sütunlardan metinleri ve tarihi tek sütunda birleştirir (Fatura Tarihi Haz-05-2007)

Sütun içeriğini karşılaştırma

Bir sütunu başka bir sütunla veya değer listesiyle karşılaştırmak için ÖZDEŞ veVEYA işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

BD122

BD123

=ÖZDEŞ([Sütun1],[Sütun2])

İlk iki sütunun içeriğini karşılaştırıldığında (Hayır)

BD122

BD123

=ÖZDEŞ([Sütun1], "BD122")

Sütun1'in içeriğini "BD122" (Evet) ile karşılaştırıldığında

Bir sütun değerinin veya bir kısmının belirli bir metinle eş olup olduğunu denetleme

Bir sütun değerinin veya bir kısmının belirli bir metinle eş olup olduğunu kontrol etmek için, EĞER, BUL,MİSAYıve ESAYISA işlevlerini kullanın.

Sütun1

Formül

Açıklama (olası sonuç)

Vietzen

=EĞER([Sütun1]="Vietzen", "Tamam", "Tamam Değil")

Sütun1'in Vietzen olup olduğunu denetler (Tamam)

Vietzen

=EĞER(ESAYISA(BUL("v",[Sütun1])), "Tamam", "Tamam Değil")

Sütun1'in v harfini içerdiğini denetler (Tamam)

BD123

=ESAYISA(BUL("BD",[Sütun1]))

Sütun1'in BD içerdiğini denetler (Evet)

Nonblank olmayan sütunları sayma

Olmayan sütunları saymak için, COUNTA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

Satışlar

19

=COUNTA([Sütun1], [Sütun2])

Olmayan sütunların sayısını sayar (2)

Satışlar

19

=COUNTA([Sütun1], [Sütun2], [Sütun3])

Olmayan sütunların sayısını sayar (2)

Metinden karakterleri kaldırma

Metinden karakterleri kaldırmak için UZUNLUK, SOLve SAĞDANişlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

Her iki alan da bir

=SOLDAN([Sütun1],UZUNLUK([Sütun1])-2)

Soldan başlayarak (Ali) 7 (9-2) karakter verir

Ayyn B1

=SAĞDAN([Sütun1], UZUNLUK([Sütun1])-8)

Sağdan başlayarak 2 (10-8) karakter (B1) verir

Sütunun başından ve sonundan boşlukları kaldırma

Sütundaki boşlukları kaldırmak için KIRP işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

 Merhaba,!

=KIRP([Sütun1])

Baştan ve bitişten boşlukları kaldırır (Merhaba! )

Sütundaki bir karakteri yineleme

Sütundaki bir karakteri yinelemek için, REPT işlevini kullanın.

Formül

Açıklama (sonuç)

=REPT(".",3)

Bir dönemi 3 kez tekrarlar (...)

=YİNELE("-",10)

Tireyi 10 kez tekrarlar (----------)

Alfabetik işlev listesi

Aşağıda, kullanıcılarına kullanılabilen işlevlerin alfabetik bağlantılarının listesi SharePoint vemektedir. Trigonometri, istatistiksel ve finansal işlevlerin yanı sıra koşullu, tarih, matematik ve metin formüllerini de içerir.

MUTLAK işlevi

ACOS işlevi

ACOSH işlevi

VE işlevi

ASİN işlevi

ASİNH işlevi

ATAN işlevi

ATAN2 işlevi

ORTALAMA işlevi

ORTALAMAA işlevi

BETADAĞ işlevi

BETATERS işlevi

BİNOMDAĞ işlevi

TAVANAYUVARLA işlevi

DAMGA işlevi

KİKAREDAĞ işlevi

ELEMAN işlevi

KOD işlevi

BİRLEŞTİR işlevi

GÜVENİRLİK işlevi

COS işlevi

BAĞ_DEĞ_SAY işlevi

BAĞ_DEĞ_DOLU_SAY işlevi

KRİTİKBİNOM işlevi

TARİH işlevi

TARİHFARKI işlevi

TARİHSAYISI işlevi

GÜN işlevi

GÜN360 işlevi

ÇİFTAZALANBAKİYE işlevi

DERECE işlevi

LİRA işlevi

ÇİFT işlevi

ÖZDEŞ işlevi

ÜSTELDAĞ işlevi

ÇARPINIM işlevi

FDAĞ işlevi

BUL işlevi

FTERS işlevi

FISHER işlevi

SAYIDÜZENLE işlevi

GAMADAĞ işlevi

GAMATERS işlevi

GAMALN işlevi

GEOORT işlevi

HARORT işlevi

SAAT işlevi

HİPERGEOMDAĞ işlevi

EĞER işlevi

TAMSAYI işlevi

IPmt İşlevi

E işlevleri

SOLDAN işlevi

UZUNLUK fonksiyonu

LN işlevi

Log İşlevi

LOG10 işlevi

LOGTERS işlevi

LOGNORMDAĞ işlevi

KÜÇÜKHARF işlevi

MAK işlevi

Ben işlevi

ORTANCA işlevi

PARÇAAL işlevi

MİN işlevi

MİNA işlevi

DAKİKA işlevi

MOD işlevi

AY işlevi

NEGBİNOMDAĞ işlevi

NORMDAĞ işlevi

NORMSDAĞ işlevi

NORMSTERS işlevi

DEĞİL işlevi

TAKSİT_SAYISI işlevi

NBD işlevi

TEK işlevi

YADA işlevi

DEVRESEL_ÖDEME işlevi

KUVVET işlevi

ANA_PARA_ÖDEMESİ işlevi

ÇARPIM işlevi

YAZIM.DÜZENİ işlevi

BD işlevi

RADYAN işlevi

REPLACE işlevi

YİNELE işlevi

SAĞDAN fonksiyonu

YUVARLA işlevi

AŞAĞIYUVARLA işlevi

YUKARIYUVARLA işlevi

MBUL fonksiyonu

SANİYE işlevi

İŞARET işlevi

SİN işlevi

SİNH işlevi

KAREKÖK işlevi

STANDARTLAŞTIRMA işlevi

STDSAPMAA işlevi

STDSAPMAS işlevi

STDSAPMASA işlevi

TOPLA işlevi

TOPKARE işlevi

YAT işlevi

TANH işlevi

TDAĞ işlevi

METNEÇEVİR işlevi

ZAMAN işlevi

TTERS işlevi

BUGÜN işlevi

KIRP işlevi

DOĞRU işlevi

BÜYÜKHARF işlevi

ABDDOLAR fonksiyonu

SAYIYAÇEVİR işlevi

VAR işlevi

VARA işlevi

VARS işlevi

VARSA işlevi

Weekday İşlevi

WEIBULL işlevi

YIL işlevi

Diğer kaynaklar

Burada yapmaya çalıştığı şeyi görmüyorsanız bu iki farklı Excel. İşte bazı ek kaynaklar. Bu sürümlerden bazıları eski sürümleri kapsaymasa da, gösterilen kullanıcı arabiriminde farklılıklar olabilir. Örneğin, sitenin Site Eylemleri menüsündekiSharePoint artık Site Eylemleri Ayarlar office 365 ayarları düğmesi - adınızın yanında dişliye benzeyen bir düğme .

Daha fazla yardıma mı ihtiyacınız var?

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×