We couldn’t sign you in
Select the account you want to use.
SharePoint listelerindeki yaygın formüllerden örnekler

Listelerdeki hesaplanmış sütunlarda formüllerin kullanılması, bir fiyattaki satış vergisini hesaplama gibi mevcut sütunlara eklemeye yardımcı olabilir. Bunlar program aracılığıyla verileri doğrulamak için birleştirilebilir. Hesaplanmış sütun eklemek için + sütun ekle'ye tıklayın ve ardından Diğer'i seçin.

Not: Hesaplanan alanlar yalnızca kendi satırlarında çalışabilir, bu nedenle başka bir satırdaki bir değere veya başka bir liste veya kitaplıkta yer alan sütunlara başvuramazsınız. Formülde arama alanları desteklenmez ve yeni eklenen satırın kimliği, formül işlenirken kimlik olmadığından kullanılamaz.

Formüller girilirken, aksi belirtilmedikçe anahtar sözcüklerle işleçler arasında boşluk yoktur.

Aşağıdakiler kapsamlı bir liste değildir. Tüm formülleri görüntülemek için bu makalenin sonundaki alfabetik listeye bakın.

Ayrıntılı yönergeleri görmek için aşağıdaki başlıklardan birini seçerek açın. 

Bir deyimin koşulunu test etmek ve Evet veya Hayır değeri döndürmek, Tamam veya Tamam Değil gibi alternatif bir değeri test etmek ya da null değeri temsil etmek için boş veya tire döndürmek için aşağıdaki formülleri kullanabilirsiniz.

Bir say ın başka bir sayıdan büyük veya küçük olup olmadığını denetleyin

Bu karşılaştırmayı gerçekleştirmek için EĞER işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

15000

9000

=[Sütun1]>[Sütun2]

Sütun1, Sütun2'den büyük mü? (Evet)

15000

9000

=EĞER([Sütun1]<=[Sütun2], "Tamam", "Tamam Değil")

Sütun1, Sütun2'den küçük veya buna eşit mi? (Tamam Değil)

Sütun içeriğini karşılaştırdıktan sonra mantıksal bir değer döndürme

Mantıksal değer (Evet veya Hayır) olan bir sonuç için VE, OR ve DEĞİl işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (olası sonuç)

15

9

8

=AND([Sütun1]>[Sütun2], [Sütun1]<[Sütun3])

15, 9'dan büyük ve 8'den küçük mü? (Hayır)

15

9

8

=OR([Sütun1]>[Sütun2], [Sütun1]<[Sütun3])

15, 9'dan büyük mü yoksa 8'den küçük mü? (Evet)

15

9

8

=NOT([Sütun1]+[Sütun2]=24)

15 artı 9, 24'e eşit değil mi? (Hayır)

Başka bir hesaplama veya Evet veya Hayır dışında herhangi bir değer olan bir sonuç için EĞER, AND ve OR işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (olası sonuç)

15

9

8

=EĞER([Sütun1]=15, "Tamam", "Tamam Değil")

Sütun1'deki değer 15'e eşitse , "Tamam" değerini döndürür. (Tamam)

15

9

8

=EĞER(VE([Sütun1]>[Sütun2], [Sütun1]<[Sütun3]), "Tamam", "Tamam Değil")

15, 9'dan büyük ve 8'den küçükse "Tamam" değerini döndürür. (Tamam Değil)

15

9

8

=EĞER(OR([Sütun1]>[Sütun2], [Sütun1]<[Sütun3]), "Tamam", "Tamam Değil")

15, 9'dan büyük veya 8'den küçükse " Tamam" döndür. (Tamam)

Sıfırları boşluk veya tire olarak görüntüleme

Sıfır görüntülemek için basit bir hesaplama yapın. Boş veya kısa çizgi görüntülemek için EĞER işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

10

10

=[Sütun1]-[Sütun2]

İkinci sayı ilk sayıdan çıkarılır (0)

15

9

=EĞER([Sütun1]-[Sütun2],"-",[Sütun1]-[Sütun2])

Değer hatalı olduğunda, bir kısa çizgi işareti döndürülür (-)

Sütunlardaki hata değerlerini gizleme

Hata değeri yerine tire, #N/A veya NA görüntülemek için ISERROR işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

10

0

=[Sütun1]/[Sütun2]

Bir hataya (#SAYI/0) yol açar

10

0

=EĞER(ISERROR([Sütun1]/[Sütun2]),"NA",[Sütun1]/[Sütun2])

Değer hatalıysa, YOKSAY değerini verir

10

0

=EĞER(ISERROR([Sütun1]/[Sütun2]),"-",[Sütun1]/[Sütun2])

Değer hatalıysa, bir kısa çizgi işareti verir

Boş alanları denetleme

Boş alanları bulmak için ISBLANK formülünü kullanabilirsiniz.

Sütun1

Formül

Açıklama (olası sonuç)

"Jöle fasulyesi"

=ISBLANK([Sütun1]

Boşsa veya boş değilse Evet veya Hayır döndürür

"Çelik"

=EĞER(ISBLANK([Sütun1]), "Tamam Değil", "Tamam")

Kendi seçimlerinizi doldurun- birincisi boşsa, ikinci seçenek değilse

Diğer IS işlevleri için bkz. IS işlevleri.

Tarihe gün, ay veya yıl sayısı ekleme, iki tarih arasındaki farkı hesaplama ve saati ondalık değere dönüştürme gibi tarih ve saatlere dayalı hesaplamalar yapmak için aşağıdaki formülleri kullanabilirsiniz.

Tarih ekleme

Tarihe gün sayısı eklemek için toplama (+) işlecini kullanın.

Not: Tarihleri değiştirdiğinizde, hesaplanan sütunun dönüş türü Tarih ve Saat olarak ayarlanmalıdır.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

6/9/2007

3

=[Sütun1]+[Sütun2]

9/6/2007'ye 3 gün ekler (12/6/2007)

12/10/2008

54

=[Sütun1]+[Sütun2]

10/12/2008'e 54 gün ekler (2/2/2009)

Tarihe birkaç ay eklemek için TARİh, YIL, AY ve GÜN işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

6/9/2007

3

=TARİh(YIL([Sütun1]),AY([Sütun1])+[Sütun2],GÜN([Sütun1]))

9/6/2007'ye 3 ay ekler (9/9/2007)

12/10/2008

25

=TARİh(YIL([Sütun1]),AY([Sütun1])+[Sütun2],GÜN([Sütun1]))

10.12.2008'e 25 ay ekler (10.10.2011)

Tarihe birkaç yıl eklemek için TARİh, YIL, AY ve GÜN işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

6/9/2007

3

=TARİh(YIL([Sütun1])+[Sütun2],AY([Sütun1]),GÜN([Sütun1]))

9/6/2007'ye 3 yıl ekler (9/6/2010)

12/10/2008

25

=TARİh(YIL([Sütun1])+[Sütun2],AY([Sütun1]),GÜN([Sütun1]))

10.12.2008'e 25 yıl ekler (10.12.2033)

Tarihe gün, ay ve yıl birleşimi eklemek için TARİh, YIL, AY ve GÜN işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

6/9/2007

=TARİh(YIL([Sütun1])+3,AY([Sütun1])+1,GÜN([Sütun1])+5)

9/6/2007'ye 3 yıl, 1 ay ve 5 gün ekler (14/7/2010)

12/10/2008

=TARİh(YIL([Sütun1])+1,AY([Sütun1])+7,GÜN([Sütun1])+5)

10/12/2008'e 1 yıl, 7 ay ve 5 gün ekler (15/7/2010)

İki tarih arasındaki farkı hesaplama

Bu hesaplamayı yapmak için TARİhSAY işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

01 Ocak 1995

15 Haziran 1999

=TARİhSAY([Sütun1], [Sütun2],"d")

İki tarih arasındaki gün sayısını verir (1626)

01 Ocak 1995

15 Haziran 1999

=TARİhLİEĞER([Sütun1], [Sütun2],"ym")

Yıl bölümünü yoksayarak tarihler arasındaki ay sayısını verir (5)

01 Ocak 1995

15 Haziran 1999

=TARİhLİEĞER([Sütun1], [Sütun2],"yd")

Yıl bölümünü yoksayarak tarihler arasındaki gün sayısını verir (165)

İki saat arasındaki farkı hesaplama

Sonucu standart saat biçiminde (hours:minutes:seconds) sunmak için çıkarma işlecini (-) ve METNEÇEVİr işlevini kullanın. Bu yöntemin çalışması için saatler 24'ü, dakika ve saniyeler ise 60'ı geçmemelidir.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

09.06.2007 10:35

09.06.2007 15:30

=METNEÇEVİr([Sütun2]-[Sütun1],"h")

İki kez arasındaki saatler (4)

09.06.2007 10:35

09.06.2007 15:30

=METNEÇEVİr([Sütun2]-[Sütun1],"h:mm")

İki kez arasındaki saatler ve dakikalar (4:55)

09.06.2007 10:35

09.06.2007 15:30

=METNEÇEVİr([Sütun2]-[Sütun1],"h:mm:ss")

İki kez arasındaki saatler, dakikalar ve saniyeler (4:55:00)

Sonucu bir zaman birimini temel alan bir toplam olarak sunmak için , INT işlevini veya HOUR, MINUTE veya SECOND işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

09.06.2007 10:35

10.06.2007 15:30

=INT(([Sütun2]-[Sütun1])*24)

İki kez arasındaki toplam saat sayısı (28)

09.06.2007 10:35

10.06.2007 15:30

=INT(([Sütun2]-[Sütun1])*1440)

İki kez arasındaki toplam dakika sayısı (1735)

09.06.2007 10:35

10.06.2007 15:30

=INT(([Sütun2]-[Sütun1])*86400)

İki kez arasındaki toplam saniye (104100)

09.06.2007 10:35

10.06.2007 15:30

=SAAT([Sütun2]-[Sütun1])

Farkın 24'ü (4) aşmadığı iki kez arasındaki saatler

09.06.2007 10:35

10.06.2007 15:30

=DAKİkA([Sütun2]-[Sütun1])

Fark 60'ı (55) aşmadığında iki kez arasındaki dakika sayısı

09.06.2007 10:35

10.06.2007 15:30

=SANİYE([Sütun2]-[Sütun1])

Fark 60'ı aşmadığında iki kez arasındaki saniye (0)

Saatleri dönüştürme

Saatleri standart saat biçiminden ondalık sayıya dönüştürmek için INT işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

10:35

=([Sütun1]-INT([Sütun1]))*24

12:00'den bu yana saat sayısı (10,583333)

12:15 PM

=([Sütun1]-INT([Sütun1]))*24

12:00'den bu yana saat sayısı (12,25)

Saatleri ondalık sayıdan standart saat biçimine (hours:minutes:seconds) dönüştürmek için bölme işlecini ve METNEÇEVİr işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

23:58

=METNEÇEVİr(Sütun1/24, "ss:mm:ss")

12:00'den bu yana saatler, dakikalar ve saniyeler (00:59:55)

2:06

=METNEÇEVİr(Sütun1/24, "h:mm")

Saat 12:00'den bu yana saat ve dakika (0:05)

Jülyen tarihleri ekleme

Jülyen tarihi, geçerli yılın ve yılın başlangıcından bu yanaki gün sayısının birleşimi olan bir tarih biçimini ifade eder. Örneğin, 1 Ocak 2007 2007001 olarak, 31 Aralık 2007 ise 2007365 olarak temsil edilir. Bu biçim Julian takvimini temel almamaktadır.

Bir tarihi Jülyen tarihine dönüştürmek için METNEÇEVİr ve TARİhSAYISI işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

6/23/2007

=METNEÇEVİr([Sütun1],"yy")&METNEÇEVİr(([Sütun1]-TARİhSAYISI("1/1/"& METNEÇEVİr([Sütun1],"yy"))+1),"000")

İki basamaklı yıl (07174) ile Julian biçiminde tarih

6/23/2007

=METNEÇEVİr([Sütun1],"yyyy")&METNEÇEVİr(([Sütun1]-TARİhSAYISI("1/1/"&METNEÇEVİr([Sütun1],"yy"))+1),"000")

Dört basamaklı yıl (2007174) ile Julian biçiminde tarih

Bir tarihi astronomide kullanılan bir Julian tarihine dönüştürmek için 2415018.50 sabitini kullanın. Bu formül yalnızca 1/3/1901 tarihinden sonraki tarihlerde ve 1900 tarih sistemini kullanıyorsanız çalışır.

Sütun1

Formül

Açıklama (sonuç)

6/23/2007

=[Sütun1]+2415018.50

Julian biçiminde tarih, astronomide kullanılır (2454274.50)

Tarihleri haftanın günü olarak göster

Tarihleri haftanın gününe ait metne dönüştürmek için METNEÇEVİr ve HAFTAGÜNÜ işlevlerini kullanın.

Sütun1

Formül

Açıklama (olası sonuç)

19 Şubat 2007

=METNEÇEVİr(WEEKDAY([Sütun1]), "dddd")

Tarih için haftanın gününü hesaplar ve günün tam adını döndürür (Pazartesi)

3 Ocak 2008

=METNEÇEVİr(HAFTAGÜNÜ([Sütun1]), "ddd")

Tarih için haftanın gününü hesaplar ve günün kısaltılmış adını (Thu) döndürür

Sayıları ekleme, çıkarma, çarpma ve bölme, sayıların ortalamasını veya ortanca değerini hesaplama, sayıyı yuvarlama ve değerleri sayma gibi çeşitli matematik hesaplamaları gerçekleştirmek için aşağıdaki formülleri kullanabilirsiniz.

Sayıları toplama

Bir satırda iki veya daha fazla sütuna sayı eklemek için toplama işlecini (+) veya TOPLA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

6

5

4

=[Sütun1]+[Sütun2]+[Sütun3]

İlk üç sütundaki değerleri ekler (15)

6

5

4

=TOPLA([Sütun1],[Sütun2],[Sütun3])

İlk üç sütundaki değerleri ekler (15)

6

5

4

=TOPLA(EĞER([Sütun1]>[Sütun2], [Sütun1]-[Sütun2], 10), [Sütun3])

Sütun1, Sütun2'den büyükse, farkı ve Sütun3'i ekler. Else add 10 and Column3 (5)

Sayıları çıkarma

Bir satırdaki iki veya daha fazla sütundaki sayıları çıkarmak için çıkarma işlecini (-) veya negatif sayılarla TOPLA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

15000

9000

-8000

=[Sütun1]-[Sütun2]

15000'den 9000'i çıkarır (6000)

15000

9000

-8000

=TOPLA([Sütun1], [Sütun2], [Sütun3])

negatif değerler de dahil olmak üzere ilk üç sütuna sayılar ekler (16000)

İki sayı arasındaki farkı yüzde olarak hesaplama

Çıkarma (-) ve bölme (/) işleçlerini ve ABS işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

2342

2500

=([Sütun2]-[Sütun1])/ABS([Sütun1])

Değişiklik yüzdesi (%6,75 veya 0,06746)

Sayıları çarpma

Bir satırdaki iki veya daha fazla sütundaki sayıları çarpmak için çarpma işlecini (*) veya ÇARPIM işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

5

2

=[Sütun1]*[Sütun2]

İlk iki sütundaki sayıları çarpar (10)

5

2

=PRODUCT([Sütun1], [Sütun2])

İlk iki sütundaki sayıları çarpar (10)

5

2

=ÇARPIM([Sütun1],[Sütun2],2)

İlk iki sütundaki sayıları ve 2 sayısını (20) çarpar

Sayıları bölme

Sayıları bir satırda iki veya daha fazla sütuna bölmek için bölme işlecini (/) kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

15000

12

=[Sütun1]/[Sütun2]

15000'i 12'ye böler (1250)

15000

12

=([Sütun1]+10000)/[Sütun2]

15000 ve 10000 ekler ve ardından toplamı 12'ye böler (2083)

Sayıların ortalamasını hesaplama

Ortalama, ortalama olarak da adlandırılır. Bir satırdaki iki veya daha fazla sütundaki sayıların ortalamasını hesaplamak için ORTALAMA işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

6

5

4

=ORTALAMA([Sütun1], [Sütun2],[Sütun3])

İlk üç sütundaki sayıların ortalaması (5)

6

5

4

=ORTALAMA(EĞER([Sütun1]>[Sütun2], [Sütun1]-[Sütun2], 10), [Sütun3])

Sütun1 Sütun2'den büyükse, farkın ortalamasını ve Sütun3 değerini hesaplayın. Aksi zaman 10 ve Sütun3 (2,5) değerlerinin ortalamasını hesaplar

Sayıların ortanca değerini hesaplama

Ortanca değer, sıralı bir sayı aralığının ortasındaki değerdir. Bir sayı grubunun ortanca değerini hesaplamak için ORTANCA işlevini kullanın.

A

B

C

D

E

Ş

Formül

Açıklama (sonuç)

10

7

9

27

0

4

=ORTANCA(A, B, C, D, E, F)

İlk 6 sütundaki sayıların ortancası (8)

Aralıktaki en küçük veya en büyük sayıyı hesaplama

Bir satırdaki iki veya daha fazla sütundaki en küçük veya en büyük sayıyı hesaplamak için , MIN ve MAX işlevlerini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

10

7

9

=MIN([Sütun1], [Sütun2], [Sütun3])

En küçük sayı (7)

10

7

9

=MAX([Sütun1], [Sütun2], [Sütun3])

En büyük sayı (10)

Değerleri sayma

Sayısal değerleri saymak için BAĞ_DEĞ_SAY işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

Elma

12/12/2007

=BAĞ_DEĞ_SAY([Sütun1], [Sütun2], [Sütun3])

Sayısal değerler içeren sütun sayısını sayar. Tarih ve saat, metin ve null değerleri dışlar (0)

12 ABD doları

#SAYI/0!

1.01

=BAĞ_DEĞ_SAY([Sütun1], [Sütun2], [Sütun3])

Sayısal değerler içeren sütun sayısını sayar, ancak hata ve mantıksal değerleri hariç tutar (2)

Bir sayıyı bir yüzde oranında artırma veya azaltma

Bu hesaplamayı yapmak için yüzde (%) işlecini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

23

3%

=[Sütun1]*(1+5%)

Sütun1'deki sayıyı %5 artırır (24,15)

23

3%

=[Sütun1]*(1+[Sütun2])

Sütun1'deki sayıyı Sütun2'deki yüzde değeriyle artırır: %3 (23,69)

23

3%

=[Sütun1]*(1-[Sütun2])

Sütun1'deki sayıyı Sütun2'deki yüzde değeriyle azaltır: %3 (22,31)

Bir sayıyı bir kuvvete yükseltme

Bu hesaplamayı yapmak için üs işlecini (^) veya POWER işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

5

2

=[Sütun1]^[Sütun2]

Beş kareyi hesaplar (25)

5

3

=POWER([Sütun1], [Sütun2])

Beş küp küpü hesaplar (125)

Sayıyı yuvarlama

Bir sayıyı yukarı yuvarlamak için YUKARIYUVARLA, TEK veya EVEN işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20.3

=YUKARIYUVARLA([Sütun1],0)

20,3'leri en yakın tamsayıya yukarı yuvarlar (21)

-5.9

=YUKARIYUVARLA([Sütun1],0)

-5,9 sayısını en yakın tamsayıya (-5) yukarı yuvarlar

12.5493

=YUKARIYUVARLA([Sütun1],2)

12,5493'i en yakın yüz, iki ondalık basameğe yukarı yuvarlar (12,55)

20.3

=EVEN([Sütun1])

20,3'leri en yakın çift sayıya yukarı yuvarlar (22)

20.3

=TEK([Sütun1])

20,3'leri en yakın tek sayıya yukarı yuvarlar (21)

Bir sayıyı aşağı yuvarlamak için YUKARIYUVARLA işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20.3

=YUKARIYUVARLA([Sütun1],0)

20,3'leri en yakın tamsayıya (20) aşağı yuvarlar

-5.9

=YUKARIYUVARLA([Sütun1],0)

-5,9'ı en yakın tamsayıya (-6) aşağı yuvarlar

12.5493

=YUKARIYUVARLA([Sütun1],2)

12,5493'leri en yakın yüz, iki ondalık basamağı (12,54) aşağı yuvarlar

Sayıyı en yakın sayıya veya kesire yuvarlamak için YUVARLA işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

20.3

=YUVARLA([Sütun1],0)

Kesir bölümü 0,5'ten (20) küçük olduğundan 20,3'leri aşağı yuvarlar

5.9

=YUVARLA([Sütun1],0)

Kesir bölümü 0,5'ten (6) büyük olduğundan 5,9'ı yukarı yuvarlar

-5.9

=YUVARLA([Sütun1],0)

Kesir bölümü -.5'ten (-6) küçük olduğundan -5,9 aşağı yuvarlar

1,25

=YUVARLA([Sütun1], 1)

Sayıyı en yakın onuncuya (bir ondalık basamak) yuvarlar. Yuvarlanacak kısım 0,05 veya daha büyük olduğundan, sayı yukarı yuvarlandı (sonuç: 1,3)

30.452

=YUVARLA([Sütun1], 2)

Sayıyı en yakın yüzdeye yuvarlar (iki ondalık basamak). Yuvarlanacak kısım olan 0,002 0,005'ten küçük olduğundan, sayı aşağı yuvarlanır (sonuç: 30,45)

Sayıyı 0'ın üzerindeki önemli basamaklara yuvarlamak için YUVARLA, YUKARIYUVARLA, YUKARIYUVARLA, INT ve UZUNLUK işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

5492820

=YUVARLA([Sütun1],3-UZUNLUK(INT([Sütun1])))

Sayıyı 3 anlamlı basamağı (5490000) yuvarlar

22230

=YUKARIYUVARLA([Sütun1],3-UZUNLUK(INT([Sütun1])))

Alttaki sayıyı 3 anlamlı basamağı (22200) aşağı yuvarlar

5492820

=YUKARIYUVARLA([Sütun1], 5 UZUNLUK(INT([Sütun1])))

En üstteki sayıyı 5 anlamlı basamağı (5492900) yukarı yuvarlar

Birden çok sütundaki değerleri birleştirmek veya birleştirmek, sütunların içeriğini karşılaştırmak, karakterleri veya boşlukları kaldırmak ve karakterleri yinelemek gibi metinleri işlemek için aşağıdaki formülleri kullanabilirsiniz.

Metinde büyük/küçük harfi değiştirme

Metnin büyük/küçük harflerini değiştirmek için , BÜYÜKHARF, KÜÇÜKHARF veya DOĞRU işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

nina Vietzen

=BÜYÜKHARF([Sütun1])

Metni büyük harfe dönüştürür (NINA VIETZEN)

nina Vietzen

=ALT([Sütun1])

Metni küçük harfle değiştirir (nina vietzen)

nina Vietzen

=DÜZGÜN([Sütun1])

Metni büyük/küçük harfe değiştirir (Nina Vietzen)

Ad ve soyadlarını birleştirme

Ad ve soyadlarını birleştirmek için ve işlecini (&) veya BİrLEŞTİr işlevini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Carlos

Carvallo

=[Sütun1]&[Sütun2]

İki dizeyi birleştirir (CarlosCarvallo)

Carlos

Carvallo

=[Sütun1]&" "&[Sütun2]

İki dizeyi bir boşlukla ayırarak birleştirir (Carlos Carvallo)

Carlos

Carvallo

=[Sütun2]&", "&[Sütun1]

Virgül ve boşlukla ayrılmış iki dizeyi birleştirir (Carvallo, Carlos)

Carlos

Carvallo

=BİrLEŞTİr([Sütun2], ",", [Sütun1])

virgülle ayrılmış iki dizeyi birleştirir (Carvallo,Carlos)

Farklı sütunlardaki metin ve sayıları birleştirme

Metin ve sayıları birleştirmek için BİrLEŞTİr işlevini, ve işlecini (&) veya METNEÇEVİr işlevini ve ve işlecini kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Yalçınkaya

28

=[Sütun1]&" "&[Sütun2]&" birimlerini sattı."

Yukarıdaki içerikleri bir tümcecik halinde birleştirir (Yang 28 birim sattı.)

Dubois

40%

=[Sütun1]&", toplam satışların "&METNEÇEVİr([Sütun2],"%0")&" sattı."

Yukarıdaki içerikleri bir tümcecik halinde birleştirir (Dubois toplam satışların %40'ını sattı.)

Not: METNEÇEVİr işlevi, temel alınan değer yerine Sütun2'nin biçimlendirilmiş değerini (0,4) ekler.

Yalçınkaya

28

=BİrLEŞTİr([Sütun1]," ",[Sütun2]," birimlerini sattı.")

Yukarıdaki içerikleri bir tümcecik halinde birleştirir (Yang 28 birim sattı.)

Metni tarih veya saatle birleştirme

Metni tarih veya saatle birleştirmek için METNEÇEVİr işlevini ve ve işlecini (&) kullanın.

Sütun1

Sütun2

Formül

Açıklama (sonuç)

Faturalama Tarihi

5 Haziran 2007

="Deyim tarihi: "&METNEÇEVİr([Sütun2], "d-mmm-yyyy")

Metni tarihle birleştirir (Deyim tarihi: 5-Haz-2007)

Faturalama Tarihi

5 Haziran 2007

=[Sütun1]&" "&METNEÇEVİr([Sütun2], "mmm-dd-yyyy")

Farklı sütunlardaki metin ve tarihi tek sütunda birleştirir (Faturalama Tarihi Haz-05-2007)

Sütun içeriğini karşılaştırma

Bir sütunu başka bir sütunla veya değer listesiyle karşılaştırmak için , ÖZDEŞ ve OR işlevlerini kullanın.

Sütun1

Sütun2

Formül

Açıklama (olası sonuç)

BD122

BD123

=TAM([Sütun1],[Sütun2])

İlk iki sütunun içeriğini karşılaştırır (Hayır)

BD122

BD123

=TAM([Sütun1], "BD122")

Sütun1'in içeriğini ve "BD122" dizesini karşılaştırır (Evet)

Sütun değerinin veya bir bölümünün belirli bir metinle eşleşip eşleşmediğini denetleme

Sütun değerinin veya bir bölümünün belirli bir metinle eşleşip eşleşmediğini denetlemek için EĞER, BUL, ARA ve ISNUMBER işlevlerini kullanın.

Sütun1

Formül

Açıklama (olası sonuç)

Vietzen

=EĞER([Sütun1]="Vietzen", "Tamam", "Tamam Değil")

Sütun1'in Vietzen olup olmadığını denetler (Tamam)

Vietzen

=EĞER(ISNUMBER(BUL("v",[Sütun1])), "Tamam", "Tamam Değil")

Sütun1'de v harfinin olup olmadığını denetler (Tamam)

BD123

=ISNUMBER(BUL("BD",[Sütun1]))

Sütun1'de BD olup olmadığını denetler (Evet)

Boş olmayan sütunları sayma

Boş olmayan sütunları saymak için BAĞ_DEĞ_SAY işlevini kullanın.

Sütun1

Sütun2

Sütun3

Formül

Açıklama (sonuç)

Satışlar

19

=BAĞ_DEĞ_SAY([Sütun1], [Sütun2])

Boş olmayan sütun sayısını sayar (2)

Satışlar

19

=BAĞ_DEĞ_SAY([Sütun1], [Sütun2], [Sütun3])

Boş olmayan sütun sayısını sayar (2)

Metinden karakterleri kaldırma

Metindeki karakterleri kaldırmak için UZUNLUK, SOL ve SAĞ işlevlerini kullanın.

Sütun1

Formül

Açıklama (sonuç)

A vitamini

=SOLDAN([Sütun1],UZUNLUK([Sütun1])-2)

Soldan başlayarak 7 (9-2) karakter döndürür (Vitamin)

B1 Vitamini

=SAĞ([Sütun1], UZUNLUK([Sütun1])-8)

Sağdan başlayarak 2 (10-8) karakter döndürür (B1)

Sütunun başından ve sonundan boşlukları kaldırma

Sütundaki boşlukları kaldırmak için KIRP işlevini kullanın.

Sütun1

Formül

Açıklama (sonuç)

 Merhaba,!

=KIRP([Sütun1])

Boşlukları başından ve sonundan kaldırır (Merhaba!)

Sütunda bir karakteri yineleme

Sütundaki bir karakteri yinelemek için REPT işlevini kullanın.

Formül

Açıklama (sonuç)

=REPT(".",3)

Bir dönemi 3 kez tekrarlar (...)

=YİNELE("-",10)

Tireyi 10 kez yineler (----------)

İşlevlerin alfabetik listesi

Aşağıda, SharePoint kullanıcıların kullanabileceği işlevlerin bağlantılarının alfabetik bir listesi yer alır. Trigonometrik, istatistiksel ve finansal işlevlerin yanı sıra koşullu, tarih, matematik ve metin formüllerini içerir.

MUTLAK işlevi

ACOS işlevi

ACOSH işlevi

VE işlevi

ASİN işlevi

ASİNH işlevi

ATAN işlevi

ATAN2 işlevi

ORTALAMA işlevi

ORTALAMAA işlevi

BETADAĞ işlevi

BETATERS işlevi

BİNOMDAĞ işlevi

TAVANAYUVARLA işlevi

DAMGA işlevi

KİKAREDAĞ işlevi

ELEMAN işlevi

KOD işlevi

BİRLEŞTİR işlevi

GÜVENİRLİK işlevi

COS işlevi

BAĞ_DEĞ_SAY işlevi

BAĞ_DEĞ_DOLU_SAY işlevi

KRİTİKBİNOM işlevi

TARİH işlevi

TARİHFARKI işlevi

TARİHSAYISI işlevi

GÜN işlevi

GÜN360 işlevi

ÇİFTAZALANBAKİYE işlevi

DERECE işlevi

LİRA işlevi

ÇİFT işlevi

ÖZDEŞ işlevi

ÜSTELDAĞ işlevi

ÇARPINIM işlevi

FDAĞ işlevi

BUL işlevi

FTERS işlevi

FISHER işlevi

SAYIDÜZENLE işlevi

GAMADAĞ işlevi

GAMATERS işlevi

GAMALN işlevi

GEOORT işlevi

HARORT işlevi

SAAT işlevi

HİPERGEOMDAĞ işlevi

EĞER işlevi

TAMSAYI işlevi

IPmt İşlevi

E işlevleri

SOLDAN işlevi

UZUNLUK fonksiyonu

LN işlevi

Log İşlevi

LOG10 işlevi

LOGTERS işlevi

LOGNORMDAĞ işlevi

KÜÇÜKHARF işlevi

MAK işlevi

Ben işlevi

ORTANCA işlevi

PARÇAAL işlevi

MİN işlevi

MİNA işlevi

DAKİKA işlevi

MOD işlevi

AY işlevi

NEGBİNOMDAĞ işlevi

NORMDAĞ işlevi

NORMSDAĞ işlevi

NORMSTERS işlevi

DEĞİL işlevi

TAKSİT_SAYISI işlevi

NBD işlevi

TEK işlevi

YADA işlevi

DEVRESEL_ÖDEME işlevi

KUVVET işlevi

ANA_PARA_ÖDEMESİ işlevi

ÇARPIM işlevi

YAZIM.DÜZENİ işlevi

BD işlevi

RADYAN işlevi

DEĞİşTİr işlevi

YİNELE işlevi

SAĞDAN fonksiyonu

YUVARLA işlevi

AŞAĞIYUVARLA işlevi

YUKARIYUVARLA işlevi

MBUL fonksiyonu

SANİYE işlevi

İŞARET işlevi

SİN işlevi

SİNH işlevi

KAREKÖK işlevi

STANDARTLAŞTIRMA işlevi

STDSAPMAA işlevi

STDSAPMAS işlevi

STDSAPMASA işlevi

TOPLA işlevi

TOPKARE işlevi

YAT işlevi

TANH işlevi

TDAĞ işlevi

METNEÇEVİR işlevi

ZAMAN işlevi

TTERS işlevi

BUGÜN işlevi

KIRP işlevi

DOĞRU işlevi

BÜYÜKHARF işlevi

ABDDOLAR fonksiyonu

SAYIYAÇEVİR işlevi

VAR işlevi

VARA işlevi

VARS işlevi

VARSA işlevi

Weekday İşlevi

WEIBULL işlevi

YIL işlevi

Diğer kaynaklar

Burada ne yapmaya çalıştığınızı görmüyorsanız, Excel'de bunu gerçekleştirip gerçekleştiremediğiniz bölümüne bakın. Bazı ek kaynaklar aşağıdadır. Bunlardan bazıları eski sürümleri kapsadığından, gösterilen kullanıcı arabiriminde farklılıklar olabilir. Örneğin, SharePoint'tekiSite Eylemleri menüsündeki öğeler artık Ayarlar office 365 ayarları düğmesi - adınızın yanında dişliye benzeyen bir düğme menüsündedir.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×