SEQUENCEgibi taşmış dizi işlevleriyle uğraştırken, spilled range işlecini (#) aralık sonrası yerleştirerek bütün taşma aralığına başvuru yapmak mümkündür. Aşağıdaki örnekte A2 hücresinde A2:A11'e taşan =SEQUENCE(10) var. C2 hücresinde A2:A11 hücresinde A2:A11 hücresinde yer alan ve =TOPLA(A2#) formülünü eşdeğeri olan =TOPLA(A2#) formülü var. Bu, taşan dizi aralığındaki tüm değerlerin toplamı olan 55'i verir.

Taşma aralığınız büyürse veya sözleşmeler oluşursa, örneğin A2'deki formülü =SıRALı(20) olarak değiştirerek TOPLA formülü bunu otomatik olarak yansıtacaktır. Bu normal bir aralıksa =TOPLA(A2:A11) girer ve taşma aralığı değişirse el ile güncelleştirmemiz gerekir. Çoğunlukla bir aralık değişirse farkında olmazsanız, bu da pek çok tahmin çalışması ortadan kaldırabilir.

=TOPLA(A2#) ile tüm taşmış dizi aralıklara başvurmak için taşan aralık işleci.

Burada, ad listesinden benzersiz bir liste oluşturma, listeyi sıralama ve ardından 3 karakterden uzun adlar için filtre uygulamanın olduğu başka bir formül örneği ve bu örnek, taşan aralık işlecinin birçok formülde kullanımına bir örnektir. E2 hücresinde =SıRALA(C2#) ve G2 hücresinde =FİLE(C2#,UZUNLUK(C2#)>3) var.

=FİLE(C2#,UZUNLUK(C2#)>3) formülüyle, taşan dizi aralığının tamamına başvuru yapmak için taşan aralık işleci (#)

Bilinen Sınırlamalar

Taşan aralık işleci, kapalı çalışma kitaplarında yapılan başvuruları desteklemez. Bunun yerine yeni bir #REF! hata değerini döndürür. Başvurulan çalışma kitabının açılması bu sorunu çözer.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

FİLTRE işlevi

RASGDİZİ işlevi

SIRALI işlevi

SIRALA işlevi

SIRALAÖLÇÜT işlevi

BENZERSİZ işlevi

Excel’de #SPILL! hataları

Dinamik diziler ve geçmiş dizi davranışı

Örtük kesişim işleci: @

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×