Bir çözümde Dynamics 365 alırken "Yönetilen özelliklerinin yapılandırması nedeniyle bu bileşen için bu eylemi tamamlayamıyor" hatası oluşuyor

Belirti

Bir çözümde Dynamics 365 almaya çalışırken, aşağıdaki iletiyle Çözüm alma başarısız olur:

"Çözümün alınması: [devamı] başarısız oldu"

Hata iletişim kutusunda olacaktır hata durumu ve ayrıntı sütununda aşağıdaki ileti görüntülenir:

"Yönetilen özelliklerinin yapılandırması nedeniyle bu bileşen için bu eylemi tamamlayamıyor"

Günlük dosyasını karşıdan yükle'yi tıklatın ve Excel'de bileşenleri sekmesini görüntülerseniz, bir ileti gibi bakın:

"Durum sütunu: hata

ErrorCode: 0x8004F026

ErrorText: Geçerli bileşenin değerlendirme (adı = varlık, kimliği koşulunun değerlendirmesini yönetilen özellik sırasında başarısız oldu (güncelleştirme) geçerli operasyondaki [GUID] =: Değerlendirme geçerli bileşenin (adı = varlık, kimliği [GUID] = geçerli işlemi (içinde) Güncelleştirme) yönetilen özellik koşulunun değerlendirmesini sırasında başarısız oldu: yönetilen özellik adı: [ManagedPropertyLogicalName]; Bileşen adı: Varlık; Öznitelik adı: [ManagedPropertyLogicalName]; "

Neden

Microsoft bu hata bazı varlıklar gibi pazarlama listesi, varlık SystemUser, takım, müşteri adresi, pozisyon, işlem para birimini içeren bir çözüm alırken burada oluşabilir bir sorunun farkındadır. Çözümünüzün Bu varlıklardan birini içeriyorsa, bu makalenin çözüm bölümüne bakın.

Yönetilen özellikleri hedef kuruluşta aynı varlığı ile almaya çalıştığınız bir varlık için uyuşmazlık var. Bu hatayı gösterir. Hedef varlık ve Kaynak Varlık özniteliklerini arasındaki eşleşmeme durumu hedef kuruluş (örnek için 8.2 9.0) sürümünden daha eski olan kaynak kuruluş sürümünü ilgili olabilir. Sistem yükseltme yapýlmadan hedef organizasyonu ve yönetilen varlýk özniteliði güncelleştirdi, bu varlık için öznitelik farklı bir tanımını içeriyorsa, çözümü başarısız olur.

Örnek:Dynamics 365 sürüm 8.2, özel bir varlık pazarlama listesi varlığı arasında bir ilişki oluşturulur. Dynamics 365 sürüm 9.0, Dynamics 365 mobil app içinde görünür hale getirmek için pazarlama listesi varlık yönetilen özniteliğini değiştirmek için sistem güncelleştirmesi uygulanmış (adı: IsVisibleInMobileClient, mantıksal adı: canmodifymobileclientvisibility) true. Yönetilen çözüm içeren özel varlık 8.2 kuruluştan verilir ve pazarlama listesi varsayılan olarak varlık tanımı bağımlılık çözüm olarak yer alır. Yönetilen çözüm CRM 9.0 kuruluşuna içe aktarıldığında, öznitelik tanımının bir uyuşmazlık yoktur. Farklı bir yayımcı'dan ve varlığı hedef kuruluş içinde yönetilen ve yönetilen özniteliği güncelleştirilebilir değil bu yana çözüm sürümünde değiştirilemez ve hata görüntülenir.

Çözüm

Microsoft neden bölümünde sözü edilen varlıklar için bu sorun için bir düzeltme yayımladı. Bu varlıklardan birini çözümünüzün bir parçası ise, bu arada kullanabileceğiniz bir geçici çözüm yoktur. ,Çözüm dosyası hedef kuruluş varlık özniteliği eşleştirmek için kaynak kuruluş varlık özniteliği değeri değiştirmek için değiştirilebilir.

Not: Bu çözüm yalnızca bu Bu çözüm alma için çalışır. Çözümü yeniden kaynak kuruluştan veriliyorsa, bu düzen yeniden tamamlanmış olması gerekir. Bu düzeltme yayımladı kadar geçici bir çözüm olması gerekir:

1. çözüm dosyasını ayıklayın.

2. customizations.xml dosyasını bir metin düzenleyicisinde açın

3. LogicalCollectionName arama (örnek: listeleri, takım, vs...)

<EntitySetName>lists</EntitySetName>

4. aşağı kaydırın ve hata iletisinde belirtilen öznitelik adını bulun. Markeitng listesi varlığı için öznitelik IsVisibleInMobileClient büyük olasılıkla olacaktır. Neden bölümünde sözü edilen diğer varlıklar için alan olur IsReadOnlyInMobileClient.

<IsVisibleInMobileClient>0</IsVisibleInMobileClient>

5. geçerli ayarın tersi için değerini değiştirmek (örnek: 1 0)

<IsVisibleInMobileClient>1</IsVisibleInMobileClient>

6. tüm dosyaların yeni düzenlenmiş bir çözüm kahraman ve alma için bu çözümü kullanabilirsiniz.

Ek Bilgi

Uyuşmazlık olan hedef kuruluş içindeki varlığı hata iletişim kutusunda tanımlanır. Uyumsuz [ManagedPropertyLogicalName] öznitelik değerleri almak için Web API GUID ile tanımlanan varlık almak için kullanın:

  1. Burada Çözüm alma girişiminde bulunan hedef kuruluş için Dynamics 365 web uygulamasına erişmek için bir web tarayıcısı açın.

  2. Sekmesi çoğaltmak (sekmesini sağ tıklatın ve ardından Çoğalt'ı tıklatın) böylece doğrulanmış tarayıcı oturumu kullanabilirsiniz.

  3. Yeni bir sekmede hata ayrıntılarını GUID değerini değiştirme [GUID] ve [organizationURL], kuruluşunuz için URL ile değiştirerek aşağıdaki komutu çalıştırın:https://[organizationURL]/api/data/v8.2/EntityDefinitions([GUID])

  4. [ManagedPropertyLogicalName] çıkış dizesi için arama yapın.

  5. Kaynak Organizasyon üzerinde aynı işlemi yapmak ve hata iletisinde belirtilen öznitelik değerleri karşılaştırın.

 

Örnek:

Hata iletisi:

Geçerli bileşenin değerlendirme (adı = varlık, kimliği = efd3a52d-04ca - 4 d 36-a54c-2a26a64f5571) yönetilen özellik koşulunun değerlendirmesini sırasında başarısız geçerli işlemde (güncelleştirme): geçerli bileşenin değerlendirme (adı = varlık, kimliği = efd3a52d-04ca-4d36-a54c-2a26a64f5571) yönetilen özellik koşulunun değerlendirmesini sırasında başarısız oldu (güncelleştirme) geçerli operasyondaki: yönetilen özellik adı: canmodifymobileclientvisibility; Bileşen adı: Varlık; Öznitelik adı: canmodifymobileclientvisibility;

Sorgu https://[organizationURL]/api/data/v8.2/EntityDefinitions(efd3a52d-04ca-4d36-a54c-2a26a64f5571)kullanırken, DisplayName varlıklar "Pazarlama listesi" şöyledir:

"DisplayName": {

"LocalizedLabels": [

{

"Etiket": "Pazarlama listesi"

"DilKodu": 1033,

"IsManaged": true

"MetadataId": "479709b3-2241-db11-898a-0007e9e17ebd"

"HasChanged": null

}

],

Varlıkların LogicalName "listesi" şöyledir:

"LogicalName": "listesi"

Ve entitiesLogicalCollectionName "listeler"

"LogicalCollectionName": "listeler"

t.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Geri bildiriminiz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×