Microsoft Dynamics CRM 2011 Outlook istemcisi dış IFD web adresine yapılandırılamıyor

Bu makale, kullanıcıların Microsoft Dynamics CRM Outlook istemcisini dış web adresiyle yapılandıramaması ve kimlik bilgilerinizin kimliğini doğrulayamadığımız için Microsoft Dynamics CRM sunucusuna bağlanılamıyor hatasıyla ilgili bir çözüm sağlar.

Şunlar için geçerlidir: Microsoft Dynamics CRM 2011
Özgün KB numarası: 2912175

Belirtiler

Microsoft Dynamics CRM 2011 dağıtımı, Active Directory Sertifika Hizmetleri (ADFS) kullanılarak İnternet'e Yönelik Dağıtım (IFD) için yapılandırıldığında, Microsoft Dynamics CRM Outlook istemcisini dış web adresiyle yapılandırmaya çalışırken kullanıcılar aşağıdaki hatayı alabilir:

Kimlik bilgilerinizin kimliğini doğrulayamadığımız için Microsoft Dynamics CRM sunucuya bağlanılamıyor. Bağlantınızı denetleyin veya daha fazla yardım için yöneticinize başvurun.

Yapılandırma günlüğü gözden geçirilirken aşağıdaki özel durum da yakalanır:

URL'ye bağlanırken hata oluştu: https://crmorg.domain.com/XRMServices/2011/Discovery.svc Özel Durum: System.ServiceModel.EndpointNotFoundException: konumunda https://adfs.domain.com/adfs/services/trust/13/username iletiyi kabul edebilecek bir uç nokta yoktu.

Ancak, kullanıcılar bir web tarayıcısı üzerinden hata olmadan dış URL'ye erişmeye devam edebilir.

Neden

/adfs/services/trust/13/username uç noktası etkinleştirilebilir. Bu uç nokta etkinleştirildiğinde, istemci kullanıcı adı ve kerberos karma uç noktalarına ulaşamaz ve bu da kimlik doğrulamasının başarısız olmasına neden olur.

Çözüm

/adfs/services/trust/13/username uç noktasını devre dışı bırakın ve ADFS hizmetini yeniden başlatın. Bu eylemi gerçekleştirmek için aşağıdaki adımlara bakın:

  1. AD FS Yönetim Konsolu'nu açın.
  2. Sol gezinti bölmesinde Hizmet'i genişletin ve uç noktalar'ı seçin.
  3. Uç nokta listesinde /adfs/services/trust/13/kullanıcı adı uç noktasını bulun ve sağ tıklayın.
  4. Devre dışı bırak'ı seçin.
  5. AD FS hizmetini yeniden başlatın.