MailboxNotEnabledForRESTAPI uyarısı Microsoft Dynamics 365 posta kutusu uyarısında görünüyor

Bu makalede, Microsoft Dynamics 365 posta kutusu uyarısında oluşan bir hatanın çözümü sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365 Müşteri Etkileşimi Çevrimiçi
Özgün KB numarası: 4534628

Belirtiler

Dynamics 365 bir posta kutusu uyarısında aşağıdaki örneğe benzer bir uyarı görürsünüz:

"E-posta iletisi gönderilirken genel bir posta kutusu erişim hatası oluştu EXO profili aracılığıyla gelen ile SSS'yi test edin ama posta kutusu Posta Kutusu <Adı> aracılığıyla gerçekten şirket içinde. İlişkili e-posta sunucusu profili Microsoft Exchange Online sahibine bildirimde bulunuldu. Sistem, iletiyi daha sonra yeniden göndermeyi dener.
Email Sunucusu Hata Kodu: MailboxNotEnabledForRESTAPI. Exchange.server 404 hatası döndürdü."

Neden

Posta kutusu Dynamics 365'da bir Exchange Online e-posta sunucusu profiliyle yapılandırılmışsa ancak posta kutusu aslında bir Exchange şirket içi posta kutusuysa bu uyarı günlüğe kaydedilebilir.

Çözüm

Posta kutusu bir Exchange şirket içi posta kutusuysa, posta kutusu kaydında yapılandırılan Email Sunucu Profilinin bir Exchange Online profili olmadığını doğrulayın. Şirket içi Exchange posta kutusuna bağlanırken bir Exchange Server (Karma) profili kullanılmalıdır.

şirket içi Exchange ile Dynamics 365 Online'ı yapılandırma hakkında daha fazla bilgi için bkz. Customer Engagement uygulamaları için Dynamics 365 'ı (çevrimiçi) Exchange Server (şirket içi) olarak bağlama.