UnknownIncomingEmailIntegrationError -2147220891 özel durum hatası Microsoft Dynamics 365

Bu makalede, Microsoft Dynamics 365'de posta kutusu uyarılarında oluşan bir hataya çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4466423

Belirtiler

Dynamics 365'da bir posta kutusu kaydındaki uyarılar bölümünü görüntülerken aşağıdaki iletilerden birini görürsünüz:

  • "Posta< Kutusu Adı>" posta kutusu aracılığıyla e-posta alınırken bilinmeyen bir hata oluştu. İlişkili e-posta sunucusu profili Profil <Adı'nın> sahibine bildirimde bulunuldu. Sistem daha sonra yeniden e-posta almaya çalışacaktır.

    Email Sunucusu Hata Kodu: Exchange sunucusu UnknownIncomingEmailIntegrationError -2147220891 özel durumu döndürdü."

  • "Posta Kutusu Adı>" posta kutusu< için randevular, kişiler ve görevler eşitlenirken bir iç Microsoft Dynamics 365 hatası oluştu. İlişkili e-posta sunucusu profili Profil <Adı'nın> sahibine bildirimde bulunuldu. Sistem daha sonra yeniden deneyecektir.

    Email Sunucu Hata Kodu: Crm.80040265.ISV kodu işlemi iptal etti."

Neden

hata kodu 80040265 ve -2147220891 isvAborted hata gösterir.

Belirtiler bölümünde listelenen ilk iletiyi görürseniz, bunun nedeni genellikle bir e-posta kaydı oluşturulurken çalışan bir iş akışı veya özel eklentidir.

Belirtiler bölümünde listelenen ikinci iletiyi görürseniz, bunun nedeni genellikle bir randevu, kişi veya görev kaydı oluşturulurken çalışan bir iş akışı veya özel eklentidir.

Çözüm

Hatada belirtilen kayıt türünün (örneğin, e-posta, randevu, kişi veya görev) oluşturulması sırasında zaman uyumlu olarak çalışan özel eklentileriniz veya iş akışlarınız olup olmadığını denetleyin. Eklenti veya iş akışı kaydın oluşturulması sırasında hataya neden oluyorsa Server-Side Eşitleme kaydı başarıyla oluşturamaz. Aşağıdaki adımlar, kuruluşunuzda e-posta oluşturma sırasında çalışan iş akışları veya eklentiler olup olmadığını belirlemenize yardımcı olabilir. Aynı adımlar, oluşturulamayan kayıt türüyse randevu gibi diğer varlıklar için de kullanılabilir:

Iş akışı

  1. Dynamics 365 web uygulamasında Ayarlar'a gidin ve İşlemler'i seçin.

  2. Görünümü Etkinleştirilmiş İşlemler olarak değiştirin.

  3. Birincil Varlık sütununa göre sıralayın ve birincil varlık olarak Email ve kategori olarak İş Akışı olan satırları arayın.

    Bunun yerine, Kategori = İş Akışı ve Birincil Varlık = Email filtrelemek için kılavuzdaki filtreleme seçeneklerini kullanabilirsiniz

  4. Yukarıdaki ölçütlere uyan (varsa) bulduğunuz her iş akışını açın.

  5. Seçeneklerde Kayıt oluşturulduğundabaşlat seçeneği belirlenmişse ve Bu iş akışını arka planda çalıştır (önerilen) seçeneği seçili değilse, bu iş akışı bunun nedeni olabilir.

  6. Sayfanın sol tarafındaki İşlem Oturumları bölümünü seçin ve başarıyla oluşturulmamış e-postayla ilgili hataları arayın.

Eklentiler

  1. Dynamics 365 web uygulamasında Ayarlar, Özelleştirmeler'e gidin ve Sistemi Özelleştir'i seçin.
  2. Sdk İleti İşleme Adımları'nu seçin.
  3. Birincil Nesne Türü Kodu (SdkMessage Filtresi) sütununa göre sıralayın ve Email varlığı için herhangi bir satır arayın.
  4. Herhangi bir satır bulursanız ve Yürütme Modu Zaman Uyumlu ise, e-postanın oluşturulmasını engelliyor olabilir.

Sorun tutarlı bir şekilde yeniden üretiliyorsa ve test olarak iş akışını veya eklentiyi geçici olarak devre dışı bırakmak mümkünse, sorunun iş akışının veya eklentinin olup olmadığını belirlemenize olanak sağlayabilir.