When you try to install a hotfix or an update on a client computer that is running Microsoft Dynamics CRM 3.0, the hotfix or update is not installed. Additionally, you receive the following error message:
You do not have permission to update Windows XP. Please contact a system administrator.
Symptoms
This issue may occur if one of the following conditions is true:
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You are not logged on to the client computer as a user who has local administrator permissions.
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The domain Group Policy applied to the client computer is too restrictive for the domain user to install a hotfix or an update.
Cause
To resolve this issue, follow these steps:
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Verify that the user who is trying to install the hotfix or the update has local Administrator permissions. To do this, follow these steps:
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Click Start, click Run, type compmgmt.msc in the Open box, and then click OK.
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Expand System Tools.
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Expand Local Users and Groups.
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Click Groups.
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Right-click Administrators, and then click Properties.
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Verify that the user is a member of the Administrators group, and then click OK.
Note If the user is not a member of the Administrators group, log off the Microsoft Dynamics CRM user, and then log on as a user who is a member of the Administrators group. After you are logged on as a user who has Administrator permissions, add the Microsoft Dynamics CRM user to the local Administrators group.
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Verify that the domain Group Policy is not too restrictive to install a hotfix or an update. To do this, follow these steps:
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Click Start, point to All Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
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Right-click the domain, and then click Properties.
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Click the Group Policy tab.
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Click Default Domain Policy, and then click Edit.
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Expand Computer Configuration.
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Expand Windows Settings.
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Expand Security Settings.
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Expand Local Policies.
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Double-click User Rights Assignment.
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Locate the following policies, and then add the Administrators group to each policy:
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Backup Files and Directories
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Restore Files and Directories
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Manage auditing and security log
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Take ownership of files or other objects
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Debug programs
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Close the Group Policy dialog box and the Active Directory Users and Computers dialog box.
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Click Start, click Run, type cmd in the Open box, and then click OK.
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At the command prompt, type the following commands, and then press ENTER after each command:
gpupdate /force
exit -
Click Yes if you receive a message to restart the computer.