Belirtiler
Microsoft Exchange Server 2019 güncelleştirmesini yükledikten sonra, posta kutusunda öğeleri ararken eksik sonuçlar alabilirsiniz.
Neden
Her Exchange Server yükseltme sırasında Microsoft Search Foundation yeniden yüklenir. Bu işlem her zaman başarıyla tamamlanmasa da, böyle bir hata Exchange Server yükseltmesinin tamamlanmasını durdurmaz.
Bu durumda, yükseltilen sunucu tamamen işlevsel görünüyor. Ancak, Microsoft Search Foundation ile ilişkili hizmetleri çeşitli sorunlar etkiler. Örneğin, Microsoft Exchange Arama hizmeti devre dışı bırakılır veya Noderunner.exe işlemi durdurulur. Bu sorunlar nedeniyle, Exchange Server çalıştıran sunucu posta kutusu öğelerinin dizinini oluşturmayı durdurur. Dizin oluşturma hatası uzun süre devam ederse, dizine alınmamış posta kutusu öğeleri kalıcı bir hata durumuna geçer.
Öğeler bu hata durumuna geçtikten sonra, arama işlemlerini etkileyen sorunlar düzeltilirse, sunucu dizin oluşturma öğelerini sürdürür. Ancak varsayılan olarak, sunucu kalıcı bir hata durumuna giren öğelerin dizinini oluşturmayı denemez. Bu nedenle, bu öğeler arama sonuçlarında görünmez.
Çözüm
Bu sorunu çözmek için kalıcı hata durumundaki öğeler için yeni bir geçersiz kılma oluşturun ve sonra öğeleri yeniden dizine oluşturun. Şu adımları izleyin:
-
Aşağıdaki cmdlet'i çalıştırarak bir ayar geçersiz kılma oluşturun:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Not Bu cmdlet'te, <Derleme Numarası> değerini etkilenen posta kutusunu içeren sunucuda çalışan Exchange Server derlemesinin sayısıyla değiştirin.
-
Aşağıdaki cmdlet'i çalıştırarak yapılandırmayı güncelleştirin:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Bu cmdlet'i çalıştırdıktan sonra%ExchangeInstallPath%\v15\config dizininde BigFunnel.Overrides.ini dosyasını görmeniz gerekir.
-
Daha önce dizine alınmamış posta kutusu öğelerini dizine almak için Exchange Server tetikleme. Bunu yapmak için aşağıdaki cmdlet'i çalıştırın:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant
Notlar:
-
Bu cmdlet'te, <posta kutusu kimliğini> etkilenen posta kutusunun adıyla değiştirin.
-
Cmdlet'inde kullanılan yardımcı adı (BigFunnelRetryFeederTimeBasedAssistant) büyük/küçük harfe duyarlıdır.
-
Cmdlet, Exchange Server 2019 toplu güncelleştirme 11 ve sonraki sürümlerinde kullanılabilir.
Bu cmdlet dizinle ilgili tüm sorunları gidermez. Bunun yerine, Exchange Arama hizmeti hiçbir zaman dizine alınmamış ve Dizinlenmemiş durumda olan öğeleri dizine eklemesini anımsatır.
-
Not: Ayarı geçersiz kılma, öğeleri yeniden dizine almak için posta kutularını taşımak zorunda kalmamanıza yardımcı olur. Ancak, daha fazla CPU kullanımına neden olabileceğinden geçersiz kılma kümesini ortamda kalıcı olarak bırakmamanızı öneririz. Öğeler yeniden dizine alındıktan sonra Remove-SettingOverride cmdlet'ini kullanarak geçersiz kılmayı kaldırın.