Belirtiler
Microsoft Exchange Server 2019 için bir güncelleştirme yükledikten sonra, posta kutusunda arama sonucunda eksik sonuçlarla karşı çıkabilirsiniz.
Neden
Her yükseltme Exchange Server sırasında Microsoft Arama Foundation yeniden yüklenir. Bu işlem her zaman başarılı bir şekilde tamamlanmasa da, böyle bir hata yükseltmenin Exchange Server tamamlandıktan sonra durmaz.
Bu durumda, yükseltilen sunucu tam işlevsel gibi görünür. Ancak, çeşitli sorunlar Microsoft Arama Foundation ile ilişkili hizmetleri etkiler. Örneğin, Microsoft Arama Exchange devre dışı bırakılır veya Noderunner.exe durdurulur. Bu sorunlar nedeniyle, çalışan sunucu posta kutusu Exchange Server öğelerini dizine alamadı. Dizin oluşturma hatası uzun bir süre devam ederse, dizine alınmayacak posta kutusu öğeleri kalıcı bir hata durumuna gider.
Öğeler bu hata durumuna girdikten sonra, arama işlemlerini etkileyen sorunlar düzeltildikten sonra, sunucu öğelerin dizinini oluşturma işlemini sürdürecek. Bununla birlikte, sunucu varsayılan olarak kalıcı bir hata durumuna yol alan öğelerin dizinini oluşturmayı denemez. Bu nedenle, bu öğeler arama sonuçlarında görünmez.
Çözüm
Bu sorunu çözmek için, kalıcı hata durumundaki öğeler için yeni bir geçersiz kılma oluşturun ve ardından öğeleri yeniden bölüme oluşturun. Şu adımları izleyin:
-
Aşağıdaki cmdlet'i çalıştırarak bir ayar geçersiz kılma oluşturun:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Not Bu cmdlet'te, <Derleme Numarası>'in yerine etkilenen posta kutusunu içeren sunucuda çalışan Exchange Server derlemesi numarasını girin.
-
Aşağıdaki cmdlet'i çalıştırarak yapılandırmayı güncelleştirin:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Bu cmdlet'i çalıştırdikten sonra, BigFunnel.Overrides.ini dosyasını %ExchangeInstallPath%\v15\config dizininde görüyor olun.
-
Tetik Exchange Server önceden dizine alınmış posta kutusu öğelerini dizine alın. Bunu yapmak için aşağıdaki cmdlet'i çalıştırın:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant
Notlar:
-
Bu cmdlet'<posta kutusu kimliği> etkilenen posta kutusunun adıyla değiştirin.
-
Cmdlet'te kullanılan yardımcının adı (BigFunnelRetryFeederTimeBasedAssistant) büyük/küçük harfe duyarlıdır.
-
Cmdlet, 2019 Exchange Server 11 ve sonraki sürümlerde kullanılabilir.
Bu cmdlet, dizinle ilgili tüm sorunları ele oluşturmaz. Bunun yerine, Exchange Dizine ekli olmayan ve Dizine Ekli olmayan durumda olan öğeleri dizine alan Arama hizmeti tarafından anımsatıldı.
-
Not: Ayar geçersiz kılma, öğeleri yeniden sıralamak için posta kutularını taşımak zorunda kalmamanıza yardımcı olur. Bununla birlikte, ortamda kalıcı olarak geçersiz kılma kümesi bırakmamanizi öneririz çünkü bu CPU kullanımına neden olabilir. Öğeler yenidennden sonra Remove-SettingOverride cmdlet'ini kullanarak geçersiz kılmayı kaldırın.