Belirtiler
Microsoft Exchange Server Kasım 2024 Güvenlik Güncelleştirmesi'ni (SU) (Sürüm 1 veya Sürüm 2) yükledikten sonra, Exchange Server takvimle ilgili bilgileri ve .ical veya .ics ekleri gibi dosyaları işlerken sorunlarla karşılaşırsınız. Bu durumda, dosyaları önizleyemez veya takvime ekleyemezsiniz.
Sorun, Web üzerinde Outlook (OWA) ve Exchange Active Sync (EAS) posta istemcisini mobil cihazda kullandığınızda oluşur. Ayrıca, .ical veya .ics dosya eklerine sahip e-posta iletilerini işlerken bu sorun Exchange Aktarım hizmetini etkileyebilir.
Exchange Server takvim bilgilerini işlemezse, aşağıdaki örneklerden biri gibi olay günlüğü girdileri oluşturur:
w3wp#MSExchangeOWAAppPool,M.Exchange.Net, M.E.E.ExIanaTimeZoneProvider+Cache.AddTimeZone, M.E.ExchangeSystem.InvalidTimeZoneException
Microsoft.Exchange.ExchangeSystem.InvalidTimeZoneException: Time zone id already exists
Neden
bu sorun, Exchange Server IanaTimeZoneMappings.xml dosyasında yinelenen bir girdi kullandığından oluşur.
Geçici çözüm
Yinelenen girdileri kaldırmak için aşağıdaki geçici çözümlerden birini kullanın.
Yöntem 1
Remove-DuplicateEntriesFromIanaMappings içindeki adımları izleyin.
Yöntem 2
-
Aşağıdaki klasörde bulunan IanaTimeZoneMappings.xml dosyasını kaydedin:
<ExchangeInstallationPath>\Microsoft\Exchange Server\V15\Bin -
Not Defteri'ni veya başka bir metin düzenleyicisini kullanarak dosyayı açın ve aşağıdaki girdiyi arayın (iki kez görünür):
<Map IANA="Asia/Bishkek" Win="Orta Asya Standart Saati" /> -
İki girdiden birini silin ve dosyayı kaydedin.
-
Yükseltilmiş bir PowerShell penceresi açın ve aşağıdaki komutları çalıştırın:
Restart-Service -Name W3SVC, WAS -Force
Restart-Service -Name MSExchangeTransport
Durum
Microsoft, bu sorunun "Şunlar için geçerlidir" bölümünde listelenen ürünleri etkilediğini doğruladı. Microsoft, gelecekteki bir güncelleştirmede sorunun çözümü üzerinde etkin bir şekilde çalışmaktadır.