HATA #: 8808 (İçerik Bakımı)HATA #: 232596 (OfficeNet) Bu makale yalnızca bir Microsoft Access veritabanı (.mdb) için geçerlidir.Orta: Temel makro, kodlama ve birlikte çalışabilirlik becerileri gerektirir.

Belirtiler

Bir XML belgesine Access sorgusu dışa aktarDığınızda ve sorgu ölçütlerde yıldız (*) gibi bir Microsoft Jet joker karakteri içeriyorsa, veriler XML belgesine dışa aktarılmaz. Bu nedenle, ortaya çıkan XML belge herhangi bir veri içermez. Access'i kullanarak aynı sorguyu çalıştırdığınızda sorgu düzgün çalışır.

Neden

Bu davranış, XML'e dışa aktardığınızda oluşur. XML, verileri veritabanından sorgulamak için ActiveX Veri Nesneleri 'ni (ADO) kullanır. Access sorgusunda Jet'e özgü joker karakter kullandığınızda, sorgu kayıt döndürür. ADO sadece Amerikan Ulusal Standartlar Enstitüsü (ANSI) 92 joker karakter tanır çünkü bu sorun oluşur.

Geçici Çözüm

Geçici bir çözüm olarak aşağıdaki yöntemlerden birini kullanın.

Yöntem 1

Sorguyu Jet'e özgü joker karakter ile ANSI 92 joker karakterdeğiştirmek için yeniden yazabilirsiniz. Örneğin, özgün sorgu * joker karakter ile buna benzer görünebilir:

SELECT Customers.CustomerIDFROM CustomersWHERE (((Customers.CustomerID)  Like "A*"));

Sorguyu aşağıdaki gibi yeniden yazabilirsiniz:

SELECT Customers.CustomerIDFROM CustomersWHERE (((Customers.CustomerID)  Like "A%"));

Not Access veritabanı ANSI 92 uyumluluğu için yapılandırılmamışsa, Access'ten yeniden yazılmış sorguyu çalıştırdığınızda, hiçbir veri döndürülmez. Ancak, yeniden yazılan sorguyu temel alan dışa aktarılan XML belgesi beklenen sonuçları döndürür.

Yöntem 2

Sorgunun ölçütü joker karakter içermeyecek şekilde sorguyu yeniden yazabilirsiniz. Örneğin, özgün sorgu * joker karakter ile buna benzer görünebilir:

SELECT Customers.CustomerIDFROM CustomersWHERE (((Customers.CustomerID)  Like "A*"));

Sorguyu aşağıdaki gibi yeniden yazabilirsiniz:

SELECT Customers.CustomerIDFROM CustomersWHERE Left(CustomerID,1) = "A";

Yöntem 3

Verileri bir XML belgesine dışa aktardığınızda, nesneye varolan bir filtrenin uygulanıp uygulanmayacağını belirtebilirsiniz. Sorgunun ölçütlerinde joker karakter belirtmek yerine, filtre dizesini istediğiniz ölçütlere eşdeğer ("A*") içeren bir filtre oluşturabilir ve bu filtreyi Dışa Aktarma XML işlemi sırasında uygulayabilirsiniz. Bunu yapmak için, Access sürümüne bağlı olarak aşağıdaki adımları izleyin.

Erişim 2003

  1. Northwind örnek veritabanını açın.

  2. Ekle menüsünde Sorgula'yıtıklatın.

  3. Yeni Sorgu iletişim kutusunda Tasarım Görünümü'nüseçin ve ardından Tamam'ıtıklatın.

  4. Görünüm menüsünde SQL View'ıtıklatın.

  5. Sorgu penceresinde aşağıdaki sorguyu yapıştırın:

    SELECT Customers.CustomerIDFROM Customers;

    Not Sorgunun ölçütünün kaldırıldığını görebilirsiniz. Bu nedenle, sorgu herhangi bir joker karakter içermez.

  6. Dosya menüsünde Kaydet'itıklatın.

  7. Farklı Kaydet iletişim kutusunun Sorgu Adı kutusunda Sorgu1yazın ve ardından Tamam'ıtıklatın.

  8. Görünüm menüsünde Datasheet Görünümü'nütıklatın.

  9. Kayıtlar menüsünde Filtre'yiişaret edin ve gelişmiş filtre/sıralama'yıtıklatın.

  10. Alan listesinde CustomerID'yiseçin.

  11. CustomerIDaltındaki Ölçütler kutusuna aşağıdaki kodu yapıştırın:

    Like "A*"
  12. Filtre menüsünde Filtre Uygula/Sırala'yıtıklatın.

  13. Dosya menüsünde Kaydet'itıklatın.

  14. Dosya menüsünde Kapat'ı tıklatın.

  15. Veritabanı penceresinde Sorgular'ıtıklatın.

  16. Query1'isağ tıklatın ve sonra Dışa Aktar'ıtıklatın.

  17. Dışa Aktar Sorgusu 'Query1' İletişim kutusuna, tür olarak kaydet listesinde XML'i seçin ve sonra Dışa Aktar'ıtıklatın.

  18. Dışa Aktar XML iletişim kutusunda, Diğer Seçenekler'itıklatın.

  19. XML'yi dışa aktar iletişim kutusunda Veri sekmesini seçin. Dışa Aktaran KayıtlarAltında, Varolan filtre onay kutusunu Uygula'yı seçmek için tıklatın ve ardından Tamam'ıtıklatın.

Erişim 2007

  1. Northwind örnek veritabanını açın.

  2. Oluştur sekmesinde, Sorgu Tasarımı'nıtıklatın ve sonra Kapat'ıtıklatın.

  3. Tasarım sekmesinde, Sonuçlar grubunda SQL Görünümü'ni tıklatın.

  4. Sorgu penceresinde aşağıdaki sorguyu yapıştırın:

    SELECT Customers.[First Name]FROM Customers;

    Not Sorgunun ölçütünün kaldırıldığını görebilirsiniz. Bu nedenle, sorgu herhangi bir joker karakter içermez.

  5. Microsoft Office Düğmesinitıklatın ve sonra Kaydet'itıklatın.

  6. Farklı Kaydet iletişim kutusunun Sorgu Adı kutusunda Sorgu1yazın ve ardından Tamam'ıtıklatın.

  7. Giriş sekmesinde, Görünümler grubunda Görünüm'eve ardından Datasheet Görünümü'nitıklatın.

  8. Giriş sekmesinde, Sırala ve Filtre grubunda Gelişmiş'i tıklatın ve sonra Gelişmiş Filtre/Sıralama'yıtıklatın.

  9. Alan listesinde, İlk Ad'ı seçin

  10. Adaltındaki Ölçütler kutusuna aşağıdaki kodu yapıştırın:

    Like "A*"
  11. Giriş sekmesinde, Sırala ve Filtre grubunda Gelişmiş'i tıklatın ve ardından Filtre Uygula/Sırala'yıtıklatın.

  12. Microsoft Office Düğmesinitıklatın ve sonra Kaydet'itıklatın.

  13. Query1'esağ tıklayın, DışaAktar'ı işaret edin, XML Dosyasınıtıklatın ve ardından Tamam'ıtıklatın.

  14. Dışa Aktar XML iletişim kutusunda, Diğer Seçenekler'itıklatın.

  15. XML'yi Dışa Aktar iletişim kutusunda Veri sekmesini tıklatın.

  16. Dışa Aktaran Kayıtlaraltında, varolan filtreyi uygula seçeneğini seçin ve ardından Tamam'ıtıklatın.

  17. Dışa Aktarma - XML Dosya iletişim kutusunda Kapat'ıtıklatın.

Durum

Microsoft, bu makalenin başında listelenen Microsoft ürünlerinde bir hata olduğunu doğruladı.

Ek Bilgi

Access 2003'te sorunu yeniden oluşturma adımları

  1. Northwind örnek veritabanını açın.

  2. Ekle menüsündeSorgula'yıtıklatın.

  3. Yeni Sorgu iletişim kutusunda TasarımGörünümü'nü seçin ve ardından Tamam'ıtıklatın.

  4. Görünüm menüsünde SQL View'ıtıklatın.

  5. Sorgu penceresinde aşağıdaki sorguyu yapıştırın:

    SELECT Customers.CustomerIDFROM CustomersWHERE (((Customers.CustomerID)  Like "A*"));
  6. Dosyamenüsünde Kaydet'i tıklatın.

  7. Farklı Kaydet iletişim kutusundabulunan Sorgu Adı kutusunaQuery1yazın.

  8. Dosya menüsündeKapat'ıtıklatın.

  9. Sorgu1'i sağ tıklatın ve sonra Dışa Aktar'ıtıklatın.

  10. Dışa Aktar Sorgusu 'Query1' To... iletişim kutusunda, tür listesi olarak Kaydet'te XML'i seçin ve sonra Dışa Aktar'ıtıklatın.

  11. Dışa Aktarma XML iletişim kutusunda, XML ile ilgili dosyaları varsayılan konuma kaydetmek içinTamam'ı tıklatın.

  12. Microsoft Internet Explorer'da dışa aktarılan XML dosyasını açın. Belirtilen sorguyu temel alan dışa aktarılan XML dosyasının herhangi bir kayıt içermediğini görebilirsiniz.

Başvurular

ANSI 92 sözdizimi hakkında daha fazla bilgi için Office Assistant'daansi sql sorgu modu hakkında yazın ve ardından Ara'yıtıklatın.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×