Belirtiler
Microsoft SQL Server 2012 ' daki veri kalitesi Istemcisindeki etki alanı yönetimi veya diğer etkinlikler için bir Bilgi Bankası (KB) açmaya çalıştığınızda, aşağıdaki hata iletisini alırsınız:
Veritabanında zaten ' RecentList: KB: etkialanı \ KullanıcıAdı ' adlı bir yapılandırma var. İleti kimliği: ConfigServiceConfigurationAlreadyExists
Neden
Bu sorun, geçerli oturum açan Kullanıcı adı ile son kullanıcı adları arasındaki karşılaştırma büyük/küçük harf duyarlı olduğundan, en son açılan bilgi temellerinin iç listesinde depolanan kullanıcı adının büyük/küçük harf duyarlı olmaması nedeniyle oluşur. Örneğin, şu adımları izleyin:
-
Windows 'da "etkialanı \ Kullanıcı" adlı bir hesap kullanarak oturum açın.
-
Veri kalitesi Istemcisini başarıyla kullanıyorsunuz.
-
Windows oturumunu kapatın ve "etkialanı \ Kullanıcı" adlı bir hesap kullanarak Windows 'ta yeniden oturum açın.
-
Bilgi Bankası açmak için veri kalitesi Istemcisini kullanmaya çalışırsınız.
Bu hata, Kullanıcı kullanıcının Kullanıcı adını yazdıkları zaman küçük ve büyük harflerle kullanılan bir fark nedeniyle oluşabilir.
Çözüm
Toplu güncelleştirme bilgileri
SQL Server 2012
Bu sorunla ilgili düzeltme ilk olarak 1 toplu güncelleştirme ile yayımlanmıştır. SQL Server 2012 için bu toplu güncelleştirme paketini edinme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası 'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
2679368 SQL Server 2012 için toplu güncelleştirme paketi 1Not Derlemeler birikimli olduğundan, her yeni düzeltme sürümü önceki SQL Server 2012 düzeltmesi sürümüyle birlikte gelen tüm düzeltmeleri ve tüm güvenlik düzeltmelerini içerir. Bu düzeltmeyi içeren en son düzeltme sürümünü uygulamayı düşünebilirsiniz. Daha fazla bilgi için Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasına tıklayın:
2692828 SQL Server 2012 sonrasında yayınlanan SQL Server 2012 derlemeleri
Durum
Microsoft bu sorunun "Uygulandığı öğe" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.
Çözüm
Bu sorunu çözmek için aşağıdaki yöntemlerden birini kullanın:
-
Etkilenen Kullanıcı için iç tablodan girişi el ile silme. Bunu yapmak için şu adımları izleyin:
-
Girişlerin varolduğunu doğrulamak için aşağıdaki ifadeyi çalıştırabilirsiniz:
SELECT * FROM DQS_MAIN.dbo.A_CONFIGURATION WHERE NAME like 'RecentList%';
-
Etkilenen kullanıcının kaydını silmek için aşağıdaki ifadeyi çalıştırabilirsiniz:
DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%<Domainname>\<Username>';
Veya tüm kullanıcıların tüm son kayıtlarını silmek için aşağıdaki ifadeyi de çalıştırabilirsiniz. (Bu, istemcideki son kullanıcıların listesini siler.)
DELETE DQS_MAIN.dbo.A_Configuration WHERE NAME LIKE 'RecentList%';
-
-
Veri kalitesi Istemci bilgisayarda oturum açtığınızda kullanıcı hesabınızı belirtmek için tutarlı büyük harfe çevirme kuralları kullanın.