Microsoft hesabıyla oturum açın
Oturum açın veya hesap oluşturun.
Merhaba,
Farklı bir hesap seçin.
Birden çok hesabınız var
Oturum açmak istediğiniz hesabı seçin.

Belirtiler

Microsoft SQL Server 2014 veya SQL Server 2012 'de norecovery seçeneğini kullanan model veritabanı için günlüğün kuyruğunu yedeklemeniz gerektiğini ve veritabanı geri yükleme durumuna koyululacağını varsayalım. Yedekleme tamamlandığında SQL Server hizmetini yeniden başlatmazsanız ve SQL Server hata günlüğünde aşağıdaki hata iletisini alıyorsunuz:

<tarih> <saat> spid10s VERITABANı ' model ' geri yükleme olarak işaretlendi ve kurtarmanın çalıştırılmasına izin vermediği bir durumda. <Tarih> <saat> spid10s hata: 927, önem derecesi: 14, eyalet: 2. <Tarih> <saat> spid10s veritabanı ' modeli ' açılamıyor. Geri yüklemenin ortasında. <tarih> <saat> spid10s tempdb oluşturulamadı. Yeterli kullanılabilir disk alanınız olmayabilir. Tempdb sürücüsündeki diğer dosyaları silerek ek disk alanı boşaltın ve SQL Server 'ı yeniden başlatın. Olay günlüğünde tempdb dosyalarının neden başlatılmadığını belirten ek hataları denetleyin. <tarih> <saat> spid10s sunucunun kapanması nedeniyle durduruldu. Trace ID = ' 1 '. Bu yalnızca bir bilgi iletisidir; Kullanıcı eylemi gerekmez.

Neden

Bu sorun, model veritabanı SQL Server örneğinde oluşturulan tüm veritabanları için şablon olarak kullanıldığı için oluşur. Model veritabanı, kurtarma durumuna izin vermiyor olarak işaretlenmişse, tempdb oluşturulamaz ve SQL Server hizmeti başlayamaz.

Çözüm

Hizmet paketi bilgileri

Bu sorunu çözmek için, SQL Server 2014 Service Pack 1 ' i edinin.

SQL Server 2014 Service Pack 1 (SP1) hakkında daha fazla bilgi için, SQL server 2014 Service Pack 1 ' de düzeltilen hatalarabakın.

Geçici Çözüm

Bu soruna geçici bir çözüm için aşağıdaki yöntemi kullanın:

  • Uygulamadan SQL Server 'a tüm bağlantıları önle

  • SQL Server hizmetini izleme bayrağı 3608 ile birlikte başlatma

  • "Veritabanı modelini kurtarma ile geri yükle" komutunu yürütme

  • 3608 izleme bayrağını kaldırın ve SQL Server 'ı yeniden başlatın

Durum

Microsoft bu sorunun "Uygulandığı öğe" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Daha fazla yardıma mı ihtiyacınız var?

Daha fazla seçenek mi istiyorsunuz?

Abonelik avantajlarını keşfedin, eğitim kurslarına göz atın, cihazınızın güvenliğini nasıl sağlayacağınızı öğrenin ve daha fazlasını yapın.

Topluluklar, soru sormanıza ve soruları yanıtlamanıza, geri bildirimde bulunmanıza ve zengin bilgiye sahip uzmanlardan bilgi almanıza yardımcı olur.

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?
Gönder’e bastığınızda, geri bildiriminiz Microsoft ürün ve hizmetlerini geliştirmek için kullanılır. BT yöneticiniz bu verileri toplayabilecek. Gizlilik Bildirimi.

Geri bildiriminiz için teşekkürler!

×