Microsoft Dynamics CRM 2011'e yükselttikten sonra oturum açan kullanıcının uygun güvenlik izinleri hatası yok

Bu makalede, oturum açan kullanıcının bu kayıtları görüntülemek veya bu hatayı gerçekleştirmek için uygun güvenlik izinlerine sahip olmaması nedeniyle Microsoft Dynamics CRM 2011'e yükseltememe sorununu çözmek için bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics CRM 2011
Özgün KB numarası: 953962

Belirtiler

Microsoft Dynamics CRM 2011'e yükselttikten sonra, kullanıcı Microsoft Dynamics CRM'da bir eylem gerçekleştirmeye çalışırken aşağıdaki hatayla karşılaşabilir:

Oturum açan kullanıcının bu kayıtları görüntülemek veya belirli bir eylemi gerçekleştirmek için uygun güvenlik izinleri yok.

Microsoft Dynamics CRM platform izlemesi etkinleştirilirse platform izlemesi aşağıdaki hata bilgilerini içerir:

MSCRM Hata Raporu:

--------------------------------------------------------------------------------------------------------
Hata: Sunucu isteği işleyemedi.
Hata Numarası: 0x80040220
Hata İletisi: SecLib::CrmCheckPrivilege başarısız oldu. UserId: ID ve PrivilegeId<: <Id> üzerinde hr = -2147220960 döndürüldü>

Not

Bu örnek bilgilerde UserId değeri ve PrivilegeId değeri, gerçek değerlerin yer tutucularıdır.

Neden

Microsoft Dynamics CRM 2011'e yükselttiğiniz zaman, özel güvenlik rollerine tüm yeni özellikler için otomatik olarak ayrıcalık verilmez. Yalnızca kullanıma hazır rollere varsayılan ayrıcalıklar verilir.

Bu sorun, kullanıcının rolüne eylemi gerçekleştirmek için gereken bir ayrıcalık verilmemesi durumunda da oluşabilir. Bu durum, aşağıdaki koşullardan biri doğruysa oluşabilir:

  • Rol sıfırdan oluşturuldu.
  • Rol, standart bir rolden kopyalandı. Ardından rol kapsamlı bir şekilde düzenlendi.

Çözüm

Bu sorunu çözmek için aşağıdaki adımları izleyin.

Not

Bu adımlar, Microsoft Dynamics CRM platform izlemesinden bilgi sahibi olmanız gerekir.

  1. Microsoft Dynamics CRM platformu izlemesinde görüntülenen hata bilgilerinde PrivilegeId değerini bulun.

  2. PrivilegeId değerini kullanan bir SQL sorgusu çalıştırarak eksik ayrıcalığı belirleyin. Örneğin, OrganizationName_MSCRM veritabanında aşağıdakine benzer bir SQL sorgusu çalıştırın:

    select Name, * from PrivilegeBase where PrivilegeId = 'a8ecac53-09e8-4a13-b598-8d8c87bc3d33'
    
  3. Kullanıcıya eksik ayrıcalığı vermek için şu adımları izleyin:

    1. 2011 Microsoft Dynamics CRM başlayın.
    2. Ayarlar'ı seçin, Ayarlar'ın altında Yönetim'i ve ardından Güvenlik Rolleri'ne tıklayın.
    3. Kullanıcıya atanan role çift tıklayın.
    4. Kullanıcının rolüne eksik ayrıcalığı verin. Örneğin, kullanıcının rolüne prvReadLead ayrıcalığı vermek için Çekirdek Kayıtlar sekmesini seçin ve ardından Müşteri Adayı satırında uygun Okuma ayrıcalığını seçin.
    5. Kaydet ve Kapat'ı seçin.