Belirtiler

Microsoft Dynamics CRM 2011'e yükselttikten sonra bir kullanıcının ne zaman aşağıdaki hatalardan biriyle karşılaşabilirsiniz Microsoft Dynamics CRM'de bir eylem gerçekleştirmeye:

Oturum açmış kullanıcının, bu kayıtları görüntülemek veya belirli bir eylemi gerçekleştirmek için gereken güvenlik izinleri yok.




Microsoft Dynamics CRM platformu izleme etkinleştirilmişse, aşağıdaki hata bilgilerini platform izleme içerir: > MSCRM hata raporu:


--------------------------------------------------------------------------------------------------------
Hata: Sunucu isteği işleyemedi.
Hata numarası: 0x80040220
Hata iletisi: SecLib::CrmCheckPrivilege başarısız oldu. Döndürülen hr = kullanıcı kimliği üzerinde-2147220960: e65023ae-54d1-da11-8e39-00145e3d5192 ve PrivilegeId: a8ecac53-09e8-4a13-b598-8d8c87bc3d33


Not: Bu örnekte bilgileri, kullanıcı kimliği değeri ve PrivilegeId değeri fiili değerleri için yer tutuculardır.

Neden

Microsoft Dynamics CRM 2011'e yükselttiğinizde, özel güvenlik rollerine ayrıcalıkları tüm yeni özellikleri otomatik olarak verilmez. Giden kutusu rolleri yalnızca varsayılan ayrıcalıklar verilir.

Bu sorun ayrıca kullanıcının rolünü eylemi gerçekleştirmek için gereken ayrıcalık verilmemişse ortaya çıkabilir. Bu durum, aşağıdaki koşullardan biri doğru olduğunda oluşabilir:

  • Rol sıfırdan oluşturulmuştur.

  • Standart rolden rol kopyalanmıştır. Daha sonra rol kapsamlı bir şekilde düzenlendi.

Çözüm

Bu sorunu gidermek için aşağıdaki adımları izleyin.

Not: Microsoft Dynamics CRM platformu izleme bilgileri sağlamak aşağıdaki adımları gerektirir.

  1. Microsoft Dynamics CRM platformu izlemeye, görünen hata bilgileri PrivilegeId değerini bulun.

  2. PrivilegeId değeri kullanan bir SQL sorgusu çalıştırarak eksik ayrıcalık belirler. Örneğin, kuruluş adı_MSCRM veritabanıyla aşağıdakine benzer bir SQL sorgusu çalıştırın:

    select Name, * from PrivilegeBase where PrivilegeId = 'a8ecac53-09e8-4a13-b598-8d8c87bc3d33'
  3. Kullanıcıya eksik ayrıcalığı vermek için şu adımları izleyin:

    1. Microsoft Dynamics CRM 2011 başlatın.

    2. Ayarlar' ı tıklatın, Yönetim altında Ayarlar' ı tıklatın ve sonra Güvenlik rollerinitıklatın.

    3. Kullanıcıya atanan rolün çift tıklatın.

    4. Kullanıcının rolüne eksik ayrıcalığını verin. Örneğin, kullanıcının rolüne prvReadLead ayrıcalığı vermek için Çekirdek Kayıtlar sekmesini tıklatın ve sonra uygun okuma ayrıcalığı neden satır'ı tıklatın.

    5. Kaydet ve Kapat'ıtıklatın.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×