Microsoft hesabıyla oturum açın
Oturum açın veya hesap oluşturun.
Merhaba,
Farklı bir hesap seçin.
Birden çok hesabınız var
Oturum açmak istediğiniz hesabı seçin.

Belirtiler

Aşağıdaki senaryoyu ele alın. Microsoft Sağlama sistem (MPS) sunucu isteklerini Microsoft Solution barındırılan ileti ve işbirliği 4.5 (HMC 4.5) ortamı için işler. Daha sonra Active Directory dizin hizmeti Active Directory Sağlayıcısı ad Arama yordamı kullanarak bir arama işlemi gerçekleştirir. Bu durumda, istekleri gecikme süresi artar. Ayrıca, aşağıdaki koşullardan biri doğruysa, bir bellek sızıntısı oluşabilir:

  • MPS sunucusu sık isteklerini gerçekleştirir.

  • Ortamı çok sayıda sağlanan nesneleri içerir.

Neden

Bu sorun oluşur nedeniyle verimsiz bir sorguişlemek, MPS içinde Active Directory Sağlayıcısı ad alanının Arama yordamı kullanarak Active Directory'de nesneleri aranır.

Not: Active Directory Sağlayıcısı ad alanının Arama yordamı doğrudan veya dolaylı olarak diğer ad HMC 4.5 mimarisi sağlama boyunca birçok yordam çağrılır. Active Directory'de bir veya daha fazla nesneleri bulmak bir yordam sahip olduğunda, Arama yordamı Active Directory Sağlayıcısı ad alanının adı verilir.

Çözüm

Düzeltme Bilgileri

Microsoft, desteklenen bir düzeltmeyi kullanıma sunmuştur. Ancak bu düzeltme yalnızca bu makalede anlatılan sorunu düzeltmek amacıyla hazırlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşmış olan sistemlere uygulayın.

İndirilebilir bir düzeltme varsa, bu Bilgi Bankası makalesinin üst kısmında "Düzeltme İndirilebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek bölümüne bir istek gönderin.

Not: Ek sorunlar oluşursa veya sorun giderme gerekiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Tam listesi Microsoft Müşteri Hizmetleri ve destek telefon numaralarını veya ayrı bir hizmet isteği oluşturmak için aşağıdaki Microsoft Web sitesini ziyaret edin:

http://support.microsoft.com/contactus/?ws=supportNot: "Düzeltme indirilebilir” formu, düzeltmenin indirilebildiği dilleri görüntüler. Kendi dilinizi görmüyorsanız, bu dil için bir düzeltme mevcut değil demektir.

Dosya bilgileri

Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yeni dosya özniteliklerine) sahiptir. Bu dosyaların tarihleri ve saatleri Koordinatlı Evrensel Saat'te (UTC) listelenmiştir. Dosya bilgilerini görüntülediğinizde koordinatlı evrensel saat yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için Denetim Masası'ndaki Tarih ve Saat öğesinde Saat Dilimi sekmesini kullanın.

Dosya adı

Dosya sürümü

Dosya boyutu

Tarih

Saat

Platform

Activedirectorypreferreddcprovider.msi

Geçerli değil

142,336

24-Jun-2010

10:58

Geçerli değil

Activedirectoryprovider.msi

Geçerli değil

365,056

24-Jun-2010

10:58

Geçerli değil

Dağıtım


Düzeltmeyi dağıtmak için dağıtım adımları izleyin:

  1. MPS dağıtım aracı ilk MPS sunucusu (MPS01) başlatın.

  2. MPS dağıtım aracı kaldırma Active Directory Sağlayıcısı. Bunu yapmak için şu adımları izleyin:

    1. Çekirdek Platform, genişletme MPS çekirdek yüklemek ve daha sonra MPF çekirdek Namespaces' ı genişletin.

    2. Active Directory Sağlayıcısıseçin ve sonra Kaldır' ı tıklatın.

  3. Dağıtım Başlat' ı tıklatın.

  4. Güncelleştirme paketinden aşağıdaki dosyalar C:\MSIShare\ klasörüne kopyalayın:

    • Activedirectorypreferreddcprovider.msi

    • Activedirectoryprovider.msi

    Not: .Msi dosyaları varolan kopyalarını kaydedin.

  5. MPS dağıtım aracı, Active Directory Sağlayıcısı yükleyin.

  6. Dağıtım Başlat' ı tıklatın.

  7. Tüm MPS altyapısı yeniden başlatın.


Durum

Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin

Eğitimleri keşfedin >

Yeni özellikleri ilk olarak siz edinin

Microsoft Insider’a katılın >

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×