Belirti
Bir posta kutusu kaydı Dynamics 365 Test & posta kutusu Etkinleştir düğmesini tıklattığınızda, aşağıdaki uyarıyı günlüğe kaydedilir ve randevu, kişileri ve görevleri eşitleme başarısız oluyor:
"Bu posta kutusuna posta kutusu kullanıcı yeterli izinlere sahip olmadığından, randevular, kişiler ve görevler < posta kutusu adı > posta kutusu eşitlenemiyor.
Sunucu hata kodu e-posta: Crm.80042f09.UserNotAssignedRoles "
Ayrıntılarını görüntülemek için tıklatın, aşağıdaki ek ayrıntıları gösterilir:
T:1738ActivityId: 3594490d-96d3-493b-861e-023b016a6050 > özel durum: işlenmeyen özel durum: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: eşitleme durumu alınamadı: işlenmeyen özel durum: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, sürüm 8.0.0.0, Culture = bağımsız, PublicKeyToken = 31bf3856ad364e35 =]]: SecLib::RetrievePrivilegeForUser başarısız - kullanıcıya hiçbir rolleri atanmış olan. Döndürülen hr =-2147209463, kullanıcı: < GUID > detay: 3594490d-96d3-493b-861e-023b016a6050-2147209463 SecLib::RetrievePrivilegeForUser başarısız - rol kullanıcıya atanır. Döndürülen hr =-2147209463, kullanıcı: < GUID >...
Neden
Dynamics 365 güvenlik rolü kullanıcıya atanmaz.
Çözüm
Kullanıcıya Dynamics 365 güvenlik rolü atayın. Nasıl bir güvenlik rolü atamak için yönergeler adım için ' ı burada.