Email Sunucu Hata Kodu Crm.80042f09.UserNotAssignedRoles'i bir posta kutusu kaydında Test & Posta Kutusunu Etkinleştir'i seçtikten sonra

Bu makalede, Microsoft Dynamics 365'da bir posta kutusu kaydında Posta Kutusunu Sına & Etkinleştir düğmesini seçtikten sonra oluşan Crm.80042f09.UserNotAssignedRoles hata kodu için bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics CRM
Özgün KB numarası: 4014646

Belirtiler

Microsoft Dynamics 365'da posta kutusu kaydında Posta Kutusunu Etkinleştir & Test et düğmesini seçtiğinizde, aşağıdaki uyarı günlüğe kaydedilir ve Randevu, Kişiler ve Görevler eşitlemesi başarısız olur:

Posta kutusu kullanıcısı bu posta kutusunda yeterli izinlere sahip olmadığından posta kutusu <Posta Kutusu Adı> için randevular, kişiler ve görevler eşitlenemiyor.
Email Sunucusu Hata Kodu: Crm.80042f09.UserNotAssignedRoles

Ayrıntılar'ı görüntülemeyi seçerseniz aşağıdaki ek ayrıntılar gösterilir:

T:1738ActivityId: <Kimlik>>Özel Durumu: İşlenmeyen Özel Durum: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Eşitleme durumu alınamadı: İşlenmemiş Özel Durum: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: SecLib::RetrievePrivilegeForUser başarısız oldu- kullanıcıya hiçbir rol atanmadı. döndürülen hr = -2147209463, Kullanıcı: <GUID> Ayrıntısı: <Id> -2147209463 SecLib::RetrievePrivilegeForUser başarısız oldu; kullanıcıya hiçbir rol atanmadı. döndürülen hr = -2147209463, Kullanıcı: <GUID>...

Neden

Kullanıcıya Microsoft Dynamics 365 güvenlik rolü atanmadı.

Çözüm

Kullanıcıya bir Microsoft Dynamics 365 güvenlik rolü atayın. Güvenlik rolü atama yönergeleri için bkz. Kullanıcı oluşturma ve güvenlik rolleri atama.