Server-Side Eşitleme kullanılırken PrivilegeDenied hatası oluşuyor

Bu makalede, Microsoft Dynamics 365'da Server-Side Eşitleme kullandığınızda oluşan PrivilegeDenied hatasına çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics CRM
Özgün KB numarası: 4015092

Belirtiler

Dynamics 365'da Server-Side Eşitlemesi kullanırken, Test & Posta Kutusunu Etkinleştir'i seçtikten sonra aşağıdaki hatayı alırsınız:

"Posta kutusu kullanıcısı bu posta kutusunda yeterli izinlere sahip olmadığından, posta kutusu <Posta Kutusu Adı> için randevular, kişiler ve görevler eşitlenemiyor.
Email Sunucusu Hata Kodu: Crm.80040220.PrivilegeDenied"

Neden

Posta kutusu kaydıyla ilişkilendirilmiş kullanıcının Server-Side Eşitlemesi'ni kullanmak için yeterli ayrıcalığı yoksa bu hata görüntülenir.

Çözüm

Kullanıcının güvenlik rolünü eksik ayrıcalığı içerecek şekilde değiştirin. Ayrıntılar bölümünü seçtiğinizde, eksik ayrıcalığının adını içermelidir. Aşağıdaki örnekte, kullanıcının Email Sunucu Profili varlığı için okuma ayrıcalığı eksiktir.

T:331ActivityId: <GUID Özel Durumu: İşlenmeyen Özel Durum: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Eşitleme durumu güncelleştirilemedi: İşlenmemiş Özel Durum: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Asıl kullanıcı (Id=<GUID>, type=8) eksik prvReadEmailServerProfile ayrıcalığı (Id=<ID>)Ayrıntı: <KIMLIK>>> -2147220960 Asıl kullanıcı (Id=<GUID>, type=8) eksik prvReadEmailServerProfile ayrıcalığı (Id=edebe6f6-cf2e-45...

Server-Side Eşitleme'yi kullanmak için gerekli olabilecek ayrıcalıkların listesi için Daha Fazla Bilgi bölümüne bakın.

Daha fazla bilgi

Aşağıdaki tabloda, Server-Side Eşitlemesi'ni kullanmak için gereken ayrıcalıklar ve ayrıcalığı bulunabilecek bir güvenlik rolündeki sekme listelenir. Sistem Yöneticisi rolüne sahip bir kullanıcı Ayarlar, Güvenlik, Güvenlik Rolleri'ne giderek bir güvenlik rolünü bulabilir ve değiştirebilir. Belirli bir kullanıcıya hangi rollerin atandığı görmek için Ayarlar'a gidin, Güvenlik'i seçin, Kullanıcılar'ı seçin, belirli Kullanıcı kaydını ve ardından Rolleri Yönet'i seçin.

Ayrıcalık adı Varlık Güvenlik rolü içindeki konum (sekme)
prvReadEmailServerProfile EmailServerProfile İş Yönetimi
prvWriteMailbox Posta kutusu İş Yönetimi
prvReadMailbox Posta kutusu İş Yönetimi
prvReadOrganization Organizasyon İş Yönetimi
prvSyncToOutlook (exchangesyncidmapping) Outlook İş Yönetimi --> Gizlilikle ilgili ayrıcalıklar
prvReadActionCard ActionCard Çekirdek Kayıtlar
prvDeleteActivity Etkinlik Çekirdek Kayıtlar
prvAppendActivity Etkinlik Çekirdek Kayıtlar
prvWriteActivity Etkinlik Çekirdek Kayıtlar
prvCreateActivity Etkinlik Çekirdek Kayıtlar
prvReadActivity Etkinlik Çekirdek Kayıtlar
prvAppendToActivity Etkinlik Çekirdek Kayıtlar
prvReadConnection Bağlantı Çekirdek Kayıtlar
prvAssignContact Kişi Çekirdek Kayıtlar
prvReadContact Kişi Çekirdek Kayıtlar
prvWriteContact Kişi Çekirdek Kayıtlar
prvCreateContact Kişi Çekirdek Kayıtlar
prvDeleteContact Kişi Çekirdek Kayıtlar
prvReadUserQuery Kaydedilmiş Görünüm Çekirdek Kayıtlar
prvReadQueue Sıra Çekirdek Kayıtlar
prvReadQuery Görünüm Özelleştirme
prvReadIncident Durumda Hizmet
prvSearchAvailability Hizmet Yönetimi --> Çeşitli Ayrıcalıklar
prvOverrideCreatedOnCreatedBy Hizmet Yönetimi --> Çeşitli Ayrıcalıklar