Windows 7 tabanlı bir bilgisayarda dosya sunucusuna bağlandığında bir dosya sunucusuna erişirken gecikme

Belirtiler

Aşağıdaki senaryoyu düşünün:

  • Windows 7 Service Pack 1 (SP1) veya Windows Server 2008 R2 SP1 çalıştıran bir istemci bilgisayar var.

  • Windows Server 2012 çalışan bir dosya sunucusu veya Windows Server 2012 R2 istemci bilgisayara bağlanın.

  • İstemci bilgisayarın dosya sunucusuna yeniden farklı bir Evrensel Adlandırma Kuralı (UNC) yolu kullanarak bağlanın.

Bu senaryoda, diğer istemci bilgisayarlar aynı dosya sunucusuna erişmeye çalıştığınızda bir gecikmeyle karşılaşabilirsiniz.

Neden

Windows 7 tabanlı bir istemci bilgisayar farklı bir UNC yolu kullanan bağlantılar için aynı istemci Kimliğini kullandığından, bu sorun oluşur. Daha sonra dosya sunucusunun bir oplock break isteği göndermek için uygun bağlantıyı belirleyemez.

Çözüm

Bu sorunu gidermek için Windows 7 veya Windows Server 2008 R2 için bir güvenlik güncelleştirmesi ve düzeltme paketi yayımlandı.

Not Bu düzeltme yalnızca Windows 7 tabanlı bir istemci bilgisayara yüklemelisiniz.

Düzeltmeyi yüklemeden önce bu makaledeki Önkoşullar bölümüne bakın.

Windows 7 ve Windows Server 2008 R2 güncelleştirmesini edinin

Bu sorunu gidermek için MS15-011 güvenlik bülteninde belgelenen yükleyin.

Windows 7 ve Windows Server 2008 R2 için düzeltmeyi edinin.

Microsoft, desteklenen bir düzeltmeyi kullanıma sunmuştur. Ancak bu düzeltme yalnızca bu makalede anlatılan sorunu düzeltmek amacıyla hazırlanmıştır. Bu düzeltmeyi yalnızca bu makalede açıklanan sorunun yaşandığı sistemlere uygulayın. Bu düzeltme, ek test süreci gerektirebilir. Bu nedenle bu sorundan ciddi bir şekilde etkilenmiyorsanız, bu düzeltmeyi içeren bir sonraki yazılım güncelleştirmesini beklemeniz önerilir.

İndirilebilir bir düzeltme varsa, bu Bilgi Bankası makalesinin üst kısmında "Düzeltme İndirilebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek'e başvurun.

Not: Ek sorunlar oluşursa veya sorun giderme gerekiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi ya da ayrı bir hizmet isteği oluşturmak için aşağıdaki Microsoft web sitesine gidin:

Not: "Düzeltme indirilebilir” formu, düzeltmenin indirilebildiği dilleri görüntüler. Kendi dilinizi görmüyorsanız, bu dil için bir düzeltme mevcut değil demektir.

Önkoşullar

Bu düzeltmeyi uygulamak için için Windows 7 veya Windows Server 2008 R2 çalışmalıdır.

Kayıt defteri bilgileri

Bu düzeltmeyi uygulamak için kayıt defterinde herhangi bir değişiklik yapmanız gerekmez.

Yeniden başlatma gereksinimi

Bu düzeltmeyi uyguladıktan sonra bilgisayarı yeniden başlatmanız gerekebilir.

Düzeltme değiştirme bilgileri

Bu düzeltme önceden yayımlanmış bir düzeltmenin yerini almaz.

Durum

Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Daha fazla bilgi

Yazılım güncelleştirme terminolojisi hakkında daha fazla bilgi için bkz: .

Bu düzeltmenin genel sürümü aşağıdaki tablolarda listelenen özniteliklere sahip dosyaları yükler. Bu dosyaların tarih ve saatleri Eşgüdümlü Evrensel Saat'te (UTC) listelenmiştir. Yerel bilgisayarınızda bu dosyaların tarih ve saatleri, yerel saatiniz ile geçerli gün ışığından yararlanma saati (DST) bilgilerine göre görüntülenir. Ayrıca, dosyalarda belirli işlemleri gerçekleştirdiğinizde tarihler ve saatler değişebilir.

Windows 7 ve Windows Server 2008 R2 dosya bilgileriyle ilgili notlar

Önemli Windows 7 düzeltmeleri ve Windows Server 2008 R2 düzeltmeleri aynı paketlerinde bulunur. Ancak, düzeltmeler düzeltme isteği sayfasında her iki işletim sistemi altında listelenir. Bir veya her iki işletim sistemleri için geçerli olan düzeltme paketini istemek için "Windows 7/Windows altında Server 2008 R2" sayfada listelenen düzeltme'yi seçin. Her zaman her düzeltmenin uygulandığı gerçek işletim sistemini belirlemek için bir makale "Aşağıdakilere Uygulanır" bölümüne bakın.

  • Belirli bir ürün, aşama (RTM, SPn) ve hizmet dalı (LDR, GDR) için geçerli dosyalar, aşağıdaki tabloda gösterildiği şekilde dosya sürümü numaraları incelenerek belirlenebilir:

  • Şunlardır dosyaları (.manifest) ve yüklü olan MUM dosyaları (.mum her ortam için) "Ek bilgi için Windows 7 ve Windows Server 2008 R2 dosya" bölümünde ayrı olarak listelenmektedir . MUM, MANIFEST ve ilişkili güvenlik kataloğu (.cat) dosyaları, güncelleştirilen bileşenlerin durumunu korumak için oldukça önemli dosyalardır. Özniteliklerin listelenmediği güvenlik kataloğu dosyaları, Microsoft dijital imzası kullanılarak imzalanmıştır.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Geri bildiriminiz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×