BITS hizmetini başlatmayı denerseniz "Hizmete Özgü Hata Kodu -2147944102" hata iletisi

Bu makale, Arka Plan Akıllı Aktarım Hizmeti (BITS) Hizmetini başlattığınızda oluşan hata 2147944102 bir çözüm sağlar.

Şunlar için geçerlidir: Windows Server 2012 R2
Özgün KB numarası: 326460

Belirtiler

BITS hizmetini Terminal Hizmetleri'nin yüklü olduğu Windows 2000 tabanlı bir bilgisayarda başlatmaya çalışırsanız aşağıdaki belirtilerle karşılaşabilirsiniz:

  • Aşağıdaki hata iletilerinden birini alırsınız:

    Windows, Yerel Bilgisayarda Arka Plan Akıllı Aktarım Hizmeti'ni başlatamadı. Daha fazla bilgi için Sistem Olay Günlüğü'nü gözden geçirin. Bu Microsoft dışı bir hizmetse, hizmet satıcısına başvurun ve hizmete özgü hata kodu -2147023194 konusuna bakın.

    -veya-

    Hizmete özgü bir hata oluştu: -2147944102.

  • Aşağıdaki olay Windows NT Olay Görüntüleyicisi Sistem günlüğüne kaydedilir:

    Olay Türü: Hata
    Olay Kaynağı: Hizmet Denetim Yöneticisi
    Olay Kategorisi: Yok
    Olay Kimliği: 7024
    Kullanıcı: Yok
    Açıklama: Arka Plan Akıllı Aktarım Hizmeti hizmeti hizmete özgü hata 2147944102 sonlandırıldı.

Neden

Terminal Hizmetleri hizmeti devre dışı bırakılırsa bu davranış oluşabilir.

Varsayılan olarak, Terminal Hizmetleri bileşeni yüklendiğinde, Terminal Hizmetleri hizmetinin başlangıç türü Otomatik olarak ayarlanır. Bir yönetici hizmetin başlangıç türünü Devre Dışı olarak değiştirirse, BITS hizmeti başlatılmaz.

Çözüm

Bu sorunu çözmek için Microsoft Windows 2000 için en son hizmet paketini edinin.

Geçici Çözüm

Bu sorunu geçici olarak çözmek için aşağıdaki yöntemlerden birini kullanın (sizin durumunuz için uygun).

Yöntem 1: Terminal Hizmetlerini Otomatik Olarak Başlatacak Şekilde Yapılandırma

Terminal Hizmetleri hizmetini otomatik olarak başlatılacak şekilde yapılandırmak için şu adımları izleyin:

  1. Başlat'a tıklayın, Ayarlar'ın üzerine gelin ve Denetim Masası'e tıklayın.
  2. Yönetimsel Araçlar'a çift tıklayın ve ardından Hizmetler'e çift tıklayın.
  3. Sağ bölmede Terminal Hizmetleri'ne sağ tıklayın ve ardından Özellikler'e tıklayın.
  4. Genel sekmesine tıklayın.
  5. Başlangıç türü kutusunda Otomatik'e ve ardından Tamam'a tıklayın.

Yöntem 2: Terminal Hizmetlerini Kaldırma

Terminal Hizmetleri'ne ihtiyacınız yoksa veya sunucuda kullanımda değilse Terminal Hizmetleri'ni kaldırın. Bunu yapmak için şu adımları uygulayın:

  1. Başlat'a tıklayın, Ayarlar'ın üzerine gelin ve Denetim Masası'e tıklayın.
  2. Program Ekle/Kaldır'a çift tıklayın.
  3. Windows Bileşenleri Ekle/Kaldır'a tıklayın.
  4. Windows Bileşenleri Sihirbazı'nda, Terminal Hizmetleri onay kutusunu temizlemek için tıklayın ve ardından İleri'ye tıklayın.
  5. Windows Bileşenleri Sihirbazı Tamamlanıyor sayfasında Son'a tıklayın.
  6. Program Ekle/Kaldır penceresinde Kapat'a tıklayın.

Durum

Microsoft, bu makalenin başında listelenen Microsoft ürünlerinde bunun bir sorun olduğunu onayladı. Bu sorun ilk olarak Microsoft Windows 2000 Service Pack 4'te düzeltildi.

Daha fazla bilgi

Bu makalenin "Belirtiler" bölümünde açıklanan sorun, Terminal Hizmetleri'nin yüklü olduğu Windows 2000 Server tabanlı bir bilgisayara Microsoft Yazılım Güncelleştirme Hizmetleri (SUS) 1.0 veya Otomatik Güncelleştirmeler 2.2 istemcisini yükledikten sonra da oluşabilir.