"Remote Desktop Services is currently busy" or "The Group Policy Client failed logon" error when you log on to an application in Windows Server 2008 R2

This article describes a problem that occurs when you log on to a computer in Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1. A hotfix is available to resolve this problem. The hotfix has a prerequisite.

Symptoms

When you log on to a Windows 2008 R2-based server and access an application by using Remote Desktop Protocol (RDP), you receive one of the following error messages:
  • The task you are trying to do can't be completed because Remote Desktop Service is currently busy.
  • The Group Policy Client failed the logon.

Cause

This problem occurs because of a synchronization issue in the user profile service (profsvc) between the work thread and the main service routine. When the user profile service stops, the service might still be busy trying to clean up the profiles.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Prerequisites

To apply this update, you must have Service Pack 1 installed in Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology that Microsoft uses to describe software updates.
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Ідентифікатор статті: 3014783 – останній перегляд: 19 бер. 2015 р. – виправлення: 1

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