Після інсталяції Adobe Acrobat 7.0 не вдається зберегти зміни у програмі Word або з'являється повідомлення про помилку в застосунку Office


Увага! Ця стаття містить відомості про внесення змін до реєстру. Перш ніж вносити такі зміни, обов'язково створіть резервну копію реєстру. та переконайтеся, що ви будете спроможні відновити реєстр у разі виникнення проблеми. Додаткові відомості щодо створення резервної копії, відновлення та редагування реєстру можна отримати у статті бази знань Microsoft Knowledge Base:
256986 Опис реєстру Microsoft Windows

ОЗНАКИ


Під час запуску однієї з програм Microsoft Office, перелічених у розділі "Застосовується до", можуть проявитися одна або декілька таких ознак:
  • Зміни робочої області документа після закриття Microsoft Word не зберігаються. До таких змін відносяться наступні:
    • створення макросу;
    • зміна шрифту за промовчанням;
    • додавання елемента автотексту;
    • додавання панелі інструментів.
  • Після перезапуску Word додані або змінені елементи відсутні.

    Примітка. Подібна поведніка спостерігається навіть якщо встановлено прапорець Запит на збереження шаблону Normal.dot.
  • Під час спроби запустити застосунок Office з'являється одне з таких повідомлень про помилку:
    visual c++ runtime error
    Microsoft visual c++ runtime library

    Program files\Microsoft office\office10\ім'я_продукта.exe

    This application has requested the runtime to terminate it in an unusual way (Запит до середовища виконання від застосунку на закриття його в незвичайний спосіб).
  • Під час відкриття документа Word з'являється таке повідомлення про помилку:
    Недостатньо пам'яті або місця на диску. Word не може відобразити необхідний шрифт.
  • Програма Word не працює, й користувач двічі клацає файл, щоб відкрити його у Word. У цьому випадку Word перестає відповідати на запити (зависає).

ПРИЧИНА


Ця проблема може виникати після інсталяції застосунків Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard або Adobe Acrobat 7.0 Elements.

Acrobat 7.0 інсталює надбудову COM у наступній папці:
\Acrobat 7.0\PDFMaker\Office
Ця надбудова COM додає до застосунків Office піктограми та команди меню PDFMaker.

ОБХІДНИЙ ШЛЯХ


Залежно від ситуації, скористайтеся для вирішення проблеми одним з наступних способів. Якщо після закриття Word не зберігаються зміни, скористайтеся способом 1 або 2. Якщо під час спроби запуску застосунку Office або відкриття документа Word з'являється повідомлення про помилку, скористайтеся способом 3 або 4.

Спосіб 1. Збереження макросів, уподобань та користувацьких налаштувань за допомогою команди "Зберегти все" меню "Файл"

Примітка. Цей спосіб не застосовується до Microsoft Office Word 2007.

Щоб зберегти макроси, уподобання та користувацькі налаштування у програмі Word 2003 або раніших версіях, виконайте такі дії:
  1. Натисніть та утримуйте клавішу SHIFT.
  2. У меню Файл виберіть команду Зберегти все.
Зміни буде збережено. Ці зміни будуть доступні також в інших документах Word.

Спосіб 2. Додавання команди "Зберегти все"

У програмі Word необхідно використовувати команду Зберегти все кожний раз при створенні макросу, уподобання або зміні налаштувань.

Щоб додати у Word команду Зберегти все, виконайте одну з наступних дій:

  • У Word 2007 виконайте такі дії, щоб додати команду Зберегти все до панелі швидкого доступу:
    1. Натисніть кнопку Microsoft Office і виберіть команду Параметри Word.
    2. Натисніть кнопку Настроювання.
    3. У полі Вибрати команди з виберіть Усі команди.
    4. У списку нижче поля Вибрати команди з виберіть Зберегти все і натисніть кнопку Додати.
    5. Натисніть кнопку OK, щоб закрити діалогове вікно Параметри Word.
  • У Word 2003 та раніших версіях Word виконайте такі дії для додавання команди Зберегти все у меню Файл:
    1. У меню Сервис виберіть команду Настроювання.
    2. На вкладці Команди натисніть Файл у групі Категорії.
    3. Зі списку Команди перетягніть команду Зберегти все на меню Файл. Коли меню Файл відкриється, розташуйте команду Зберегти все у потрібному місці в меню.
    4. Закрийте діалогове вікно Настроювання.

Спосіб 3. Зверніться до компанії Adobe

Зверніться до компанії Adobe Systems Incorporated за відомостями щодо наявності оновлення для Acrobat 7.0.

Щоб отримати додаткові відомості про спосіб звернутися до Adobe Systems Incorporated, клацніть номер відповідної статті бази знань Microsoft Knowledge Base:
65416 Контактні відомості постачальників устаткування та програмного забезпечення, A-K (Це посилання може вказувати на матеріали, повністю або частково викладені англійською мовою.)

60781 Контактні відомості постачальників устаткування та програмного забезпечення, L-P (Це посилання може вказувати на матеріали, повністю або частково викладені англійською мовою.)

60782 Контактні відомості виробників устаткування та програмного забезпечення, Q-Z (Це посилання може вказувати на матеріали, повністю або частково викладені англійською мовою.)
Корпорація Майкрософт надає вам контактні відомості сторонніх виробників для сприяння отриманню від них технічної підтримки. Ці відомості можуть змінюватися без попередження. Корпорація Майкрософт не гарантує точності контактних відомостей сторонніх виробників.

Спосіб 4. Видалення надбудови Adobe із програм Office

Після видалення надбудови Adobe збереження файлів у форматі PDF (Portable Document File) у застосунках Office буде неможливим.

Щоб видалити надбудову Adobe, виконайте такі дії:

Примітка. Нижченаведені дії можуть різнитися залежно від версії Microsoft Windows, інстальованої на вашому комп'ютері. У цьому разі за описом конкретних дій звертайтеся до документації продукту.
  1. Закрийте всі програми.
  2. Натисніть кнопку Пуск, виберіть пункт Настройки, а потім Панель керування.
  3. Двічі клацніть компонент Інсталяція та видалення програм.
  4. У списку Інстальовані програми виберіть Adobe Acrobat Professional 7.0 і натисніть кнопку Змінити.
  5. Виберіть команду Змінити та натисніть кнопку Далі.
  6. Розгорніть вузол Створити Adobe PDF.
  7. Розгорніть вузол Acrobat PDFMaker.
  8. Клацніть стрілку біля Microsoft Office і виберіть Не інстальовано.
  9. У вікні майстра інсталяції Adobe Acrobat Professional 7.0 натисніть кнопку OK.
  10. Закрийте вікно "Інсталяція та видалення програм"
Якщо після виконання перелічених вище дій проблему не буде усунуто, видаліть надбудову Adobe з реєстру вручну.

Увага! Перед видаленням надбудови Adobe вручну зверніться до компанії Adobe за додатковими відомостями.

Попередження. Неправильне внесення змін до реєстру за допомогою редактора реєстру або в інший спосіб може призвести до серйозних проблем, Ці проблеми можуть викликати необхідність переінсталяції операційної системи. Корпорація Майкрософт не може гарантувати усунення цих проблем. Відповідальність за наслідки змінення реєстру несе користувач.

Для видалення надбудови Adobe вручну виконайте такі дії:
  1. Натисніть кнопку Пуск, виберіть команду Виконати, введіть regedit та натисніть кнопку OK.
  2. Знайдіть і клацніть такий підрозділ реєстру:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin
  3. У меню Файл виберіть Експорт, введіть ім'я файлу та виберіть команду Зберегти.
  4. Клацніть правою кнопкою миші параметр реєстру PDFMaker.OfficeAddin і в контекстному меню виберіть команду Видалити.
  5. Виконайте дії 3 та 4, щоб видалити параметри реєстру, що відповідають надбудові, в таких підрозділах реєстру:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook
  6. Закрийте редактор реєстру.

ДОДАТКОВІ ВІДОМОСТІ


За промовчанням програма Word використовує глобальний шаблон (файл Normal.dotm у Word 2007, файл Normal.dot у Word 2003 та раніших версіях Word). Зміни, застосовувані до всіх нових документів, за промовчанням зберігаються у глобальному шаблоні. Якщо під час збереження змін ви вкажете інший шаблон, цього не відбувається. Acrobat 7.0 може перешкодити застосунку Word автоматично зберігати зміни у глобальному шаблоні.

Докладніше про цю проблему див. на веб-сайті Adobe: