An Office for Mac file that contains text opens as a blank file

Symptoms

Text does not appear when you open a file that should contain text in one of the following Microsoft Office for Mac applications:
  • Microsoft Word for Mac
  • Microsoft Excel for Mac
  • Microsoft PowerPoint for Mac

Cause

This issue can occur for one of the following reasons:
  • A font file is damaged.
  • A font is not available in the application.

Resolution

Step 1: Change the font in the Office for Mac file

  1. Open the Word document, Excel workbook, or the PowerPoint presentation.
  2. For Word or PowerPoint, on the Edit menu, click Select All. For Excel, click the box above the first row of cells to select all cells.
  3. Select a different font.
If you can now see the text, there is a problem with the original font. If you want to display the text by using the original font, go to step 2.

Step 2: Disable the fonts in the Fonts folder

  1. Create a folder on your desktop, and name it "Disabled User Fonts."
  2. On the Go menu, click Home.
  3. Open Library.
    Note The Library folder is hidden in Mac OS X Lion. To display this folder, hold down the OPTION key while you click the Go menu.

  4. Open Fonts.
  5. On the Edit menu, click Select All.
  6. Drag the contents of the Fonts folder to the "Disabled User Fonts" folder you created on the desktop.
  7. On the Apple menu, click Restart.
  8. Open the Office for Mac file.
If the problem continues to occur, go to "Step 3: Check for bad fonts."

If the problem is resolved, go to the "Isolating fonts in a font folder" section.

Isolating fonts in a font folder

This process involves testing half of your data and then the other half to see which half contains the data that is causing problems. As soon as you find a set of fonts that does not cause the problem, set aside that set of fonts. Repeat the process with the set of fonts that contains the data that is causing the problem by splitting that set in half and then testing again. Repeat the process again until you have isolated the font that is causing the problem.
  1. After you disable all fonts by using one of the previous methods, and after you confirm that the issue that you are troubleshooting no longer recurs, re-enable half of the fonts.
  2. Try to perform the action that previously produced the problem. In this case, start the application, access the font menu, and so on. Then, take one of the following actions:
    • If the problem does not recur, disable these fonts by moving them to a new folder that you created on the desktop and named "Tested Good Fonts," and then re-enable the other half of the fonts. Repeat step 2.
    • If the problem recurs, disable half of the currently enabled fonts.


Step 3: Check for bad fonts

  1. Use Font Book to resolve duplicates and to validate fonts:
    1. Quit all applications.
    2. On the Go menu, select Applications.
    3. Open Font Book.
    4. Click the first font.
    5. On the Edit menu, click Select All.
    6. On the Edit menu, click Look for Duplicates.
    7. If duplicate fonts are found, click Resolve Automatically.
    8. Select all fonts again. On the File menu, click Validate Fonts.
    9. Disable any fonts that have a red X next to them.
    10. On the Apple menu, click Restart.
  2. Count the number of fonts installed in the following folders:
    • Macintosh HD/System Folder/Fonts
    • Macintosh HD/System/Library/Fonts

     There should be no more than 255 fonts in these folders. If there are more, contact Apple support.
  3. A bad font in Classic can cause a problem with any application and even with the OS, not just with Office for Mac. OSX checks several locations for fonts. One of those locations is fonts in OS9. OSX performs this check whether Classic is running or not.


Step 4: Create a new Mac user profile

After you create a new Mac user, you have a complete, fresh set of preferences, and all other related files will be freshly generated. To create a new Mac user profile, follow these steps:
  1. Quit all open applications.
  2. On the Apple menu, click System Preferences.
  3. Under System, click Users & Groups or Accounts depending on your OS version.
  4. Click the lock to make changes.
  5. Click the plus sign [+].
  6. For the name, short name, password, and verify password, use the word "test."
  7. Make sure that this user can administer the computer.
  8. Click Create User and close the window.
  9. On the Apple menu, log out you user account, and then log on to the test user account.
  10. Test the file.
Note You can move files from one user account to another user account when you move the files to the Shared folder on your system. You can find the Shared folder here:
Macintosh HD / Users / Shared
The Shared folder can be accessed from both user accounts. Move a copy of your files into this folder as your original user. Then, log on to your new Mac user, access the Shared folder, and then drag the files to a location in your new Mac user. (For example, you can drag the files to the desktop.) Do not leave these files in the Shared folder.

If there is still a problem in the new Mac user profile, the font problem is related to the System Font folder or to the hard disk font folder (or to the Office 2004 fonts folder if Microsoft Office 2004 for Mac is installed on the system). In this case, view the Troubleshoot All Users Library Fonts Folder section. You must contact Apple Support to troubleshoot the System fonts.

Troubleshoot All Users Library Fonts Folder

  1. Create a folder on your desktop that is named "Disabled Fonts."
  2. On the Go menu, click Computer.
  3. Double-click your hard disk icon. The default name will be Macintosh HD.
  4. Open Library, and then open Fonts.
  5. On the Edit menu, click Select All.
  6. Drag the contents of the Fonts folder to the "Disabled Fonts" folder on the desktop.
  7. On the Apple menu, click Restart.
  8. Open the Office for Mac file, and check whether text is displayed.
If the problem is resolved, disable 50% of your fonts and compare the results. Continue this process for the half that reproduces the problem. For more information, see the "Isolating fonts in a font folder" subsection in Step 2.

If the problem continues to occur, contact Apple support as the font issue is likely related to the system fonts.
Thuộc tính

ID Bài viết: 2434675 - Xem lại Lần cuối: 16-11-2011 - Bản sửa đổi: 1

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