Bỏ qua để tới nội dung chính
Đăng nhập với Microsoft
Đăng nhập hoặc tạo một tài khoản.
Xin chào,
Chọn một tài khoản khác.
Bạn có nhiều tài khoản
Chọn tài khoản bạn muốn đăng nhập.
Tiếng Anh
Chúng tôi rất tiếc. Bài viết này không có bằng ngôn ngữ của bạn.

This article also applies to the following:

  • Microsoft .NET Framework 3.5

Summary

Customers who run .NET Framework applications that rely on Transport Layer Security (TLS) 1.2, such as Intuit QuickBooks Desktop, may experience connectivity failures after they upgrade their system to a newer version of Windows.

Symptoms

Consider the following scenario:

In this scenario, you observe connectivity failures after the upgrade. The failures may include, but are not limited to, the following exception message and inner exception message:

System.Net.Http.HttpRequestException: An error occurred while sending the request.

System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)

Cause

This problem occurs because the SchUseStrongCrypto flag is not preserved throughout the Windows upgrade process.

Workaround

To work around this problem, use one of the following methods.

Workaround 1

Re-enable TLS 1.2 support as a machine-wide default protocol by setting the SchUseStrongCryptoregistry key flag that has a DWORD value of 1, as follows:

HKEY_LOCAL_MACHINE\SOFTWARE\[Wow6432Node\]Microsoft\.NETFramework\<VERSION>: SchUseStrongCrypto

Note You must add "[Wow6432Node\]" if the application runs as a 32-bit process on a 64-bit operating system, and set <VERSION> to either v4.0.30319 (for .NET Framework 4 and later versions) or v2.0.50727 (for .NET Framework 3.5).

Workaround 2

Enable TLS 1.2 support for your particular application (not machine-wide) by using an AppContext switch in the "<runtime>" section of your config file, as follows:

<runtime>

<AppContextSwitchOverrides value="Switch.System.Net.DontEnableSchUseStrongCrypto=false" />

</runtime>

Note By using this switch, you you can avoid this problem from recurring in future Windows upgrades because the setting will be correctly persisted.

Status

Microsoft has now resolved this issue for some devices. An update is available on Microsoft’s Update Catalog as of August 16, 2018 for those customers who have Intuit QuickBooks installed.

These customers may also check for updates on Windows Update by going to Settings > Update & Security > Windows Update and selecting Check for updates.

For devices that do not have Intuit QuickBooks installed and who are experiencing this issue:  Microsoft is working on a resolution and will provide an update in an upcoming release. 

 

Bạn cần thêm trợ giúp?

Bạn muốn xem các tùy chọn khác?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Thông tin này có hữu ích không?

Điều gì ảnh hưởng đến trải nghiệm của bạn?
Khi nhấn gửi, phản hồi của bạn sẽ được sử dụng để cải thiện các sản phẩm và dịch vụ của Microsoft. Người quản trị CNTT của bạn sẽ có thể thu thập dữ liệu này. Điều khoản về quyền riêng tư.

Cảm ơn phản hồi của bạn!

×