Bạn hiện đang ngoại tuyến, hãy chờ internet để kết nối lại

Thông báo lỗi khi bạn sử dụng Trình tạo DVD của Windows để tạo DVD: "Chuỗi Lớp Không hợp lệ"

Triệu chứng
Khi bạn cố gắng tạo DVD bằng cách sử dụng Trình tạo DVD của Windows trong Windows 7, bạn nhận được thông báo lỗi giống như sau: 

Chuỗi Lớp Không hợp lệ
Nguyên nhân
Vấn đề này có thể xảy ra vì một số khoá đăng ký đã bị hỏng trong quá trình cài đặt các trình điều khiển DirectShow.

Gần như tất cả các ứng dụng phương tiện đều cài đặt trình điều khiển DirectShow riêng của chúng. Vì có nhiều gói trình điều khiển sẵn có trên Internet, có thể xảy ra trường hợp một số khoá đăng ký bị hỏng trong quá trình cài đặt trình điều khiển.
Giải pháp
Quan trọng Phần, phương pháp hoặc tác vụ này chứa các bước chỉ dẫn bạn cách sửa đổi sổ đăng ký. Tuy nhiên, có thể xảy ra sự cố nghiêm trọng nếu bạn sửa đổi sổ đăng ký không đúng cách. Do đó, hãy chắc chắn rằng bạn thực hiện các bước sau cẩn thận. Để bảo vệ tốt hơn, hãy sao lưu sổ đăng ký trước khi bạn sửa đổi. Sau đó, bạn có thể khôi phục sổ đăng ký nếu xảy ra sự cố. Để biết thêm thông tin về cách sao lưu và khôi phục sổ đăng ký, hãy bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:
322756 Cách sao lưu và khôi phục sổ đăng ký trong Windows
Để khắc phục sự cố này, sử dụng một trong các phương pháp sau đây:

Phương pháp 1: Xoá hai khoá đăng ký

  1. Bấm Bắt đầu rồi gõ cmd vào hộp tìm kiếm.


  2. Bấm chuột phải vào cmd rồi bấm vào Chạy với tư cách quản trị viên.



  3. Trong dấu nhắc lệnh, hãy gõ các lệnh sau. Nhấn Enter sau mỗi lệnh.

    reg DELETE "HKEY_CLASSES_ROOT\CLSID\{083863F1-70DE-11D0-BD40-00A0C911CE86}\Instance\" /v "{79D28B7F-A6BD-49EF-8CEA-EA0E7791589E}" /f

    reg DELETE "HKEY_CLASSES_ROOT\CLSID\{083863F1-70DE-11D0-BD40-00A0C911CE86}\Instance\" /v "{138130AF-A79B-45D5-B4AA-87697457BA87}" /f

  4. Nếu bạn nhận được thông báo lỗi cho biết rằng khoá không tồn tại, hãy sử dụng phương pháp sau.

Phương pháp 2: Khôi phục Hệ thống của Người dùng

  1. Bấm vào Bắt đầu, gõ khôi phục hệ thống vào hộp tìm kiếm rồi nhấn Enter.



  2. Trong hộp thoại Khôi phục các tệp và thiết đặt hệ thống, bấm Tiếp theo.



  3. Chọn điểm khôi phục đã được tạo trước khi cài đặt gói trình điều khiển đã gây ra lỗi sau đó bấm Tiếp theo.



    Chú ý Nếu bạn muốn chọn điểm khôi phục khác, bấm để chọn hộp kiểm Hiển thị các điểm khôi phục khác.
  4. Trong hộp thoại Xác nhận điểm khôi phục của bạn, bấm Hoàn tất.



  5. Sau khi hệ thống đã được khôi phục, tải xuống gói trình điều khiển khác, sau đó cố gắng tạo lại DVD bằng cách sử dụng Trình tạo DVD của Windows.
Thông tin thêm
Để biết thêm thông tin về cách gỡ rối lỗi này, truy cập vào website Diễn đàn Microsoft Answers: 
Thuộc tính

ID Bài viết: 2619822 - Xem lại Lần cuối: 06/02/2014 07:39:00 - Bản sửa đổi: 1.1

  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • kbstepbystep kbhowto kbtshoot kbprb KB2619822
Phản hồi