Bạn nhận được một lỗi script và không thể in từ Internet Explorer 9

QUAN TRỌNG: Bài viết này được dịch bằng phần mềm dịch máy của Microsoft chứ không phải do con người dịch. Microsoft cung cấp các bài viết do con người dịch và cả các bài viết do máy dịch để bạn có thể truy cập vào tất cả các bài viết trong Cơ sở Kiến thức của chúng tôi bằng ngôn ngữ của bạn. Tuy nhiên, bài viết do máy dịch không phải lúc nào cũng hoàn hảo. Loại bài viết này có thể chứa các sai sót về từ vựng, cú pháp hoặc ngữ pháp, giống như một người nước ngoài có thể mắc sai sót khi nói ngôn ngữ của bạn. Microsoft không chịu trách nhiệm về bất kỳ sự thiếu chính xác, sai sót hoặc thiệt hại nào do việc dịch sai nội dung hoặc do hoạt động sử dụng của khách hàng gây ra. Microsoft cũng thường xuyên cập nhật phần mềm dịch máy này.

Nhấp chuột vào đây để xem bản tiếng Anh của bài viết này: 2652062
Tóm tắt
Bạn có thể nhận được một lỗi kịch bản tương tự sau khi cố gắng in một web site từ Internet Explorer 9.

Lưu ý: Số dòng có thể khác nhau.

Lỗi đã xảy ra trong script trên Trang này.
Dòng: 2053
Char: 1
Lỗi: Các cuộc gọi thủ tục không hợp lệ hay tranh luận.
Mã: 0
URL: res/ieframe.dll/preview.js.

Nếu bạn có vấn đề in trong Internet Explorer và không nhận được một lỗi script, xem Không thể để in hoặc xem qua in ấn của một web site trong Internet Explorer.
Nguyên nhân
Bạn có thể nhận được lỗi này nếu trình trình điều khiển máy in là lỗi thời, không tương hợp về sau, hoặc bị hỏng. Để sửa lỗi này, hãy làm theo các bước trong phần giải pháp dưới đây.
Giải pháp
Để khắc phục điều này, tải về và cài đặt chuyên biệt các trình điều khiển mới nhất cho máy in của bạn. Có ba cách để tìm và cài đặt chuyên biệt trình trình điều khiển máy in mới nhất. Sử dụng các bước dưới đây Bắt đầu với bước đầu tiên. Nếu bước mà không làm việc, đi bước tiếp theo.

Ngắt kết nối, và sau đó kết nối máy in của bạn để PC của bạn

  1. Rút phích cắm cáp USB của máy in từ máy tính của bạn.
    Lưu ý:Máy in không dây, tắt máy in.
  2. Mở thiết bị và máy in bằng cách nhấp vào các Bắt đầu nút chọn một Hình ảnh của nút chọn một Bắt đầu, và sau đó, trên menu Bắt Đầu, nhấp vào Thiết bị và máy in.
  3. Bấm chuột phải vào biểu tượng máy in của bạn và chọn Loại bỏ thiết bị.
  4. Kết nối máy in của bạn với máy PC bằng cáp USB.
    Lưu ý: Máy in không dây, bạn cần tham khảo thông tin đi kèm với máy in hướng dẫn cài đặt chuyên biệt.
Nếu ngắt kết nối, và tái kết nối máy in của bạn không giải quyết vấn đề, tiếp tục bước tiếp theo.

Cập nhật các trình trình điều khiển máy in bằng cách sử dụng Windows Update

Bạn có thể cần phải Cài đặt Windows Update để tự động tải xuống và cài đặt chuyên biệt bản Cập Nhật được khuyến cáo. cài đặt chuyên biệt bất kỳ bản Cập Nhật quan trọng, được đề nghị, và tùy chọn có thể cập nhật tính năng hệ thống và phần mềm khác mà có thể giúp đỡ để sửa chữa vấn đề máy in của bạn. Để cập nhật trình trình điều khiển máy in mới nhất cho máy in của bạn bằng cách sử dụng Windows Update, nhấp vào liên kết cụ thể cho các phiên bản Windows của bạn và làm theo các bước trong các bài viết:

Tìm và cài đặt chuyên biệt trình trình điều khiển máy in trong Windows 7

Tìm và cài đặt chuyên biệt trình trình điều khiển máy in trong Windows Vista

Nếu Cập Nhật trình điều khiển máy in của bạn bằng cách sử dụng Windows Update đã không giải quyết vấn đề, tiếp tục bước tiếp theo.

Cập Nhật trình trình điều khiển máy in của bạn từ các nhà sản xuất thiết bị

Nếu máy in của bạn đi kèm với một đĩa, đĩa đó có thể chứa phần mềm cài đặt chuyên biệt một trình điều khiển cho máy in của bạn. Nếu máy in của bạn đã không đi kèm với phần mềm, nó có thể là cần thiết để đi đến web site của nhà sản xuất để xác định vị trí, tải về và cài đặt chuyên biệt trình trình điều khiển máy in mới nhất cho máy in của bạn.
Cách giải quyết khác
Nếu tất cả các phương pháp trong phần "Giải quyết" vẫn không thể giải quyết vấn đề, hãy thử phương pháp workaround sau đây.

Phương pháp 1 in bằng cách sử dụng Internet Explorer 9 (32 bit) thay vì Internet Explorer 9(64bit)

  1. Bấm vào các Bắt đầu nút chọn một Hình ảnh của nút chọn một Bắt đầu, loại Internet Explorer trong các Tìm chương trình và các tập tin, và sau đó chọn Internet Explorer.
  2. Cố gắng in một lần nữa.

Phương pháp 2 in sử dụng chạy như administator cho Internet Explorer

  1. Bấm vào các Bắt đầu nút chọn một Hình ảnh của nút chọn một Bắt đầu, loại Internet Explorer trong các Tìm chương trình và các tập tin.
  2. Bấm chuột phải Internet ExplorerChương trình và nhấp vào Chạy như quản trị viên.
  3. Cố gắng in một lần nữa.

Thông tin thêm
Cho thông tin về làm thế nào để khắc phục sự cố các lỗi kịch bản trong Internet Explorer, xemLàm thế nào để khắc phục sự cố script lỗi trong Internet Explorer trên máy tính dựa trên Windows

Cảnh báo: Bài viết này được dịch tự động

Thuộc tính

ID Bài viết: 2652062 - Xem lại Lần cuối: 10/04/2012 22:52:00 - Bản sửa đổi: 3.0

Windows Internet Explorer 9

  • kbcip kbmt KB2652062 KbMtvi
Phản hồi