Bỏ qua để tới nội dung chính
Đăng nhập với Microsoft
Đăng nhập hoặc tạo một tài khoản.
Xin chào,
Chọn một tài khoản khác.
Bạn có nhiều tài khoản
Chọn tài khoản bạn muốn đăng nhập.
Tiếng Anh
Chúng tôi rất tiếc. Bài viết này không có bằng ngôn ngữ của bạn.

Symptoms

In the Japanese version of Microsoft Forefront Threat Management Gateway (TMG) 2010, when you use the Alert mail function to send an email message to the administrator, you may receive an Alert email message in which the Japanese characters in the subject line are not readable.

For example, you may receive an Alert email message from Forefront Threat Management Gateway to the Simple Mail Transfer Protocol (SMTP) server whose subject line resembles one of the following:

Subject: Microsoft Forefront TMG - è¦å‘Šãƒ†ã‚¹ãƒˆ メール

Subject: Microsoft Forefront TMG - ??????????????? ????????

Cause

This problem occurs because the encoding format for specifying the character set is not included in the subject header of the Forefront TMG Alert email message.

The raw Japanese characters are written in the "Subject:" header. An affected email client cannot detect the correct character set when the client displays the subject line. This results in unreadable, non-Japanese characters.

Resolution

To resolve this issue, follow these steps:

  1. Install the hotfix package that is described in the following article in the Microsoft Knowledge Base. (Or, install a more recent service pack if one is available.)

    2649961 Rollup 1 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2

  2. Copy the following text into a file that is named Enable265591.vbs: 

    Set objCurrentArray = CreateObject("FPC.Root").GetContainingArray



    objCurrentArray.MailCodePage = 130537



    objCurrentArray.Save
  3. Run the Enable265591.vbs script in an elevated command prompt on any TMG stand-alone or array member. You have to run the script one time for each array.

You do not have to restart the computer. The setting becomes effective shortly after you run the script, as with any other array configuration change.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Bạn cần thêm trợ giúp?

Bạn muốn xem các tùy chọn khác?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Thông tin này có hữu ích không?

Điều gì ảnh hưởng đến trải nghiệm của bạn?
Khi nhấn gửi, phản hồi của bạn sẽ được sử dụng để cải thiện các sản phẩm và dịch vụ của Microsoft. Người quản trị CNTT của bạn sẽ có thể thu thập dữ liệu này. Điều khoản về quyền riêng tư.

Cảm ơn phản hồi của bạn!

×