Chuột có thể không phản hồi sau khi bạn khởi động ứng dụng App-V

QUAN TRỌNG: Bài viết này được dịch bằng phần mềm dịch thuật của Microsoft và có thể được Cộng đồng Microsoft chỉnh sửa lại thông qua công nghệ CTF thay vì một biên dịch viên chuyên nghiệp. Microsoft cung cấp các bài viết được cả biên dịch viên và phần mềm dịch thuật thực hiện và cộng đồng chỉnh sửa lại để bạn có thể truy cập vào tất cả các bài viết trong Cơ sở Kiến thức của chúng tôi bằng nhiều ngôn ngữ Tuy nhiên, bài viết do máy dịch hoặc thậm chí cộng đồng chỉnh sửa sau không phải lúc nào cũng hoàn hảo. Các bài viết này có thể chứa các sai sót về từ vựng, cú pháp hoặc ngữ pháp, Microsoft không chịu trách nhiệm về bất kỳ sự thiếu chính xác, sai sót hoặc thiệt hại nào do việc dịch sai nội dung hoặc do hoạt động sử dụng của khách hàng gây ra.

Nhấp chuột vào đây để xem bản tiếng Anh của bài viết này: 2987845
Triệu chứng
Khi bạn khởi động một quy trình được ảo ảo hoá ứng dụng của Microsoft phiên bản 4.5, phiên bản 4.6 hoặc phiên bản 5 (App-V 4.5, App-V 4.6 App-V 5.0) trên thiết bị hỗ trợ màn hình cảm ứng, con trỏ chuột có thể không đáp ứng. Khi bạn thoát khỏi quá trình wisptis.exe hoặc trình điều khiển App-V, chuột Bắt đầu làm việc lại. Điều này cũng ảnh hưởng đến máy chủ đầu cuối RDS/nếu kinh nghiệm màn hình được kích hoạt (tức là, nếu máy chủ mặc định cài đặt chuyên biệt không được kích hoạt).
Nguyên nhân
Trong một số trường hợp, App-V tạo ra một phiên bản thứ hai của quá trình wisptis.exe như là một phần của khởi động ứng dụng. Điều này có thể tạo ra xung đột giữa trình wisptis.exe đang chạy (vì hệ thống là màn hình cảm ứng) và quy trình wisptis.exe mới đã được kích hoạt bằng cách khởi động ứng dụng. Bởi thoát trình wisptis.exe hoặc trình điều khiển App-V, bạn loại bỏ xung đột.
Giải pháp

Tùy chọn 1: Giải pháp tự động

Để khắc phục sự cố này tự động, cài đặt chuyên biệt bản Cập Nhật Khuôn khổ .NET hotfix mới nhất. Khi bạn thực hiện việc này, cài đặt chuyên biệt kiểm nhập ObjExclusion là không cần thiết.

Lưu ý: Đây là giải pháp được khuyến nghị.

cài đặt chuyên biệt hotfix rollup này từ Hotfix rollup 3026376 (gián tuyến cài đặt) cho Khuôn khổ .NET 4.5, 4.5.1 và 4.5.2 Windows Vista SP2, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2008 SP2, Windows Server 2008 R2 SP1, Windows Server 2012 và Windows Server 2012 R2.

Tuỳ chọn 2: Trình hướng dẫn sử dụng

Để tự khắc phục sự cố này, tạo khoá kiểm nhập sau trên máy tính khách.

App-V 5.0:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Subsystem\ObjExclusions

App-V 4.6:

x 86 hệ thống

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\SystemGuard\ObjExclusions

x 64 Hệ thống

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\SystemGuard\ObjExclusions
Loại: Reg_SZ
Tên: WPFMouseAndTouchInput
Giá trị: {773F1B9A-35B9-4E95-83A0-A210F2DE3B37}-running

Thông tin thêm
Để biết thêm thông tin, hãy xem Ứng dụng-V: trên tên lõi đối tượng ảo (còn gọi là con VObjects).

APP-V, ứng dụng ảo hóa, 5.0, Wisptis.exe appv 5, điều này áp dụng cho 4.6 cũng

Cảnh báo: Bài viết này được dịch tự động

Thuộc tính

ID Bài viết: 2987845 - Xem lại Lần cuối: 03/19/2015 21:25:00 - Bản sửa đổi: 2.0

Microsoft Application Virtualization 5.0 for Windows Desktops, Microsoft Application Virtualization 5.0 for Windows Desktops Service Pack 1, Microsoft Application Virtualization 5.0 for Windows Desktops Service Pack 2

  • kbmt KB2987845 KbMtvi
Phản hồi