Cấu hình không được Cập Nhật và ID sự kiện 29181 được ghi lại trong System Center Operations Manager

QUAN TRỌNG: Bài viết này được dịch bằng phần mềm dịch thuật của Microsoft và có thể được Cộng đồng Microsoft chỉnh sửa lại thông qua công nghệ CTF thay vì một biên dịch viên chuyên nghiệp. Microsoft cung cấp các bài viết được cả biên dịch viên và phần mềm dịch thuật thực hiện và cộng đồng chỉnh sửa lại để bạn có thể truy cập vào tất cả các bài viết trong Cơ sở Kiến thức của chúng tôi bằng nhiều ngôn ngữ Tuy nhiên, bài viết do máy dịch hoặc thậm chí cộng đồng chỉnh sửa sau không phải lúc nào cũng hoàn hảo. Các bài viết này có thể chứa các sai sót về từ vựng, cú pháp hoặc ngữ pháp, Microsoft không chịu trách nhiệm về bất kỳ sự thiếu chính xác, sai sót hoặc thiệt hại nào do việc dịch sai nội dung hoặc do hoạt động sử dụng của khách hàng gây ra.

Nhấp chuột vào đây để xem bản tiếng Anh của bài viết này: 3092452
Triệu chứng
Trong một môi trường Microsoft System Center có nhiều khách hàng, thay đổi cấu hình không được Cập Nhật trên máy chủ quản lý. Ngoài ra, các sự kiện liên tục được ghi vào Nhật ký Operations Manager:


Tên đăng nhập: Operations Manager
Nguồn: OpsMgr quản lý cấu hình
ID sự kiện: 29181
Mức: lỗi
Người dùng: K/C
Máy tính: <server></server>

Mô tả: OpsMgr quản lý cấu hình bản ghi dịch vụ không thể thực hiện 'SnapshotSynchronization' kiếm mục công việc do exceptionMicrosoft.EnterpriseManagement.ManagementConfiguration.DataAccessLayer.DataAccessException sau: ảnh chụp truyền dữ liệu hoạt động không bó ghi.

Nguyên nhân
Sự cố này xảy ra khi các bản ghi dịch vụ quản lý cấu hình không thành công do chuyển Phiên bản không thể thực hiện một số lượng lớn chèn. Vấn đề này thường xảy ra khi môi trường có nhiều khách hàng, chẳng hạn như 2000 trở lên.
Giải pháp
Để khắc phục sự cố này, hãy làm theo các bước sau để sửa đổi thiết đặt kích thước lô cho bản ghi dịch vụ quản lý cấu hình trên máy chủ quản lý:
  1. Thực hiện sao lưu của chương trình Files\System Trung tâm 2012\Operations Manager\Server\ConfigService.Config.
  2. Chỉnh sửa tệp ConfigService.config và sau đó thay đổi các thiết đặt như sau:
    <Setting Name="SnapshotSyncManagedEntityBatchSize" Value="10000" /><Setting Name="SnapshotSyncRelationshipBatchSize" Value="10000" /><Setting Name="SnapshotSyncTypedManagedEntityBatchSize" Value="20000" />
  3. Khởi động bản ghi dịch vụ cấu hình.
Thông tin thêm
Để xác định xem bạn đang gặp phải sự cố này, hãy chạy truy vấn SQL sau đây đối với bộ máy cơ sở dữ liệu OperationsManager:
select * from cs.WorkItem where workitemname like '%snapshot%' order by StartedDateTimeUtc desc
Trong trường hợp được mô tả trong phần "Triệu chứng",workitemstateid luôn có 10 (thất bại) thay vì 20 (thành công).

Cảnh báo: Bài viết này được dịch tự động

Thuộc tính

ID Bài viết: 3092452 - Xem lại Lần cuối: 11/02/2015 07:05:00 - Bản sửa đổi: 1.0

Microsoft System Center 2012 Operations Manager Service Pack 1, Microsoft System Center 2012 R2 Operations Manager

  • kbexpertiseadvanced kbsurveytest kbtshoot kbmt KB3092452 KbMtvi
Phản hồi