Triệu chứng
Khi bạn cố gắng cài đặt một ứng dụng từ System Center 2012 Configuration Manager Company Portal một thiết bị, quá trình cài đặt không thành công. Sự cố này xảy ra nếu người quản trị site đã cố gắng phân phối lại ứng dụng cho một Manage.Microsoft.com phân phối hoặc đã cố gắng làm mới nội dung.
Lỗi tương tự như sau được ghi lại trong tệp outgoingcontentmanager.log trên máy chủ site:
Tải SAS trên gói Intune XXX011D6 Intune Id {guid}/file_name
LỖI: Không thể tải vị trí SAS cho package_id
do lỗi trống: Không thể tải lên ngoại lệ trong GetSasUrl cho gói package_id: System.InvalidOperationException - Không thể tải lên vì kết quả trống.
Nguyên nhân
Sự cố này xảy ra vì cấu phần trình quản lý nội dung đi tải lên nội dung đã tải lên bằng cách sử dụng cùng một giá trị SHA đã được tính toán trước đó dựa trên tên tệp. Trong trường hợp này, việc phân phối lại không thành công. Quy trình phân phối lại cũng loại bỏ dữ liệu khỏi bảng Nội dung MDM trong cơ sở dữ liệu site Configuration Manager và sao chép thao tác xóa Microsoft Intune.
Giải pháp
Sau khi bản cập nhật nóng này được cài đặt, các ứng dụng đang ở trạng thái Thử lại sẽ tự động cập nhật Manage.Microsoft.com điểm phân phối. Các ứng dụng hiển thị sự cố chuyển phát nội dung có thể được cập nhật bằng cách chọn Cập nhật Nội dung trên tab Loại Triển khai của các thuộc tính ứng dụng.
Thông tin cập nhật nóng
Hotfix được hỗ trợ có sẵn từ Bộ phận Hỗ trợ của Microsoft. Tuy nhiên, hotfix này là nhằm sửa chữa chỉ vấn đề được mô tả trong bài viết này. Áp dụng hotfix này chỉ cho hệ thống đang gặp vấn đề mô tả trong bài viết này. Hotfix này có thể nhận được kiểm tra bổ sung. Do đó, nếu bạn không bị ảnh hưởng nghiêm trọng bởi sự cố này, chúng tôi khuyên bạn nên đợi bản cập nhật phần mềm tiếp theo có chứa cập nhật nóng này.
Nếu bản cập nhật nóng có sẵn để tải xuống thì có mục "Tải xuống bản cập nhật nóng sẵn dùng" ở đầu bài viết Cơ sở Kiến thức này. Nếu phần này không xuất hiện, hãy liên hệ với bộ phận Dịch vụ và Hỗ trợ Khách hàng của Microsoft để nhận hotfix.
Lưu ý Nếu có sự cố khác xảy ra hoặc nếu cần khắc phục sự cố bất kỳ, bạn có thể phải tạo một yêu cầu dịch vụ riêng biệt. Chi phí hỗ trợ thông thường sẽ áp dụng cho các câu hỏi và sự cố hỗ trợ bổ sung không đủ điều kiện cho hotfix cụ thể này. Để có danh sách đầy đủ các số điện thoại của Bộ phận Dịch vụ Khách hàng và Hỗ trợ của Microsoft hoặc để tạo yêu cầu dịch vụ riêng, hãy truy cập trang web sau của Microsoft:
http://support.microsoft.com/contactus/?ws=supportLưu ý Biểu mẫu "Tải xuống cập nhật nóng" hiển thị các ngôn ngữ mà hotfix có sẵn. Nếu bạn không thấy ngôn ngữ của mình, đó là vì bản cập nhật nóng không có sẵn cho ngôn ngữ đó.
Điều kiện tiên quyết
Để áp dụng bản cập nhật nóng này, bạn phải cài đặt Bản cập nhật Tích lũy 2 cho System Center 2012 Configuration Manager Gói Dịch vụ 2 và Trung tâm Hệ thống 2012 R2 Configuration Manager Gói Dịch vụ 1.
Thông tin về khởi động lại
Bạn không phải khởi động lại máy tính sau khi áp dụng hotfix này.
Thông tin thay thế hotfix
Hotfix này không thay thế bất kỳ hotfix đã phát hành trước đó.
Phiên bản tiếng Anh của hotfix này có các thuộc tính tệp (hoặc các thuộc tính tệp mới hơn) được liệt kê trong bảng sau đây. Ngày và giờ của các tệp này được liệt kê theo Giờ chuẩn quốc tế (UTC). Khi bạn xem thông tin về tệp, tệp đó đã được chuyển đổi thành giờ địa phương. Để tìm ra sự khác biệt giữa UTC và giờ địa phương, hãy dùng tab Múi giờ trong mục Ngày và Giờ trong Panel điều khiển.
Tên tệp |
Phiên bản tệp |
Kích thước tệp |
Ngày |
Giờ |
Nền |
---|---|---|---|---|---|
Microsoft.configurationmanager.intunecontentmanager.dll |
5.0.8239.1308 |
81,072 |
Ngày 5 tháng 10 năm 2015 |
01:40 |
x86 |
Trạng thái
Microsoft đã xác nhận đây là sự cố trong các sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".
Tham khảo
Tìm hiểu về thuật ngữ mà Microsoft sử dụng để mô tả các bản cập nhật phần mềm.