Bạn hiện đang ngoại tuyến, hãy chờ internet để kết nối lại

Tuỳ chỉnh hình nền máy tính để bàn có thể không được hiển thị sau khi Windows Welcome xong

QUAN TRỌNG: Bài viết này được dịch bằng phần mềm dịch máy của Microsoft chứ không phải do con người dịch. Microsoft cung cấp các bài viết do con người dịch và cả các bài viết do máy dịch để bạn có thể truy cập vào tất cả các bài viết trong Cơ sở Kiến thức của chúng tôi bằng ngôn ngữ của bạn. Tuy nhiên, bài viết do máy dịch không phải lúc nào cũng hoàn hảo. Loại bài viết này có thể chứa các sai sót về từ vựng, cú pháp hoặc ngữ pháp, giống như một người nước ngoài có thể mắc sai sót khi nói ngôn ngữ của bạn. Microsoft không chịu trách nhiệm về bất kỳ sự thiếu chính xác, sai sót hoặc thiệt hại nào do việc dịch sai nội dung hoặc do hoạt động sử dụng của khách hàng gây ra. Microsoft cũng thường xuyên cập nhật phần mềm dịch máy này.

Nhấp chuột vào đây để xem bản tiếng Anh của bài viết này:329677
TRIỆU CHỨNG
Sau khi người dùng đã xem Windows chào (còn được biết đến như là "ra khỏi hộp Experience" hoặc OOBE), người dùng có thể không thấy các Tùy biến OEM desktop wallpaper nền. Người dùng có thể xem chỉ là một đồng bằng máy tính để bàn với các biểu tượng hiển thị.

Chú ý Vấn đề này xảy ra trên Windows XP như sau:
  • Vấn đề này xảy ra trên Windows XP Home Edition chỉ khi các tùy chỉnh phông nền nền là một tập tin JPEG (.jpg). Bitmap tệp bitmap hình nền (.bmp) không gây ra vấn đề này.
  • Vấn đề này nào không xảy ra trên Windows XP Professional Edition vì sự chuyển đổi ảnh bitmap được lưu trữ trong thư mục hồ sơ của người quản trị. Thư mục này không phải là xóa bỏ bởi Windows Welcome.
NGUYÊN NHÂN
Khi các hình nền máy tính để bàn là tùy chỉnh, và nếu một JPEG tập tin được sử dụng, các hệ điều hành chuyển đổi tập tin vào một tệp bitmap (.bmp), và sau đó cửa hàng bitmap file trong thư mục hồ sơ người dùng hiện thời. Các phông nền tập tin luôn luôn được đặt tên Wallpaper1.bmp.

Trong chế độ kiểm toán của Windows XP Home Edition, tập tin được lưu trữ trong vị trí sau:
% SystemDrive %\Documents và Settings\Owner\Local Settings\Application Data\Microsoft
Trong thời gian Windows chào đón (OOBE), nội dung của chủ sở hữu bản gốc thư mục hồ sơ được tuyên truyền để thư mục hồ sơ chủ sở hữu mới được thành lập, và bản gốc chủ sở hữu tài khoản và hồ sơ thư mục sẽ bị xóa. Điều này là do thiết kế. Tuy nhiên, vì cơ quan đăng ký vẫn trỏ đến chủ sở hữu bản gốc thư mục hồ sơ không còn tồn tại, các hình nền là không hiển thị.
GIẢI PHÁP
Quan trọng Phần, phương pháp hoặc nhiệm vụ này chứa các bước cho bạn biết làm thế nào để sửa đổi registry. Tuy nhiên, vấn đề nghiêm trọng có thể xảy ra nếu bạn sửa đổi registry không chính xác. Vì vậy, hãy chắc chắn rằng bạn làm theo các bước sau một cách cẩn thận. Để bảo vệ được thêm vào, sao lưu sổ đăng ký trước khi bạn sửa đổi nó. Sau đó, bạn có thể khôi phục sổ đăng ký nếu một vấn đề xảy ra. Để biết thêm chi tiết về làm thế nào để sao lưu và khôi phục sổ đăng ký, hãy nhấp vào số bài viết sau đây để xem bài viết trong cơ sở kiến thức Microsoft:
322756 Cách sao lưu và lưu trữ sổ đăng kư trong Windows

Để làm việc xung quanh vấn đề này, sử dụng một trong các cách sau phương pháp để sửa đổi đăng ký:
  • Phương pháp 1: Sử dụng ký biên soạn.
  • Cách 2: Sử dụng một tập tin cơ quan đăng ký (được liệt kê sau này trong điều này phần).

Phương pháp 1: Sử dụng ký biên soạn

Sau khi bạn áp dụng các hình nền mà bạn muốn trong chế độ kiểm toán, và trước khi bạn chạy Sysprep.exe trong chế độ reseal, sửa đổi registry sau giá trị:
  1. Bắt đầu Registry Editor (Regedit.exe).
  2. Xác định vị trí và sau đó bấm các Phông nền giá trị dưới khóa sau trong registry:
    HKEY_CURRENT_USER\Control Panel\Desktop
  3. Trên các Chỉnh sửa trình đơn, nhấp vàoSửa đổi, loại sau đây, và sau đó nhấp vàoOk:
    % USERPROFILE %\Local Settings\Application Data\Microsoft\Wallpaper1.BMP
  4. Xác định vị trí và sau đó bấm cácOriginalWallpaper giá trị theo phím sau đây trong các đăng ký:
    HKEY_CURRENT_USER\Control Panel\Desktop
  5. Trên các Chỉnh sửa trình đơn, nhấp vàoSửa đổi, loại sau đây, và sau đó nhấp vàoOk:
    % USERPROFILE %\Local Settings\Application Data\Microsoft\Wallpaper1.BMP
  6. Thoát khỏi Registry Edit.

    Bạn có thể bây giờ chạy Syspre.exe Reseal chế độ.

Cách 2: Sử dụng một tập tin Registry

Ngoài ra, bạn có thể cập nhật sổ đăng ký bằng cách sử dụng sau đây Registry file:

Phiên bản Windows Registry Editor 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]"Wallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp""OriginalWallpaper"="%USERPROFILE%\\Local Settings\\Application Data\\Microsoft\\Wallpaper1.bmp"
Chú ý Lưu các tập tin đăng ký là Fixwall.reg. Bằng cách sử dụng các % USERPROFILE % biến môi trường trong registry mục, bạn làm cho nó có thể cho các hệ điều hành để xác định vị trí các tập tin bằng cách đánh giá các thay đổi và sau đó cung cấp đường dẫn thư mục hồ sơ chính xác của phông nền tệp bitmap.

Các tập tin đăng ký có thể được chuyển nhập mà không có người sử dụng sự can thiệp từ một tập tin thực thi bằng cách sử dụng cú pháp sau đây (giả định rằng các đăng ký tập tin trong phần này được lưu dưới dạng Fixwall.reg):
regedit/s fixwall.reg
TÌNH TRẠNG
Microsoft đã xác nhận rằng đây là một lỗi trong các sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".
THÔNG TIN THÊM

Các bước để tạo lại hành vi

  1. Cài đặt Microsoft Windows XP Home Edition bằng cách sử dụng Kit Preinstallation OEM (OPK). Sau khi cài đặt xong, hệ thống đang ở chế độ kiểm toán (hộp thoại công cụ chuẩn bị hệ thống có xuất hiện trong góc trên bên phải của màn hình).
  2. Thay đổi hình nền máy tính để bàn. Phông nền bạn chọn phải có một tập tin JPEG (.jpg).
  3. Sử dụng công cụ để chuẩn bị hệ thống Resealnút để chuẩn bị hệ thống và chạy Windows Welcome (OOBE) sau khi rằng máy tính bắt đầu.
  4. Bắt đầu máy tính, và sau đó làm theo chỉ dẫn trong các Thuật sĩ Windows chào đón (OOBE).

    Sau khi đã hoàn tất thuật sĩ, các máy tính để bàn xuất hiện. Tuy nhiên, hình nền đã chọn không hiển thị được.
OPK XP NHÀ SP1 SP2 SYSPREP

Cảnh báo: Bài viết này được dịch tự động

Thuộc tính

ID Bài viết: 329677 - Xem lại Lần cuối: 09/23/2011 03:08:00 - Bản sửa đổi: 3.0

  • kbbug kbfix kbmt KB329677 KbMtvi
Phản hồi