Bạn nhận được thông báo lỗi "Thao tác đã không được thực hiện trên socket" khi cố kết nối mạng

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Bài viết này đã được lưu trữ. Bài viết được cung cấp "nguyên trạng" và sẽ không còn được cập nhật nữa.
TRIỆU CHỨNG
Khi bạn cố kết nối máy tính vào mạng, bạn có thể nhận được thông báo lỗi sau đây:
Thao tác đã không được thực hiện trên socket.
Hiện tượng này xảy ra trên máy tính có chứa địa chỉ IP từ một máy chủ có Giao thức Cấu hình Thiết bị Động (DHCP). Nếu bạn gán một địa chỉ IP tĩnh cho máy tính của mình, bạn sẽ không nhận được thông báo này.
NGUYÊN NHÂN
Vấn đề này có thể xảy ra nếu bạn đã cài đặt sản phẩm của bên thứ ba có sử dụng Windows sockets và cũng sử dụng các lệnh ipconfig, release và renew. Các khóa con sổ đăng ký của Windows sockets có thể bị hỏng.
GIẢI PHÁP
Quan trọng Phần phương pháp hoặc tác vụ này chứa các bước chỉ dẫn cách sửa đổi sổ đăng ký cho bạn. Tuy nhiên, có thể xảy ra sự cố nghiêm trọng nếu bạn sửa đổi sổ đăng ký không đúng cách. Vì vậy, hãy chắc chắn rằng bạn thực hiện các bước sau cẩn thận. Để bảo vệ tốt hơn, hãy sao lưu sổ đăng ký trước khi sửa đổi. Sau đó, bạn có thể khôi phục sổ đăng ký nếu xảy ra sự cố. Để biết thêm thông tin về cách sao lưu và khôi phục sổ đăng ký, bấm vào số bài viết sau đây để xem bài viết trong Cơ sở Kiến thức Microsoft:
322756 Cách sao lưu và khôi phục sổ đăng ký trong Windows (Bài viết này có thể chứa liên kết tới nội dung tiếng Anh (chưa được dịch)).
Để giải quyết sự cố này, sử dụng một trong các phương pháp sau.

Phương pháp 1

Chúng tôi khuyên bạn nên sử dụng Phương pháp 1 nếu một trong các điều kiện sau đây đúng:
  • Bạn chỉ có một máy tính.
  • Bạn không có quyền truy nhập vào máy tính giống máy tính đầu tiên mà bạn đã gặp hiện tượng được mô tả trong phần "Hiện tượng" Máy tính giống máy tính đầu tiên là một máy tính khác có cùng phiên bản hệ điều hành và có cấu hình phần cứng tương tự.
Sử dụng Registry Editor để xuất chuyển và xóa các khóa con đăng ký Winsock và Winsock2, sau đó loại bỏ và cài đặt lại TCP/IP trên Microsoft Windows 2000 hoặc Microsoft Windows XP. Để thực hiện việc này, làm theo các bước sau.

Xuất chuyển và xóa các khóa con đăng ký đã hỏng

  1. Cho đĩa mềm vào trong ổ đĩa mềm của máy tính có các mục đăng ký mà bạn đang xuất chuyển.
  2. Bấm Bắt đầu, bấm Chạy, gõ regedit, sau đó bấm OK.
  3. Định vị rồi bấm khoá con đăng ký sau:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
  4. Thực hiện một trong các bước sau, tùy thuộc vào hệ điều hành:
    • Đối với Windows XP, trên menu Tệp, bấm Xuất chuyển.
    • Đối với Windows 2000, trên menu Sổ đăng ký, bấm Xuất chuyển.
  5. Trong ô Lưu vào, bấm 3½ Đĩa mềm (A:), gõ tên cho tệp trong ô Tên tệp, sau đó bấm Lưu.
  6. Bấm chuột phải Winsock, sau đó bấm Xóa. Khi bạn được nhắc xác nhận xoá, bấm Có.
  7. Lặp lại các bước từ 3 tới 6 cho khóa con sau đây:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock2
    Chú ý Mỗi tệp .reg bạn lưu phải có tên khác nhau.
  8. Bấm chuột phải Winsock2, bấm Xóa, sau đó bấm Có.
  9. Thoát khỏi Registry Editor.

Máy tính chạy Windows 2000

Loại bỏ TCP/IP trên một máy tính chạy Windows 2000
  1. Đăng nhập vào Windows với tư cách là quản trị viên.
  2. Trong Pa-nen Điều khiển, bấm đúp Kết nối Mạng, bấm chuột phải vào Kết nối Mạng Cục bộ, sau đó bấm Thuộc tính.
  3. Bên dưới Cấu phần này sử dụng các khoản mục sau, bấm Giao thức Internet (TCP/IP), rồi bấm Dỡ cài đặt.
  4. Làm theo các chỉ dẫn trên màn hình để loại bỏ TCP/IP.
  5. Khởi động lại máy tính của bạn, nhưng bấm Không nếu bạn được nhắc để Windows kích hoạt giao thức.
Cài đặt TCP/IP trên máy tính chạy Windows 2000
  1. Đăng nhập vào Windows với tư cách là quản trị viên.
  2. Trong Pa-nen Điều khiển, bấm đúp Kết nối Mạng, bấm chuột phải vào Kết nối Mạng Cục bộ, sau đó bấm Thuộc tính.
  3. Bấm Cài đặt.
  4. Trong hộp thoại Lựa chọn Loại Cấu phần Mạng, bấm Giao thức, sau đó bấm Thêm.
  5. Bên dưới Giao thức Mạng, bấm Giao thức Internet (TCP/IP), sau đó bấm OK.
  6. Khi giao thức được cài đặt, bấm Đóng.
  7. Khởi động lại máy tính của bạn.

Máy tính chạy Windows XP

Cài đặt lại TCP/IP trên máy tính chạy Windows XP
Trong Windows XP, ngăn xếp TCP/IP là cấu phần lõi của hệ điều hành. Vì vậy, bạn không thể loại bỏ TCP/IP trong Windows XP.
  1. Trước hết phải cài đặt TCP/IP. Để thực hiện việc này, làm theo các bước sau:
    1. Trong Pa-nen Điều khiển, bấm đúp Kết nối Mạng, bấm chuột phải vào Kết nối Mạng Cục bộ, rồi bấm Thuộc tính.
    2. Bấm Cài đặt.
    3. Bấm Giao thức, rồi bấm Thêm.
    4. Bấm Có Đĩa.
    5. Trong ô Sao các tệp của nhà sản xuất từ, gõ System_Drive_Letter:\windows\inf, rồi bấm OK.
    6. Trong danh sách các giao thức có sẵn, bấm Giao thức Internet (TCP/IP), rồi bấm OK.
  2. Khởi động lại máy tính của bạn.

Phương pháp 2

Nếu bạn đang sửa sự cố này trên một số máy tính và bạn có quyền truy nhập vào một máy tính đang hoạt động có cùng phiên bản hệ điều hành và có cấu hình phần cứng tương tự, chúng tôi khuyến nghị dùng Phương pháp 2.

Để giải quyết vấn đề này, xóa các mục trong sổ đăng ký bị hỏng, rồi thay thế chúng bằng thông tin khóa sổ đăng ký bạn đã xuất chuyển từ máy tính có cài đặt TCP/IP đang hoạt động. Để thực hiện việc này, làm theo các bước sau.

Xóa các mục trong sổ đăng ký bị hỏng

Trên máy tính có các mục trong sổ đăng ký bị hỏng, làm theo các bước sau:
  1. Bấm Bắt đầu, bấm Chạy, gõ regedit, sau đó bấm OK.
  2. Trong Registry Editor, định vị và bấm khóa con đăng ký sau:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
    .
  3. Bấm chuột phải vào Winsock, sau đó bấm Xóa. Khi bạn được nhắc xác nhận xoá, bấm Có.
  4. Bấm chuột phải vào Winsock 2, sau đó bấm Xóa. Khi bạn được nhắc xác nhận xoá, bấm Có.

Xuất chuyển các mục trong sổ đăng ký ra đĩa mềm

Trên máy tính có cài đặt TCP/IP hoạt động, làm theo các bước sau.

Chú ý Máy tính mà bạn đang chuyển nhập các mục trong sổ đăng ký phải sử dụng cùng phiên bản Windows và phải giống hoặc là bản sao của máy tính đang gặp phải hiện tượng được mô tả trong phần "Hiện tượng".
  1. Đưa đĩa mềm vào trong ổ đĩa mềm của máy tính có các mục trong sổ đăng ký mà bạn đang xuất chuyển.
  2. Bấm Bắt đầu, bấm Chạy, gõ regedit, sau đó bấm OK.
  3. Trong Registry Editor, định vị và bấm khóa con đăng ký sau, rồi bấm Winsock:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
  4. Bấm Tệp, rồi bấm Xuất chuyển.
  5. Trong ô Lưu vào, bấm 3½ Đĩa mềm (A:), gõ tên cho tệp đó trong ô Tên tệp, sau đó bấm Lưu.
  6. Bấm Winsock2, bấm Tệp, sau đó bấm Xuất chuyển.
  7. Trong ô Lưu vào, bấm 3½ Đĩa mềm (A:), gõ tên cho tệp đó trong ô Tên tệp, sau đó bấm Lưu.

    Chú ý Mỗi tệp .reg bạn lưu phải có một tên khác nhau.
  8. Thoát khỏi Registry Editor.

Chuyển nhập các mục trong sổ đăng ký từ đĩa mềm

Trên máy tính có mục trong sổ đăng ký bị hỏng, hãy làm theo các bước sau:
  1. Đưa đĩa mềm có chứa các tệp .reg vào ổ đĩa mềm của máy tính đang gặp phải hiện tượng được mô tả trong phần "Hiện tượng".
  2. Khởi động Windows Explorer, bấm Máy tính của Tôi, sau đó bấm đúp 3½ Đĩa mềm (A:).
  3. Bấm đúp vào mỗi tệp .reg mà bạn đã tạo và lưu vào đĩa mềm trong phần "Xuất chuyển các khóa đăng ký ra đĩa mềm".
  4. Bấm Có khi được nhắc thêm thông tin vào sổ đăng ký.
  5. Bấm OK khi nhận được thông báo rằng thông tin được nhập thành công vào sổ đăng ký.
  6. Thoát khỏi Registry Editor.
  7. Khởi động lại máy tính bị ảnh hưởng.
THÔNG TIN THÊM
Các phương pháp này khôi phục chức năng cơ bản cho các khóa con Winsock và Winsock2. Bạn có thể phải cài đặt lại một số phần mềm proxy hoặc tường lửa của bên thứ ba.
Lỗi Winsock, TCP/IP, socket
Thuộc tính

ID Bài viết: 817571 - Xem lại Lần cuối: 12/08/2015 02:23:59 - Bản sửa đổi: 8.5

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows 2000 Server

  • kbnosurvey kbarchive kberrmsg kbprb KB817571
Phản hồi