Lỗi truy cập vi phạm xảy ra nếu thông tin dịch vụ đầu cuối của bạn bị hỏng

Hỗ trợ cho Windows XP đã kết thúc

Microsoft đã kết thúc hỗ trợ dành cho Windows XP vào ngày 8 tháng 4 năm 2014. Thay đổi này đã ảnh hưởng đến các bản cập nhật phần mềm và tùy chọn bảo mật của bạn. Tìm hiểu ý nghĩa của điều này với bạn và cách thực hiện để luôn được bảo vệ.

Hỗ trợ cho Windows Server 2003 đã kết thúc vào ngày 14 tháng 7 năm 2015

Microsoft đã kết thúc hỗ trợ cho Windows Server 2003 vào ngày 14 tháng 7 năm 2015. Thay đổi này đã ảnh hưởng đến các bản cập nhật phần mềm và tùy chọn bảo mật của bạn. Tìm hiểu ý nghĩa của điều này với bạn và cách thực hiện để luôn được bảo vệ.

QUAN TRỌNG: Bài viết này được dịch bằng phần mềm dịch máy của Microsoft chứ không phải do con người dịch. Microsoft cung cấp các bài viết do con người dịch và cả các bài viết do máy dịch để bạn có thể truy cập vào tất cả các bài viết trong Cơ sở Kiến thức của chúng tôi bằng ngôn ngữ của bạn. Tuy nhiên, bài viết do máy dịch không phải lúc nào cũng hoàn hảo. Loại bài viết này có thể chứa các sai sót về từ vựng, cú pháp hoặc ngữ pháp, giống như một người nước ngoài có thể mắc sai sót khi nói ngôn ngữ của bạn. Microsoft không chịu trách nhiệm về bất kỳ sự thiếu chính xác, sai sót hoặc thiệt hại nào do việc dịch sai nội dung hoặc do hoạt động sử dụng của khách hàng gây ra. Microsoft cũng thường xuyên cập nhật phần mềm dịch máy này.

Nhấp chuột vào đây để xem bản tiếng Anh của bài viết này:828664
TRIỆU CHỨNG
Khi bạn chạy một tiện ích quản trị dịch vụ đầu cuối, chẳng hạn như Tsprof.exe, Mmc.exe hoặc Usrmgr.exe, các tiện ích có thể tạo ra một lỗi vi phạm truy cập và bỏ bất ngờ khi nó quản lý tài khoản người dùng nhất định.

Khi bạn chạy bất kỳ chương trình nào có sử dụng các chức năng API của WTSSetUserConfig hoặc WTSQueryUserConfig để đặt hoặc để lấy thông tin người dùng, các tiện ích có thể tạo ra lỗi hành vi vi phạm quyền truy cập và bỏ bất ngờ khi nó quản lý tài khoản người dùng nhất định.

Khi bạn kết nối Remote Desktop và sau đó thử đăng nhập với một trương mục người dùng nhất định, kết nối máy tính từ xa có thể đột nhiên đóng. Nếu đăng nhập từ xa máy tính để bàn dựa trên cố gắng đổi sang máy tính dựa trên Microsoft Windows XP hoặc với một máy tính dựa trên Microsoft Windows Server 2003 giao diện điều khiển, máy tính để bàn từ xa sẽ thực hiện một bugcheck sau khi trình bất ngờ quits. Tùy thuộc vào cấu hình, máy tính để bàn từ xa có thể khởi động lại.

Một hoặc nhiều của các sự kiện sau đây có thể được ghi vào sổ ghi sự kiện:

Tổ chức sự kiện ID 1004
Lỗi ứng dụng mã nguồn
Báo cáo đã xếp hàng lỗi: faulting ứng dụng mmc.exe, phiên bản 5.2.3790.0, faulting module tsuserex.dll, phiên bản 5.2.3790.0, lỗi địa chỉ 0x0000c3a9.

Tổ chức sự kiện ID 1004
Lỗi ứng dụng mã nguồn
Báo cáo đã xếp hàng lỗi: faulting ứng dụng mmc.exe, phiên bản 5.2.3790.0, faulting module tsuserex.dll, phiên bản 5.2.3790.0, lỗi địa chỉ 0x0000c3a9.

Tổ chức sự kiện ID 1004
Lỗi ứng dụng mã nguồn
Báo cáo đã xếp hàng lỗi: faulting ứng dụng mmc.exe, phiên bản 5.2.3790.0, faulting module tsuserex.dll, phiên bản 5.2.3790.0, lỗi địa chỉ 0x0000c3a9.

Tổ chức sự kiện ID 1004
Lỗi ứng dụng mã nguồn
Faulting ứng dụng, phiên bản 0.0.0.0, faulting module regapi.dll, phiên bản 5.2.3790.0, lỗi địa chỉ 0x00002c4d.

Tổ chức sự kiện ID 1004
Lỗi ứng dụng mã nguồn
Báo cáo đã xếp hàng lỗi: faulting ứng dụng winlogon.exe, phiên bản 0.0.0.0, faulting module regapi.dll, phiên bản 5.2.3790.0, lỗi địa chỉ 0x00002c4d.

Tổ chức sự kiện ID 1001
Lỗi ứng dụng mã nguồn
Lỗi nhóm 62739595.

Tổ chức sự kiện ID 1001
Lỗi ứng dụng mã nguồn
Lỗi nhóm 45054588

NGUYÊN NHÂN
Vấn đề này có thể xảy ra khi bị hỏng dữ liệu người dùng là gặp phải.
GIẢI PHÁP

Thông tin hotfix Windows Server 2003

Hotfix được hỗ trợ đang được Microsoft cung cấp. Tuy nhiên, hotfix này là nhằm khắc phục chỉ sự cố được mô tả trong bài viết này. Hotfix này chỉ áp dụng cho hệ thống đang gặp vấn đề cụ thể này. Hotfix này có thể nhận được thử nghiệm bổ sung. Vì vậy, nếu bạn không bị ảnh hưởng bởi vấn đề này, chúng tôi đề nghị bạn đợi cho Cập Nhật tiếp theo của phần mềm có chứa hotfix này.

Nếu hotfix này sẵn có để tải xuống, có phần "Tải xuống hotfix sẵn có" ở đầu bài viết trong Cơ sở Kiến thức này. Nếu phần này không xuất hiện, liên hệ với Phòng Hỗ Trợ và Dịch vụ Khách hàng của Microsoft để lấy hotfix này.

Chú ý Nếu vấn đề khác xảy ra hoặc nếu bất cứ xử lý sự cố là cần thiết, bạn có thể phải tạo một yêu cầu dịch vụ riêng biệt. Các chi phí hỗ trợ thông thường sẽ áp dụng để hỗ trợ thêm câu hỏi và vấn đề này không đủ điều kiện cho hotfix này cụ thể. Đối với một danh sách đầy đủ của Microsoft dịch vụ khách hàng và hỗ trợ số điện thoại hoặc để tạo ra một yêu cầu dịch vụ riêng biệt, ghé thăm Web site sau của Microsoft: Chú ý Các hình thức "Hotfix download available" hiển thị các ngôn ngữ mà các hotfix có sẵn. Nếu bạn không thấy ngôn ngữ của mình thì đó là do hotfix này hiện không có ngôn ngữ đó.

Thông tin về tệp

Phiên bản tiếng Anh của hotfix này có các thuộc tính tệp (hoặc sau này tập tin thuộc tính) mà được liệt kê trong bảng sau. Ngày và giờ của những tệp này được liệt kê theo giờ chuẩn quốc tế (UTC). Khi bạn xem chi tieát taäp tin, nó được chuyển đổi thành giờ cục bộ. Để biết sự khác nhau giữa UTC và local time, sử dụng các Múi giờ thẻ công cụ ngày và giờ trong Pa-nen điều khiển.

Windows Server 2003, phiên bản 32-bit

   Date         Time   Version            Size    File name   -----------------------------------------------------------   19-Aug-2004  23:41  5.2.3790.202       50,176  Regapi.dll   19-Aug-2004  23:41  5.2.3790.202       81,920  Tsuserex.dll

Windows Server 2003, phiên bản 64-bit

   Date         Time   Version            Size    File name     Platform   ---------------------------------------------------------------------   19-Aug-2004  21:37  5.2.3790.202      129,536  Regapi.dll     IA-64   19-Aug-2004  21:37  5.2.3790.202      223,744  Tsuserex.dll   IA-64   19-Aug-2004  21:41  5.2.3790.202       50,176  Wregapi.dll    x86   19-Aug-2004  21:41  5.2.3790.202       81,920  Wtsuserex.dll  x86

Thông tin gói dịch vụ Windows XP

Để giải quyết vấn đề này, có được gói dịch vụ mới nhất cho Windows XP. Để biết thêm thông tin, bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:
322389 Cách lấy gói dịch vụ Windows XP mới nhất

Thông tin hotfix Windows XP

Hotfix được hỗ trợ đang được Microsoft cung cấp. Tuy nhiên, hotfix này là nhằm khắc phục chỉ sự cố được mô tả trong bài viết này. Hotfix này chỉ áp dụng cho hệ thống đang gặp vấn đề cụ thể này. Hotfix này có thể nhận được thử nghiệm bổ sung. Vì vậy, nếu bạn không bị ảnh hưởng bởi vấn đề này, chúng tôi đề nghị bạn đợi cho Cập Nhật tiếp theo của phần mềm có chứa hotfix này.

Nếu hotfix này sẵn có để tải xuống, có phần "Tải xuống hotfix sẵn có" ở đầu bài viết trong Cơ sở Kiến thức này. Nếu phần này không xuất hiện, liên hệ với Phòng Hỗ Trợ và Dịch vụ Khách hàng của Microsoft để lấy hotfix này.

Chú ý Nếu vấn đề khác xảy ra hoặc nếu bất cứ xử lý sự cố là cần thiết, bạn có thể phải tạo một yêu cầu dịch vụ riêng biệt. Các chi phí hỗ trợ thông thường sẽ áp dụng để hỗ trợ thêm câu hỏi và vấn đề này không đủ điều kiện cho hotfix này cụ thể. Đối với một danh sách đầy đủ của Microsoft dịch vụ khách hàng và hỗ trợ số điện thoại hoặc để tạo ra một yêu cầu dịch vụ riêng biệt, ghé thăm Web site sau của Microsoft: Chú ý Các hình thức "Hotfix download available" hiển thị các ngôn ngữ mà các hotfix có sẵn. Nếu bạn không thấy ngôn ngữ của mình thì đó là do hotfix này hiện không có ngôn ngữ đó.

Thông tin về tệp

Phiên bản tiếng Anh của hotfix này có các thuộc tính tệp (hoặc sau này tập tin thuộc tính) mà được liệt kê trong bảng sau. Ngày và giờ của những tệp này được liệt kê theo giờ chuẩn quốc tế (UTC). Khi bạn xem chi tieát taäp tin, nó được chuyển đổi thành giờ cục bộ. Để biết sự khác nhau giữa UTC và local time, sử dụng các Múi giờ thẻ công cụ ngày và giờ trong Pa-nen điều khiển.

Windows XP, phiên bản 32-bit

   Date         Time   Version            Size    File name   --------------------------------------------------------------   10-Sep-2003  18:30  5.1.2600.1254      32,768  Cfgbkend.dll   10-Sep-2003  18:30  5.1.2600.1254      30,720  Pchsvc.dll   10-Sep-2003  18:30  5.1.2600.1254      33,280  Racpldlg.dll   10-Sep-2003  18:30  5.1.2600.1267      44,544  Regapi.dll   10-Sep-2003  18:30  5.1.2600.1254      41,472  Safrslv.dll   02-Aug-2003  07:45  5.1.2600.1254     129,536  Sessmgr.exe   10-Sep-2003  18:30  5.1.2600.1254     200,192  Termsrv.dll   10-Sep-2003  18:30  5.1.2600.1254      88,064  Tscfgwmi.dll

Windows XP, phiên bản 64-bit

   Date         Time   Version            Size    File name     Platform   ----------------------------------------------------------------------   10-Sep-2003  17:38  5.1.2600.1254     104,448  Cfgbkend.dll  IA-64   10-Sep-2003  17:38  5.1.2600.1254     110,080  Pchsvc.dll    IA-64   10-Sep-2003  17:38  5.1.2600.1254      90,112  Racpldlg.dll  IA-64   10-Sep-2003  17:38  5.1.2600.1267     127,488  Regapi.dll    IA-64   10-Sep-2003  17:38  5.1.2600.1254     111,616  Safrslv.dll   IA-64   02-Aug-2003  08:44  5.1.2600.1254     419,328  Sessmgr.exe   IA-64   10-Sep-2003  17:38  5.1.2600.1254     622,592  Termsrv.dll   IA-64   10-Sep-2003  17:38  5.1.2600.1254     326,144  Tscfgwmi.dll  IA-64   10-Sep-2003  18:30  5.1.2600.1267      44,544  Wregapi.dll   x86

Windows 2000

Hotfix được hỗ trợ đang được Microsoft cung cấp. Tuy nhiên, hotfix này là nhằm khắc phục chỉ sự cố được mô tả trong bài viết này. Hotfix này chỉ áp dụng cho hệ thống đang gặp vấn đề cụ thể này. Hotfix này có thể nhận được thử nghiệm bổ sung. Vì vậy, nếu bạn không bị ảnh hưởng bởi vấn đề này, chúng tôi đề nghị bạn đợi cho Cập Nhật tiếp theo của phần mềm có chứa hotfix này.

Nếu hotfix này sẵn có để tải xuống, có phần "Tải xuống hotfix sẵn có" ở đầu bài viết trong Cơ sở Kiến thức này. Nếu phần này không xuất hiện, liên hệ với Phòng Hỗ Trợ và Dịch vụ Khách hàng của Microsoft để lấy hotfix này.

Chú ý Nếu vấn đề khác xảy ra hoặc nếu bất cứ xử lý sự cố là cần thiết, bạn có thể phải tạo một yêu cầu dịch vụ riêng biệt. Các chi phí hỗ trợ thông thường sẽ áp dụng để hỗ trợ thêm câu hỏi và vấn đề này không đủ điều kiện cho hotfix này cụ thể. Đối với một danh sách đầy đủ của Microsoft dịch vụ khách hàng và hỗ trợ số điện thoại hoặc để tạo ra một yêu cầu dịch vụ riêng biệt, ghé thăm Web site sau của Microsoft: Chú ý Các hình thức "Hotfix download available" hiển thị các ngôn ngữ mà các hotfix có sẵn. Nếu bạn không thấy ngôn ngữ của mình thì đó là do hotfix này hiện không có ngôn ngữ đó.

Thông tin về tệp

Phiên bản tiếng Anh của hotfix này có các thuộc tính tệp (hoặc sau này tập tin thuộc tính) mà được liệt kê trong bảng sau. Ngày và giờ của những tệp này được liệt kê theo giờ chuẩn quốc tế (UTC). Khi bạn xem chi tieát taäp tin, nó được chuyển đổi thành giờ cục bộ. Để biết sự khác nhau giữa UTC và local time, sử dụng các Múi giờ thẻ công cụ ngày và giờ trong Pa-nen điều khiển.
   Date         Time   Version        Size    File name   ------------------------------------------------------   07-Jan-2004  20:44  5.0.2195.6889  36,624  Regapi.dll
TÌNH TRẠNG
Microsoft đã xác nhận rằng đây là một vấn đề trong các sản phẩm của Microsoft được liệt kê trong phần "Áp dụng cho".

Windows XP

Lỗi này được sửa lần đầu tiên trong Microsoft Windows XP Gói dịch vụ số 2.
THÔNG TIN THÊM
Hotfix được mô tả trong bài viết này không sửa các dữ liệu bị hỏng. Các hotfix bảo vệ các mã gây ra quá trình để thoát khỏi bất ngờ với một lỗi vi phạm truy cập.

Sau khi bạn áp dụng hotfix này, bạn có thể đăng nhập vào một Windows 2000 dựa trên hoặc một máy tính dựa trên Windows XP bằng cách sử dụng máy tính để bàn từ xa mà không có lỗi. Tuy nhiên, bạn vẫn có thể nhận được một thông báo lỗi khi bạn thay đổi các thuộc tính của tài khoản người dùng hoặc khi bạn đăng nhập bằng cách sử dụng tài khoản đó.

Nếu bạn sử dụng Microsoft Management Console (MMC) để chỉnh sửa hoặc xem thuộc tính người dùng, bạn có thể nhận được một thông báo lỗi tương tự như dưới đây:
Tính chất dịch vụ thiết bị đầu cuối
Không thể nạp tài sản dịch vụ đầu cuối cho người dùng này vì: các tham số không đúng.
Hoặc, khi bạn cố gắng đăng nhập vào một máy tính Windows Server 2003 dựa trên bằng cách sử dụng một kết nối từ xa máy tính để bàn, bạn có thể nhận được một thông báo lỗi tương tự như dưới đây:
Thông báo đăng nhập
Hệ thống có thể không đăng nhập bạn vào nhờ các lỗi sau:Các tham số không chính xác.
Hãy thử lại hay hỏi người quản trị hệ thống của bạn
Để sửa dịch vụ đầu cuối người sử dụng dữ liệu tham nhũng, hãy làm theo các bước sau:
  1. Tạo một tập tin văn bản với những dòng văn bản, nơi tên người dùng là tên của trương mục người dùng với các thông tin bị hỏng và ở đâu tên miền là tên miền của bạn.
    DN: CN =tên người dùngCN = người dùng, DC =tên miềnDC = com
    changetype: sửa đổi
    Xoá: userParameters
  2. Tên tập tin "Users.txt."
  3. Tại dấu nhắc lệnh, gõ lệnh sau để chạy tập tin:
    Ldifde –I –f users.txt
    Chạy câu lệnh này cũng sẽ xóa thuộc tính và giải quyết sự cố trên một tên miền Active Directory.

    Chú ý Việc xoá các thuộc tính userParameters trong trương mục người dùng có thể ảnh hưởng đến các chương trình khác. Nếu chương trình cụ thể thông tin được lưu trữ có, nó sẽ phải được repopulated. Ví dụ, các chương trình có thể bị ảnh hưởng là FPNW, RAS và tất cả các dịch vụ thiết bị đầu cuối, cụ thể người sử dụng thông tin.
THAM KHẢO
Để biết thêm chi tiết về những thuật ngữ được sử dụng trong bài viết này, nhấp vào số bài viết sau đây để xem bài viết trong cơ sở kiến thức Microsoft:
824684 Mô tả thuật ngữ chuẩn được sử dụng để mô tả các bản cập nhật phần mềm của Microsoft
chấm dứt

Cảnh báo: Bài viết này được dịch tự động

Thuộc tính

ID Bài viết: 828664 - Xem lại Lần cuối: 08/30/2011 09:16:00 - Bản sửa đổi: 2.0

Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows XP Professional, Microsoft Windows 2000 Server

  • kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbmt KB828664 KbMtvi
Phản hồi