Bạn hiện đang ngoại tuyến, hãy chờ internet để kết nối lại

Khi bạn cố gắng cài đặt Gói Dịch vụ Windows XP, bạn sẽ nhận được thông báo lỗi "Truy cập bị từ chối" hoặc "Không hoàn thành cài đặt Gói Dịch vụ"

Hỗ trợ cho Windows XP đã kết thúc

Microsoft đã kết thúc hỗ trợ dành cho Windows XP vào ngày 8 tháng 4 năm 2014. Thay đổi này đã ảnh hưởng đến các bản cập nhật phần mềm và tùy chọn bảo mật của bạn. Tìm hiểu ý nghĩa của điều này với bạn và cách thực hiện để luôn được bảo vệ.

Triệu chứng
Khi bạn cài đặt Windows XP Gói Dịch vụ 2 (SP2) hoặc Gói Dịch vụ 3 (SP3), bạn có thể nhận được thông báo lỗi tương tự một trong các thông báo sau:
Lỗi thiết lập Gói Dịch vụ 3. Truy nhập bị từ chối
Lỗi thiết lập Gói Dịch vụ 3. Không hoàn thành cài đặt Gói Dịch vụ
Hoặc, tệp Svcpack.log có thể chứa thông báo lỗi sau:
DoRegistryUpdates failed
Nguyên nhân
Những lỗi này có thể xảy ra khi quyền cho một hoặc nhiều khoá đăng ký bị giới hạn ngăn gói dịch vụ không cập nhật các khoá. Các khoá đăng ký có thể bị giới hạn bởi một số chương trình nhất định. Những chương trình này thay đổi danh sách kiểm soát quyền truy cập hệ thống (SACL) trong Sổ đăng ký để các tài khoản quản trị viên không thể thay đổi chúng. Trình cài đặt gói dịch vụ chạy theo tài khoản quản trị viên (Người dùng) và do vậy, không thể truy cập các khoá đăng ký bị giới hạn. Nếu Gói Dịch vụ Windows XP không thể cập nhật khoá đăng ký vì bị giới hạn bởi chương trình khác thì việc cài đặt gói dịch vụ sẽ thất bại.

Để xác định việc cập nhật cho sổ đăng ký có thất bại không, hãy đi tới phần "Thông tin Bổ sung".
Giải pháp
Sử dụng các phương pháp khắc phục sau theo trình tự mà chúng được trình bày để giải quyết sự cố. Những phương pháp này dành cho người dùng có trình độ trung bình đến chuyên sâu.

Lưu ý Bạn phải đăng nhập vào Windows bằng tài khoản người dùng là quản trị viên máy tính để hoàn thành phương pháp này. Nếu đây là máy tính cá nhân của bạn thì bạn có thể được đăng nhập bằng tài khoản của quản trị viên. Nếu máy tính này là một phần của mạng ở cơ quan, bạn có thể phải nhờ quản trị viên hệ thống giúp đỡ. Để xác minh rằng bạn đã đăng nhập vào Windows bằng tài khoản người dùng là quản trị viên máy tính, hãy truy cập Web site sau của Microsoft:

Phương pháp 1: Khởi động lại máy tính rồi thử tải xuống và cài đặt Windows XP SP3 từ Trung tâm Tải xuống của Microsoft

Nếu một chương trình đang chạy với một tệp bị khoá, việc khởi động lại máy tính có thể khoá tệp. Để thử mở khoá tệp, hãy thoát tất cả chương trình và khởi động lại máy tính. Sau đó, thử lại tải xuống và cài đặt gói dịch vụ.

Nếu ban đầu bạn cố gắng cài đặt Windows XP SP3 qua Windows Update và thất bại, hãy tải xuống gói tải xuống Windows XP SP3 từ Trung tâm Tải xuống của Microsoft. Sau khi bạn tải xuống gói dịch vụ, hãy thử cài đặt.Để biết thêm thông tin về cách tải xuống Windows XP Gói Dịch vụ 3, bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:
322389 Cách lấy gói dịch vụ Windows XP mới nhất
Nếu phương pháp này khắc phục được thông báo lỗi và nếu bạn cài đặt thành công Windows XP SP3 thì bạn đã hoàn thành.

Để biết thêm thông tin về khôi phục cài đặt bảo mật mặc định cho Windows XP, hãy bấm vào số bài viết sau để xem bài viết trong Cơ sở Kiến thức của Microsoft:
313222 Làm cách nào để khôi phục thiết đặt bảo mật thành thiết đặt mặc định?


Nếu phương pháp này không khắc phục được sự cố, hãy chuyển sang phương pháp 2.

Phương pháp 2: Khởi động lại máy tính rồi đóng hoặc tắt bất kỳ chương trình chống vi rút hoặc phần mềm chống gián điệp nào đang chạy

Cảnh báo Cách này có thể khiến máy tính hoặc mạng dễ bị tấn công bởi những người dùng nguy hiểm hoặc bởi phần mềm nguy hiểm như vi-rút. Chúng tôi không khuyến nghị sử dụng cách này nhưng chúng tôi cung cấp thông tin này để bạn có thể áp dụng cách này theo lựa chọn riêng của bạn. Ban tự chịu rủi ro khi sử dụng cách này.

Bạn có thể giảm nguy cơ tấn công bởi người dùng hoặc phần mềm nguy hiểm bằng cách không truy cập các Web site khác hoặc tải xuống các tệp trong khi chương trình chống vi rút và phần mềm chống gián điệp đã bị đóng hoặc tắt.

Một trong các nguyên nhân phổ biến nhất của việc cài đặt thất bại là khi một chương trình của bên thứ ba như chương trình chống vi rút có chứa một tệp đang mở hoặc khoá một tệp mà trình cài đặt gói dịch vụ cần. Để ngăn sự cố này, hãy làm theo những bước sau trước khi bạn cài đặt Windows XP SP3:
  1. Thoát tất cả chương trình rồi khởi động lại máy tính.
  2. Sau khi bạn khởi động lại máy tính, đóng hoặc tắt các chương trình chống vi rút hoặc phần mềm chống gián điệp đang chạy.

    Lưu ý Bạn có thể tắt các chương trình từ khu vực thông báo. Để thực hiện việc này, bấm chuột phải vào biểu tượng chương trình của bên thứ ba rồi bấm vào một tuỳ chọn để đóng hoặc tắt ứng dụng. Nếu không có tuỳ chọn này, xem tài liệu về chương trình hoặc liên hệ với nhà sản xuất chương trình để biết hướng dẫn.
  3. Sau khi bạn đóng chương trình chống vi rút hoặc chương trình phần mềm chống gián điệp, cài đặt Windows XP SP3 từ gói tải xuống đầy đủ mà bạn đã tải xuống trong phương pháp 1.
  4. Sau khi hoàn thành cài đặt Windows XP SP3, khởi động lại chương trình chống vi rút hoặc chương trình chống phần mềm gián điệp mà bạn đã tắt ở bước 2.
Nếu phương pháp này khắc phục được thông báo lỗi và nếu bạn cài đặt thành công Windows XP SP3 thì bạn đã hoàn thành.

Nếu phương pháp này không giải quyết được sự cố và nếu bạn đồng ý thử các bước khắc phục sự cố nâng cao, đi tới phần "Khắc phục sự cố nâng cao”. Nếu bạn không hài lòng với các bước khắc phục sự cố nâng cao, đi tới phần "Các bước Tiếp theo”.
KHẮC PHỤC SỰ CỐ NÂNG CAO
Phần này bao gồm phương pháp khắc phục sự cố nâng cao để thử nếu các bước trong phần "Giải pháp” không hiệu quả. Phương pháp này chỉ dành cho người dùng chuyên sâu.

Đặt lại sổ đăng ký và quyền đối với tệp

Để chúng tôi đặt lại sổ đăng ký và quyền đối với tệp cho bạn, đi tới phần "Khắc phục sự cố cho tôi". Nếu bạn muốn tự bật Cập nhật Tự động, hãy chuyển tới phần "Để tôi tự khắc phục sự cố".


Khắc phục sự cố cho tôi

Để khắc phục tự động sự cố này, hãy bấm vào liên kết Khắc phục sự cố này. Sau đó bấm vào Chạy trong hộp thoại Tệp Tải xuống và thực hiện theo các bước trong thuật sỹ này.
Khắc phục sự cố này
Microsoft Fix it 50389

Chú ý Thuật sĩ này có thể chỉ có bằng tiếng Anh; tuy nhiên, khắc phục sự cố tự động cũng hoạt động đối với các phiên bản ngôn ngữ khác của Windows.

Chú ý Nếu bạn không sử dụng máy tính có sự cố, bạn có thể lưu giải pháp khắc phục sự cố tự động vào ổ đĩa flash hoặc CD rồi chạy trên máy tính có sự cố.

Để tôi tự khắc phục sự cố

Quan trọng Phần, phương pháp hoặc tác vụ này chứa các bước chỉ dẫn bạn cách sửa đổi sổ đăng ký. Tuy nhiên, có thể xảy ra sự cố nghiêm trọng nếu bạn sửa đổi sổ đăng ký không đúng cách. Do đó, hãy chắc chắn rằng bạn thực hiện các bước sau cẩn thận. Để bảo vệ tốt hơn, hãy sao lưu sổ đăng ký trước khi bạn sửa đổi. Sau đó, bạn có thể khôi phục sổ đăng ký nếu xảy ra sự cố. Để biết thêm thông tin về cách sao lưu và khôi phục sổ đăng ký, hãy bấm số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft:
322756 Cách sao lưu và khôi phục sổ đăng ký trong Windows
Để đặt lại sổ đăng ký và quyền đối với tệp, hãy làm theo các bước sau:
  1. Tải xuống rồi cài đặt tệp Subinacl.exe. Để thực hiện việc này, hãy ghé thăm web site sau của Microsoft:
  2. Khởi động Notepad.
  3. Sao chép rồi dán văn bản sau vào Notepad.
    cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    Microsoft chỉ cung cấp mô hình lập trình để minh hoạ mà không đảm bảo dưới bất kỳ hình thức nào dù có quy định rõ ràng hay ngụ ý. Điều này bao gồm nhưng không giới hạn trong các hình thức bảo hành đối với tính thương mại cũng như tính thích hợp cho một mục đích cụ thể. Bài viết này giả định rằng bạn đã quen với ngôn ngữ lập trình đang được giải thích, và công cụ được sử dụng để tạo và gỡ lỗi quy trình. Microsoft hỗ trợ các kỹ sư có thể giúp giải thích tính năng của một quy trình đặc biệt. Tuy nhiên, họ sẽ không sửa đổi những mô hình này để cung cấp tính năng được bổ sung hoặc xây dựng quy trình nhằm đáp ứng các yêu cầu cụ thể của bạn.
  4. Lưu tệp Notepad này dưới dạng Reset.cmd.
  5. Bấm đúp vào tệp Reset.cmd để chạy tập lệnh.

    Lưu ý Tệp tập lệnh này có thể mất nhiều thời gian mới chạy được. Bạn phải chạy tập lệnh này với tư cách là quản trị viên.
  6. Cài đặt Windows XP SP3.
Nếu phương pháp này khắc phục được thông báo lỗi và nếu bạn cài đặt thành công Windows XP SP3 thì bạn đã hoàn thành.

Nếu phương pháp này không giải quyết được sự cố, đi tới phần "Các bước Tiếp theo”.
Thông tin thêm

Cách xác định cập nhật sổ đăng ký có thất bại không

  1. Bấm Bắt đầu, bấm Chạy, gõ %windir%\svcpack.log rồi bấm OK. Tệp Svcpack.log mở ra.
  2. Trên menu Chỉnh sửa, bấm Tìm kiếm.
  3. Trong ô Tìm kiếm cái gì, gõ DoRegistryUpdates failed , rồi bấm Tìm kiếm Tiếp.

    Nếu cập nhật sổ nhật ký thất bại, thông báo lỗi "Cập nhật Sổ đăng ký Thất bại" sẽ hiển thị trong tệp. Điều này cho biết rằng sự cố đang ngăn cập nhật sổ đăng ký. Thông báo lỗi này giống như sau:
    xxxx.xxx: DoInstallation:DoRegistryUpdates failed.
    xxxx.xxx: Truy nhập bị từ chối
    xxxx.xxx: Thông báo được hiển thị cho người dùng: Truy nhập bị từ chối
    Lưu ý Trong thông báo này, xxxx.xxx thể hiện dấu thời gian của mỗi mục nhập.

Phần mềm chống vi-rút

Chương trình chống vi-rút được thiết kế nhằm giúp bảo vệ máy tính của bạn khỏi vi-rút. Bạn không được tải xuống hoặc mở tệp từ những nguồn mà bạn không tin cậy, ghé thăm các Web site mà bạn không tin cậy, hoặc mở e-mail có phần đính kèm khi chương trình chống vi-rút của bạn không được kích hoạt. Để có thêm thông tin về các vi-rút máy tính, bấm số bài viết sau để xem bài viết trong Cơ sở Kiến thức Microsoft.
129972 Vi-rút máy tính: mô tả, phòng tránh, và phục hồi
CÁC BƯỚC TIẾP THEO
Nếu các phương pháp này không hiệu quả với bạn, bạn có thể sử dụng Web site Dịch vụ Hỗ trợ Khách hàng của Microsoft để tìm các giải pháp khác cho sự cố của bạn. Một số dịch vụ mà các Web site Dịch vụ Hỗ trợ Khách hàng của Microsoft cung cấp gồm có: Nếu bạn vẫn gặp sự cố, bạn có thể muốn liên hệ với bộ phận Hỗ trợ:
winxpsp3 windowsxpsp3 fixit fix it
Thuộc tính

ID Bài viết: 949377 - Xem lại Lần cuối: 07/25/2013 12:15:00 - Bản sửa đổi: 6.0

  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Service Pack 2
  • kbexpertisebeginner kbregistry kberrmsg kbtshoot kbprb kbfixme kbmsifixme KB949377
Phản hồi